Jump to content

Recommended Posts

I have installed the latest CbB with hotfix and all of the old projects I tested seem to work correctly.

These include quite a lot of Soundtoys and Waves plugins which seem to work as they did in CbB v2020.11.

 

Share this post


Link to post
Share on other sites
On 1/24/2021 at 1:50 AM, msmcleod said:

@Heinz Hupfer - the only thing that has changed with Control Surfaces, is the way refresh rates of less than 25ms are handled.  This feature was created for a specific hardware use case, so as long as you're using a refresh rate of 50 or above, I can't see what could have changed here.

Can you confirm what refresh settings you have, and also if you're using the Allow10msControlSurfaceRefresh flag?

We will try to find out the reason for observation with AZ Controller "offline", but it will be helpful to know if something was changed in:

  1. input MIDI and the way it is delivered to Control surfaces, so something which can affect the number of received  messages (when there are many of them, f.e. a knob is turned fast).
  2. commands processing, so processing of many commands (like go to the next measure) coming fast.

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

We will try to find out the reason for observation with AZ Controller "offline", but it will be helpful to know if something was changed in:

  1. input MIDI and the way it is delivered to Control surfaces, so something which can affect the number of received  messages (when there are many of them, f.e. a knob is turned fast).
  2. commands processing, so processing of many commands (like go to the next measure) coming fast.

The only thing that was changed in control surfaces, was the way refresh is sent  - it notifies the main frame using SendMessage rather than PostMessage, but ONLY if the refresh time is < 25ms. In other words, as long as your refresh time is >= 25ms, it works exactly the same way as it did in 2020.11.

There have been no changes in command processing.

I'm pretty stumped as to why things are different for AZController in this release. The MackieControl surface is working exactly as it did in 2020.11 - including things like using the jog wheel for scrolling through the measures.

Share this post


Link to post
Share on other sites
3 hours ago, msmcleod said:

I'm pretty stumped as to why things are different for AZController in this release. The MackieControl surface is working exactly as it did in 2020.11 - including things like using the jog wheel for scrolling through the measures.

Unlike other plug-ins, AZ Controller allows fancy things... And Heinz has decided to do jogging a bit unusual way, as you can see in his videos, he is jogging by fader. In addition he is calling "Go to prev/next measure" for that. I also support "normal" jogging, including by fader/knob. But somehow he had better results with commands before.

Why he could get 127 changes from controller even on fast movement and why that "works" only 2 times in 2021.1 and can be "reset" by preset reloading stump me as well 🤨 I have no ideas so far.

Share this post


Link to post
Share on other sites

HI:)

Quote

In addition he is calling "Go to prev/next measure" for that. I also support "normal" jogging, including by fader/knob. But somehow he had better results with commands before.

I tried other possibilities but this was the fastest way and the way "Marko" did in his BCR2000 Preset years ago. 

Heinz.

 

Share this post


Link to post
Share on other sites

An updated hotfix build has been posted which includes the following extra fixes:

  • Crash inserting Kuasa plugin
  • Ripple All not working when deleting from Arranger Inspector
  • Adding a new articulation event should default to velocity 100
  • Fixed bitmap memory leak in when editing using audio snap that could cause blank screen
  • VST3 Host Bypass does not work with plugins that report it as non-automatable 
  • Automation write not working with certain VST2 plugins until envelope was created

@Sergio Miranda

 

  • Thanks 2

Share this post


Link to post
Share on other sites
7 hours ago, Noel Borthwick said:

An updated hotfix build has been posted which includes the following extra fixes:

  • Crash inserting Kuasa plugin
  • Ripple All not working when deleting from Arranger Inspector
  • Adding a new articulation event should default to velocity 100
  • Fixed bitmap memory leak in when editing using audio snap that could cause blank screen
  • VST3 Host Bypass does not work with plugins that report it as non-automatable 
  • Automation write not working with certain VST2 plugins until envelope was created

@Sergio Miranda

 

Thank you very much. Best support service ever.

Edited by solarlux

Share this post


Link to post
Share on other sites
On 1/23/2021 at 1:53 AM, Noel Borthwick said:

Indeed, this is some weird bug with WavesLocalServer that we found earlier. I've already reported it to Waves. 
If you run into it the workaround is to kill that task before installing or reboot the machine. I'm sure its not intended to be permanently running since a clean boot doesn't run it.

Hi everybody, I think this could also be a new "feature" since the last Win10-Update.
A few minutes ago I had a similar problem installing the latest update of Ocenaudio with "Qt5Concurrent.dll".

Maybe Windows changed its behaviour regarding the locking of dlls used by applications?

All the best 2 U

PS: Even the CbB-Hotfix Installer bld.88 had this problem with "sndfile.dll". I fixed it by shutting down the Waves process - as usual 😉

Share this post


Link to post
Share on other sites

I have more issues with ever-morphing windows 10 than i used to have with XP.. ymmv

Share this post


Link to post
Share on other sites

The WavesLocalServer Has nothing to do with Windows. Its its an unintended consequence of the path used by the WavesLocalServer Process that also happens to use the sndfile.dll internally. Waves has already acknowledged it and will be fixing it in their next update.

  • Thanks 1

Share this post


Link to post
Share on other sites

I have an idea concerning AZController misbehavior with 2021.1...

Can it be that surface loop/midi can be called multi-threaded now? I mean f.e. calling MIDIIn while in idle loop?

Not that is not allowed, but I have never observed that in any previous versions. There are some reasons AZController is not re-entrant. But the "protection" code can be buggy, since it was never tested...  

Share this post


Link to post
Share on other sites

Hotfix Build 91 has been posted to the EA channel. It includes fixes for some more reported and preexisting issues.

  • Freezing a synth could cause synth automation on all tracks to get orphaned
  • MMCSS now assigns all threads to the same MMCSS task groups for better efficiency. MMCSS thread limit has been increased to 128 to handle high number of cores.
  • Increased contrast of PRV clip outlines so they are visible regardless of current theme.
  • Arranger: Fix for trailing notes being incorrectly picked up by a section.
  • Ripple All not working when deleting from Arranger Inspector - additional fix for handling del key in the inspector.
  • Ripple Edit delete Section with overlapping notes at the end not working
  • Skip non automatable parameters in choose parameter dialog
  • Updated CWAF tool to latest known version number string to "27.13.0.xxx".

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Just now, azslow3 said:

There is no more problem with AZ Controller. Was my fault 🙄

Thanks for checking. What was the issue?

Share this post


Link to post
Share on other sites

Thanks for the Arranger section inclusion of outlying MIDI notes function!

Could we have something similar for audio too?

I often have audioclips slightly overlaping song sections (e.g. a guitar strum starts a bit before the bar beginning).

The logic may be simple: those overlaping audioclips, which have more than half of its length inside the section, would be included...

  • Great Idea 1

Share this post


Link to post
Share on other sites

The Arranger Section is not working for Control+Drag sections if "Select Events with Sections" is off.

If it´s ON then it works properly.

Sometimes the copy+paste keyboard shortcuts works, other times it doesn't.

I´m using the latest hotfix (Build 91)

Edited by Andres Medina

Share this post


Link to post
Share on other sites
6 hours ago, Andres Medina said:

The Arranger Section is not working for Control+Drag sections if "Select Events with Sections" is off.

If it´s ON then it works properly.

Sometimes the copy+paste keyboard shortcuts works, other times it doesn't.

I´m using the latest hotfix (Build 91)

All work fine. You need to look when you have selected all then it works. All is good.Its logical it need to enable  select events with section to work.

Edited by solarlux

Share this post


Link to post
Share on other sites
10 hours ago, Noel Borthwick said:

Thanks for checking. What was the issue?

Cakewalk exists for too long, v27 😀

Roland has not foreseen that Windows 8 drivers can work in Windows 10, so many devices was instantly "obsolete". AZ Controller also checks host version... fortunately it is still "supported" and so the bug could be fixed. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for fixing the delete Arranger section with overlapping notes and with Ripple Edit! Now it works fine! Special thanks to @msmcleod!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, azslow3 said:

Cakewalk exists for too long, v27 😀

Roland has not foreseen that Windows 8 drivers can work in Windows 10, so many devices was instantly "obsolete". AZ Controller also checks host version... fortunately it is still "supported" and so the bug could be fixed. 

Generally speaking it's risky to conditionally target host versions because the version number doesn't necessarily mean functionality changes. Some plugins also do this and it can lead to unexpected issues.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...