Jump to content
Noel Borthwick

2019.05 CbB Release highlights

Recommended Posts

Nice work.  Had the opportunity to show the improvement list to a friend of mine who has been on the skeptical side.       His comment was worth the time.   "Man, they are jumping right in and really trying to improve this daw!"   I smiled and said, "You damn, right!  You better get on board!"  Thank you as always.

Share this post


Link to post
Share on other sites

All great improvements and additions, one bug still seems to linger on.. where sometimes when pressing play or record may cause a loud beep that will only stop after you click on an "echo" button on any track (sometimes the audio/midi reset button works for this, sometimes not). At least it's an easy thing to tackle during a session, it can be frustrating is all. Especially working in somewhat loud sessions.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the update CbB and crew ! Smoothest / easiest update to date. You guys are killing it. Great fixes, features and  updates.

  • Like 1

Share this post


Link to post
Share on other sites
On 5/17/2019 at 5:43 PM, scook said:

If Drag and Drop - What to do with existing material is set to "Slide Over Old to Make Room" this is the cause of the problem. Do not use this option...ever. Set this to one of the other options and use Ripple Edit when "slide over" is needed.

 

On 5/17/2019 at 5:59 PM, Noel Borthwick said:

Can you share a project or some way for us to reproduce this? We can try and fix it. FWIW while we did fix some copy/paste bugs in this release the main focus was on slip editing.
If you know of a problem and its not something others are seeing its likely never going to get fixed unless you bring attention to it with a repro.

All is well, it was this secondary paste window that pops up when you go to paste. In there are all the options as in preferences which seems to over-ride the preferences selected. It had "Slide over Old to Make Room" checked, after i changed it to "Blend Old and New" all was back to normal.

I do my copying and pasting, cutting etc from the VS700 it would be a good idea to remove this popup paste window altogether.

Edited by dahjah
  • Thanks 1

Share this post


Link to post
Share on other sites
37 minutes ago, dahjah said:

I do my copying and pasting, cutting etc from the VS700 it would be a good idea to remove this popup paste window altogether.

Sounds like the VS700 is setup to call Paste Special. Can't you configure the button to call the regular paste function?

Share this post


Link to post
Share on other sites
4 hours ago, scook said:

Sounds like the VS700 is setup to call Paste Special. Can't you configure the button to call the regular paste function?

hmmm wish I knew how to do that, supm to look into.

Share this post


Link to post
Share on other sites

Noel - The enhancements for audio editing  are amazing. I've been doing a lot of very tight waveform editing the last few months and I thought I was getting some errors when rendering - particularly with stretching and slip editing - but I was doing this against an existing project where I had completely re-written the tempo map and was tasked to cut audio tracks in a thousand places and move and stretch them to fit the new tempo adjusted midi tracks. It was very tedious and I thought I was taxing the whole thing by rendering against a continuously varied tempo map. The fixes for wave editing are super tight .  I feel really confident going in a cleaning up things now - Thanks again for all the pain staking work your team is doing.

Edited by RBH
  • Like 1

Share this post


Link to post
Share on other sites

Glad you find it useful @RBH. We spent a lot of time finding and tracking each case where slip editing was inaccurate. There are a ton of permutations we had  to  consider when you throw combinations of editing edges, stretching, tempo maps and also throw ARA into the mix.

We want editing to be as solid as possible since it's a primary function. Let us know if you find any problem cases we may have missed.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Noel Borthwick said:

We want editing to be as solid as possible since it's a primary function. Let us know if you find any problem cases we may have missed.

In Sonar there was a problem when selecting a group of clips and then if I wanted to drag-move or copy the bunch but in the meantime while already holding the selection with a mouse I realized that for instance I've forgot to switch the snap settings, on or off, then when I click escape on the keyboard the whole selection always returns to the one clip only that was clicked and thus loosing the whole selection, often very carefully made and with passion(!) ;). That was always kinda off-putting to me.

Didn't have the occasion to check yet, but if Cakewalk exhibits the same behaviour, maybe it's worth making it keep the selection, for more flawless editing experience?

  • Like 1

Share this post


Link to post
Share on other sites

Is there any 'un-planned' (since it works so well this release 😁) for off-line update?  You can download and install the software, but only need to get online for authorization?

My studio has barely a blip of a signal, probably just enough for auth.  Always have to disconnect and take the computer to a location with signal for hotspot.

Share this post


Link to post
Share on other sites
16 hours ago, Noel Borthwick said:

We want editing to be as solid as possible since it's a primary function. Let us know if you find any problem cases we may have missed.

Just 3 minor things that needle me the last few days:

  • If you COPY a clip in a take lane and paste it to another take lane at the same now time, then the clip is always being removed from the original lane (like with cut and paste).

  • Sometimes a clip is being removed or put to the beginning of the song, if I increment or decrement the Start in the clip properties several times.

  • If I have defined a loop section when comping, the stop playing with the space bar does not always turn back to the now position (although I have set "On Stop, Rewind to Now Marker"). In those cases the now marker either stops at the current position or it jumps to the start of the song (although I pressed the space bar only with a short hit). During comping this really interrupts your workflow! HINT: I have the feeling that this happens often when you stop near the end of the loop/clip.
  • When comping with a loop section, sometimes the playing cannot be stopped (neither with the space bar, nor with the stop button). Luckily CbB's menus are still active so that I can at least save the project before I kill the process in the Task Manager (it seems that only the play thread is unresponsive).
  • Selecting a part of a take lane clip and then changing the gain ("Process > Apply Effect > Gain...") with a detailed resolution results sometimes in a weird wave form (some empty space between the selected part and the non-selected area). After several zoom outs the wave form is being cured, but still strange if I zoom in again. If I bounce to clip everything is okay. HINT: I don't know if this only happens if the Start of the take lane clip has been moved once before?

 

Edited by marled
Remove space line

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...