Jump to content
Morten Saether

[CLOSED] Cakewalk 2020.04 Early Access 2

Recommended Posts

21 minutes ago, User 905133 said:

You have the Basic workspace; change that. See the image here--no screensets in the Basic Workspace.

 

Fixed. Thank you, it's the simple things we overlook.

 

Share this post


Link to post
Share on other sites

No screenset issues here - not with any Workspace or "None".

Just saying for info purposes....

Share this post


Link to post
Share on other sites

The basic workspace has screensets unchecked. If you want to use that workspace with screensets you can save a copy of it with screensets turned on again in manage workspaces.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, User 905133 said:

The issues I described have not gone away; they are reasonably consistent; I am trying narrowing it down. At least with the projects I am using on my PC, they might be related to the drawing of VSTs, possibly specific VSTs or specific VSTs from specific manufacturers.  Or, it could be related to some changes I did to my PC: (1) removing virtual desktops and/or (2) under privacy settings denying permissions for apps, such as camera, mic, location, etc.

I rarely use screensets and have the ability to explore work arounds. I was curious when I saw the screenset issue post and found I also had it under the newest Early Access Release.  I am used to other issues with Cakewalk that go unresolved, so it is not a major issue for me. The nature of bugs can be elusive--sometimes they show up, sometimes they don't.

I have no doubt that 99% of users might not have a specific problem.  

As for me, I will roll back to the last working non-early release and re-test the files I have been testing the screenset issue. If I don't have these issues, I will put a post-it note on my monitor not to accept any newer versions. 

If I find a work around, I might share that.  So far, for me the FX VST Control Bar lock up I have been experiencing this morning can be resolved my minimizing the plug-in and then docking it in the Multidock. Unfortunately, that locks the FX VST into a cutoff mode.  There are several work arounds for that--such as deleting the plug-in and inserting it again.

If I can create a new project with a non-third-party paid plug-in that distributes the issues, I will share it.

To be clear, as I originally stated (i.e., the reference to Project A and Project B), I have also been able to open some projects and not have the screenset issues.  On my PC, it only seems to occur with some projects. I am now officially bored with trying to isolate the problem.  😉 

Apologies to those who have no issues with screensets.

@User 905133 Can you send me a project that repro's this behavior? Don't save the project in the new version - send the original project file.
If you load the same project in the prior release do you see the screensets working there?

Share this post


Link to post
Share on other sites
38 minutes ago, Noel Borthwick said:

@User 905133 Can you send me a project that repro's this behavior? Don't save the project in the new version - send the original project file.
If you load the same project in the prior release do you see the screensets working there?

Thanks for asking.  This afternoon I updated some plug-ins and am currently doing a vst rescan-after-reset. The project I had been using to test was updated; so maybe that will fix the screenset issue.  If not, I will send you a cwp file that has the issue that was saved under 2020.01.  

Share this post


Link to post
Share on other sites

I have used the arranger on one new project and after some time getting used to it it performed great.  I applied the arrangement to my project and saved with a new name so I could go back if needed. 

There is one thing I noticed that I think that could be a useful option.  Once the Arrangement is applied all the clips are trimmed so that slip editing the beginning or end of a clip no longer has the full clip data.  I think it could be useful to have the option to retain the original clip data after the arrangement is applied.  This could be a global option or a clip property to retain the data.

Just a thought.

All in all the arranger is something I think will really speed up my process.

thanks to Noel and the team for all the hard work.

Share this post


Link to post
Share on other sites
Posted (edited)

ooops

Edited by User 905133
was supposed to be a PM; deleted from here, sent as PM with attachments

Share this post


Link to post
Share on other sites
6 hours ago, Tom Riggs said:

I have used the arranger on one new project and after some time getting used to it it performed great.  I applied the arrangement to my project and saved with a new name so I could go back if needed. 

There is one thing I noticed that I think that could be a useful option.  Once the Arrangement is applied all the clips are trimmed so that slip editing the beginning or end of a clip no longer has the full clip data.  I think it could be useful to have the option to retain the original clip data after the arrangement is applied.  This could be a global option or a clip property to retain the data.

Just a thought.

All in all the arranger is something I think will really speed up my process.

thanks to Noel and the team for all the hard work.

@Tom Riggs - are you sure you can't slip edit after committing your arrangement? It seems to be working fine for me:

slip_edit_after_commit.gif

Share this post


Link to post
Share on other sites

Guys, I notice that all the efforts and interests of the version seem to be focused on the Arranger, which, certainly, very soon will be an excellent tool with more sedimentation. However I have some considerations to make about the version and some details:

1) The PRESETS listing on the Pro Channel was an excellent facility. Why not do the same when inserting FX Chain and inserting FX Chain Insert? See the Menu below. When we want one of these options, DAW opens the folders to choose from. It would be nice to have the listings there too.

image.png.759ad555c59c17c1c69f241eb4c83e94.png

2- On the PLUGIN Manager screen, another great facilitator would also be to show the new plugins included in another color or in another box. It would be much easier to include the new ones in our own Menus.

image.png.d2dfcd13057c1241276bee0a08b00515.png

3) It is a feature that has not yet been used. So I don't know if it's from this version or from long ago. After including EXTERNAL INSERT the application started to make sequential and random clicks.

image.png.49126eed4d92a247802350ed9afe7927.png

 

4)  I use the MT Power DRUM Kit battery PLUGIN. I noticed that if I direct OUTPUT to a Battery Map, the sound is lost and the PLUGIN loses all controls. Is it something that the Battery Map could be filtering out?

image.png.2679c92c9b6a7b89b822be27137b0f10.png

 

 

 

 

Share this post


Link to post
Share on other sites

Event view key Ctrl+Alt+Space

2020.01 event list. Ctrl+Alt+Space to play one next note. 

EA1 Ctrl+Alt+Space doesn't work. 

then 2020.01 Rollback installer. now 2020.01 and it works.
I will test EA2 at other PC for easy to check 2020.01 and EAn.

why you changed s-key and no notice? or just a bug?
there is no info at EA1 EA2.

in EA1 
perf /shortcut key /area evetlist view / not same as 2020.01

my edit work speed get very slow.
if keys confrict, (key for Arranger, 
please keep all function with other keys.

any combo key in windows system I can setup.

Here is my set up with external macro system.
// key C-P        = Enter NumPlusSign    Enter C-A-Space Up Down        # Enter + Enter 音だし Up Down
// key C-O        = Enter NumHyphenMinus Enter C-A-Space Up Down        # Enter - Enter 音だし Up Down

Ctrol-P to play + note and sound play
Ctrol-O to play - note and sound play

and Ctrol-Sapce to Ctrl+Alt+Space with external keymacro
// # 1180914 21:38:18    Cakewalk Ctrl+Alt+Space CW Event Listで 音をならす これを Ctrl+Spaceに
//#    左が押す元のキー
//# key C-Space = C-A- Space         # Ctrl+Space -> Ctrl+Alt+Space
//#    1180914 21:46:14    逆も一応いれる。
//p# key C-A-Space = C-Space         # Ctrl+Alt+Space -> Ctrl+Space
 

Share this post


Link to post
Share on other sites
3 hours ago, JM2 said:

Event view key Ctrl+Alt+Space

2020.01 event list. Ctrl+Alt+Space to play one next note. 

EA1 Ctrl+Alt+Space doesn't work. 

then 2020.01 Rollback installer. now 2020.01 and it works.
I will test EA2 at other PC for easy to check 2020.01 and EAn.

why you changed s-key and no notice? or just a bug?
there is no info at EA1 EA2.

in EA1 
perf /shortcut key /area evetlist view / not same as 2020.01

my edit work speed get very slow.
if keys confrict, (key for Arranger, 
please keep all function with other keys.

any combo key in windows system I can setup.

Here is my set up with external macro system.
// key C-P        = Enter NumPlusSign    Enter C-A-Space Up Down        # Enter + Enter 音だし Up Down
// key C-O        = Enter NumHyphenMinus Enter C-A-Space Up Down        # Enter - Enter 音だし Up Down

Ctrol-P to play + note and sound play
Ctrol-O to play - note and sound play

and Ctrol-Sapce to Ctrl+Alt+Space with external keymacro
// # 1180914 21:38:18    Cakewalk Ctrl+Alt+Space CW Event Listで 音をならす これを Ctrl+Spaceに
//#    左が押す元のキー
//# key C-Space = C-A- Space         # Ctrl+Space -> Ctrl+Alt+Space
//#    1180914 21:46:14    逆も一応いれる。
//p# key C-A-Space = C-Space         # Ctrl+Alt+Space -> Ctrl+Space
 

2020.04 builds have Ctrl + Alt + Space bound to Preview Play Arrangement From Now Time as a Global Binding. This is overriding your existing binding which is view-specific to the Event List. If you unbind the global one the Preferences, it should return to the 2020.01 behavior. 

Share this post


Link to post
Share on other sites

It may already be reported, but when I commit arrangement to project and one of my track is filtered on volume or other curve : the audio of these tracks disappears. And are not rendered of course...

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Jonathan Sasor said:

2020.04 builds have Ctrl + Alt + Space bound to Preview Play Arrangement From Now Time as a Global Binding. This is overriding your existing binding which is view-specific to the Event List. If you unbind the global one the Preferences, it should return to the 2020.01 behavior. 

Thanks info.

EA2 Version: 2020.04 (Build 164,64bit)
in EA1 EA2 
I can't do setup for my old 2020.01 behavior. 

what I did unbind  is 
locate Ctrl + Alt + Space
push unbind

so I can't unbind "Preview Play Arrangement From Now Time" 
this seems inside setup. no bind to right side function.
so unbind botton makes nothing.

I have REC video at yourtube, URL later.
//youtube live to archive is very slow today

"Ctrl + Alt + Space for Event view play one note" is not my setup. 
I just change Ctrl + Space to outside of cakewalk.
2020.01 has it in inside setup.
inside setup means such as SPACE for play/Stop

is there function name for Event list-play one note?
if so I can setup some key to that function.
play one note means 
if 10 events at event list
repeart Ctrl + Alt + Space to 1 2 3 4 5 ..

EA2-keybind-1.jpg

 

Edited by JM2

Share this post


Link to post
Share on other sites
Posted (edited)

EA2 Version: 2020.04 (Build 164,64bit)
Lang Japanese: no 3 menus 
Create Secion from Selection|Markers|Sections
I can't do this 3 functions.
 

 

jpg
same setup/project file 
English lang
Japanese lang  no menu 3 lines

EA2-no-jp-menu-1.jpg

Edited by JM2

Share this post


Link to post
Share on other sites
4 minutes ago, JM2 said:

EA2 Version: 2020.04 (Build 164,64bit)
Lang Japanese: no 3 menus 
Create Secion from Selection|Markers|Sections
I can't do this 3 functions.

 

2020.04 is not fully localized yet, which is why it's missing in Japanese. These options will be there in the final public release. 

Share this post


Link to post
Share on other sites
Posted (edited)

So far so good, no crashes yet.

However, I've always had an issue with the responsiveness of scrolling. Especially since I use freewheel scrolling without detents, so once I start a significant scroll, I could be waiting for half a minute until it's finished scrolling. Even just scrolling single steps, if there's a lot of stuff to paint, it can take up to about a second, and it seems to be completely synchronous/blocking on the UI thread. My PC isn't the most powerful these days (2x 4-core Xeon 3.3GHz, no HT) but I'm sure the paint routine can be improved, perhaps asynchronously; scroll, bitblt, enqueue the full redraw the later? I made a screen recording that I'll link to once it's uploaded.  
(EDIT: Here's the video: https://youtu.be/WNJMNN_Eho0 )

Secondly, composite waveforms don't behave quite how I expect. When I have take lanes open, if I have multiple clips with interleaved audio, and I have sections of one clip muted, this ghosts the waveform of the other clip in the composite waveform. When take lanes are closed, it only shows the topmost clip, which I suppose makes sense for editing, but it's not reflective of the audio. Picture attached.

 

Other than, well done! Super pleased with the introduction of ProChannel module presets! (But would love some copypasta so I don't have to save temporary presets. 😛 )

cbb composite.png

Edited by Ashley Miller
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

 

Gerenciador de plug-ins

Ao tentar fazer alterações em um menu MIDI Effects personalizado, quando escolho o nome do menu na caixa de listagem, há um abandono sem gravação, retornando ao projeto.

Even worse happened, when I had it saved and chose the name of a Custom Menu I had been using. Disaster: the entire menu has been replaced.
It is clear that the Effects Menu of non-MIDI plugins when saved saves everything, but the MIDI menu when saved only saves MIDI effects. Disaster summary: I will have to rebuild all of the custom menu again, as the rollback does not reverse what is personalized.

 

image.png.ee8cfa0f2edd307b39b43153c1933e45.png

Edited by Milton Sica

Share this post


Link to post
Share on other sites
14 hours ago, Ashley Miller said:

So far so good, no crashes yet.

However, I've always had an issue with the responsiveness of scrolling. Especially since I use freewheel scrolling without detents, so once I start a significant scroll, I could be waiting for half a minute until it's finished scrolling. Even just scrolling single steps, if there's a lot of stuff to paint, it can take up to about a second, and it seems to be completely synchronous/blocking on the UI thread. My PC isn't the most powerful these days (2x 4-core Xeon 3.3GHz, no HT) but I'm sure the paint routine can be improved, perhaps asynchronously; scroll, bitblt, enqueue the full redraw the later? I made a screen recording that I'll link to once it's uploaded.  
(EDIT: Here's the video: https://youtu.be/WNJMNN_Eho0 )

Secondly, composite waveforms don't behave quite how I expect. When I have take lanes open, if I have multiple clips with interleaved audio, and I have sections of one clip muted, this ghosts the waveform of the other clip in the composite waveform. When take lanes are closed, it only shows the topmost clip, which I suppose makes sense for editing, but it's not reflective of the audio. Picture attached.

 

Other than, well done! Super pleased with the introduction of ProChannel module presets! (But would love some copypasta so I don't have to save temporary presets. 😛 )

 

@Ashley MillerProchannel module copy paste is already available. Do you not see it in the context menu? Click on the preset picker to view the presets and you should see Copy Settings and Paste Settings in the menu.

Regarding scrolling painting in windows can't be done async since its all on the UI thread. However generally it shouldn't be that slow. Can you share a project that exhibits this very slow behavior so we can repro it here?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...