Jump to content
Twisted Fingers

Audio Pops and Crackling During Playback while Mixing

Recommended Posts

What can I do to stop the popping and clicking during playback? I'm using the Izotope Production Suite for mixing and I understand that this suite is CPU intensive but my CPU never breaks a sweat.

I'm hearing consistent popping and crackling (sounds like bacon frying in another room) while mixing with sample buffer settings of 64 to 1024 samples on my Focusrite Scarlett 18i8. I updated to the latest 1.10b3 version of the driver which drastically improved performance but not enough to eliminate the popping and clicking.

With a sample buffer size of 64 samples, round trip latency is 9.3 ms (412 samples). With a sample buffer size of 1024 samples, round trip latency is 97 ms (4274 samples). The only difference I notice is that there's significantly more popping and clicking at 64 samples than at 1024 samples. At 64 samples, playback sometimes won't start after a mixing change, but pressing play again gets it going.

Focusrite tech support, which has been very supportive, have suggested that the problem could be my DirectX Driver which LatencyMon shows to have a highest execution time of 0.52 ms. Other execution times >0.04 ms are Kernal Mode Driver Framework at 0.497 ms, High Definition Audio Bus Driver at 0.32 ms and TCP/IP Driver at 0.24 ms. I used dxdiag to verify that I have the latest DirectX 12 driver. I also have the Intel Driver and Support Assistant which keeps all Intel related drivers up to date.

A screenshot of my PC System Info is attached. I have set Page File Size to 0. My reasoning is that I have 32 GB of memory and Cakewalk doesn't us more that 12 GB. I'd set the Page File to 800 MB as recommended by the Page File setting dialog to have enough room for a dump file, but decided to go to 0 MB because LatencyMon was showing Hard Pagefaults and I thought that Windows 10 might be moving memory pages to memory even when there's lots of available memory. Pagefaults did drastically reduce but not to 0. With the Page File set to 0 MB LatencyMon shows 6 Hard Pagefaults. How can that be? I've attached a Memory Resource Monitor screenshot showing memory use during Cakewalk playback.

The CPU Resource Monitor and the Cakewalk Performance Monitor that none of my CPU's 12 threads are more that 10% utilized.  Basically it looks like my computer is idling along not breaking a sweat while I'm hearing all this popping and clicking. Is there some way to get my computer to take more interest in eliminating popping and clicking?

My ASUS X99-Deluxe II Motherboard has 40 PCIe lanes a number of BIOS setting options to to best use those. I've settled on settings that seemed best for me but I'm not sure. My main two drives are M.2 and the third is a SSD. My video card is an AMD R7 250 series. It has an AMD Settings app that is frequently requesting that I update the Radeon driver that I'm not even sure I need because I don't do video games, 3D graphics, or use the HDMI audio output. I also have an Intel Thunderbolt 3 card which I still can't afford a audio interface to use.

Any suggestions appreciated.

PC System Info.png

Windows Memory Resource Monitor.png

Share this post


Link to post
Share on other sites
20 minutes ago, Twisted Fingers said:

What can I do to stop the popping and clicking during playback? I'm using the Izotope Production Suite for mixing and I understand that this suite is CPU intensive but my CPU never breaks a sweat.

What kind of processing are you doing? I know with a lot of their RX plugins, there are different real time playback modes. make sure your not at the highest quality, if you are using those types of plugins. I usually select the first or 2nd playback algorithm, but when i export, i select the highest one

Share this post


Link to post
Share on other sites

I get weird sounds using my Focusrite Safire Pro 40.  Sounds like tearing cardboards at times. I think it is resulting from my Roland vst instruments. If I start a new project and don’t use the plugin, it doesn’t happen.  A project that uses the plugin has random sounds. When I export, the sounds are not there.

Share this post


Link to post
Share on other sites
20 hours ago, CJ Jacobson said:

What kind of processing are you doing?

Thanks CJ. I use the Izotope Production Suite which includes Ozone 8 Advanced, Neutron 2 Advanced, Nectar 3, Insite 2, Trash 2, VocalSynth 2 and RX 7 Standard. I have all but RX 7 in the mix with multiple instances of Neutron 2. I use RX 7 offline only.

I know that these plugins use a lot computer power; but as I stated, I have plenty of CPU power and RAM left. I am able to mix with a 64 sample buffer except that the pops and clicks make listening very difficult. What I'm looking for and haven't found is where's the bottle neck causing the pops and clicks? LatencyMon gives it a thumbs up.

Share this post


Link to post
Share on other sites
20 hours ago, razor7music said:

Try changing your audio card buffer. Here's an existing post.

You might also disable the 64-bit Double Precision Engine. See (hear) if that works.

Thanks razor7music.  That's existing post is pretty old, but a lot of the discussion seems relevant.  My Record and Playback I/O buffer size is 512 kB by default. I don't recall ever adjusting them. The 64-bit Double Precision Engine on but I don't believe that's a problem. My CPU is idling along at under 10% of capacity.

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, TVR PRODUCTIONS said:

I get weird sounds using my Focusrite Safire Pro 40.  Sounds like tearing cardboards at times. I think it is resulting from my Roland vst instruments. If I start a new project and don’t use the plugin, it doesn’t happen.  A project that uses the plugin has random sounds. When I export, the sounds are not there.

TVR Productions, I don't have a clue what causes that. I haven't experienced that problem. Sorry.

Share this post


Link to post
Share on other sites
3 hours ago, Twisted Fingers said:

Thanks CJ. I use the Izotope Production Suite which includes Ozone 8 Advanced, Neutron 2 Advanced, Nectar 3, Insite 2, Trash 2, VocalSynth 2 and RX 7 Standard. I have all but RX 7 in the mix with multiple instances of Neutron 2. I use RX 7 offline only.

I know that these plugins use a lot computer power; but as I stated, I have plenty of CPU power and RAM left. I am able to mix with a 64 sample buffer except that the pops and clicks make listening very difficult.

The 64 sample buffer is the most likely problem. It can work fine for tracking. Not so much for mixing with those plug-ins.

  • Like 1

Share this post


Link to post
Share on other sites

When I switch from tracking to mixing, I ALWAYS jack up my audio interface's ASIO Buffer Size to either 1024 or 2048 samples.  This is for 2 reasons:

1) Many of the more robust plugins, like convoluted reverb plugs, use a technique of look-ahead processing, to do what they do, and this requires a huge buffer size to accommodate  it.  

2) There is no need to maintain a small ASIO Buffer Size when mixing, because any latency induced by a large buffer size doesn't matter, because you aren't trying to track to it, so any delay in playback is fine, for mixing.

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites

I totally agree with Bob.  If you're just mixing, keep setting the ASIO buffer higher until the bacon stops frying.  If it never does, it must be something else terrible wrong with your setup.

  • Like 1

Share this post


Link to post
Share on other sites

Pretty much until the end of time, you will be alternating your ASIO Buffer Size values: small value when recording tracks, huge value when mixing.  It is simply the nature of the requirements of the more heavy duty plugins,  added and used during mixing, that you need to do this, for all but the simplest projects.

I don't even really think about it anymore.  My brain automatically sets the ASIO Buffer Size to either 128 or 64 for tracking, and then way up to either 1024 or 2048 when switching to mixing.  I never ever have audio Rice Crispy noises when mixing, and if I happen to get any issues when recording with the buffer set to 64, I simply  bump it up to 128, which is still fine for tracking.

Bob Bone

  • Like 2

Share this post


Link to post
Share on other sites
13 hours ago, Base 57 said:

The 64 sample buffer is the most likely problem. It can work fine for tracking. Not so much for mixing with those plug-ins.

 

11 hours ago, Robert Bone said:

When I switch from tracking to mixing, I ALWAYS jack up my audio interface's ASIO Buffer Size to either 1024 or 2048 samples. 

 

10 hours ago, BRainbow said:

I totally agree with Bob.  If you're just mixing, keep setting the ASIO buffer higher until the bacon stops frying.  If it never does, it must be something else terrible wrong with your setup.

 

4 hours ago, Robert Bone said:

Pretty much until the end of time, you will be alternating your ASIO Buffer Size values: small value when recording tracks, huge value when mixing.  It is simply the nature of the requirements of the more heavy duty plugins,  added and used during mixing, that you need to do this, for all but the simplest projects.

Thanks folks. Looks like we have consensus. I do that too to reduce the popping and crackling; but I don't get dropouts even at 64 samples. Unfortunately the largest ASIO buffer size offered by Focusrite Scarlett 18i8 with it's new driver is 1024 and I still hear pops and clicks at 1024.

However, I'm still confused. Aren't the ASIO buffers used to account for I/O processing only not internal processing with the ASIO input buffer provide time for an analog input to be converted to digital, processed by the audio interface and placed into the Cakewalk input buffer, and the ASIO output buffer provide time for a Cakewalk output to be processed by the audio interface and converted to an analog signal? The attached Cakewalk Driver Settings screenshots. ASIO's latency calculations are based only on I/O processing latency and not on Cakewalk project processing including plugin latency. These numbers do not change based on project complexity or plugin selections.

So I don't understand why ASIO buffer size increases are required to accommodate plugin processing delay? Don't the Record and Playback Buffers handle Cakewalk processing delays? Mine are set to 512 kB, I think by default. I don't remember changing them. However, after reading the paragraph pasted below from the new PDF documentation. I progressively reduced record and playback buffer sizes to 1 kB. Magically CPU utilization increased a little and the popping and cracking reduced. On initial testing I didn't hear any pops or crackles at an ASIO buffer size or 128 samples. Note to self: I haven't tested the Record I/O buffer size while recording yet.

Copied from top of page 1481 in the new PDF documentation (couldn't find in the online help documentation)

The “I/O Buffer Size” may not be well matched to your hard disk Cakewalk may be reading and writing audio data to/from your hard disk in chunks that are either too large or too small for your particular hard disk's characteristics. Go to Edit > Preferences > Audio - Sync and Caching and try different values for Playback I/O Buffer Size and Record I/O Buffer Size until you find values that works well for your particular hard disk: The default value is 64. Try reducing this value, to 32, then 16. After each change, close the dialog box (click OK) and re-test your project's recording/playback behavior. If problem(s) persist, try increasing this value, to 128, then 256, then 512. Again, close the dialog box and re-try your project after each change. If you have an older, slower computer or an older, slower hard disk, you should try increasing the buffer size; decreasing is not advised on slower hardware. However, increasing this setting uses more of your computer's RAM. If you have a smaller amount of RAM in your computer, increasing the buffer size may not help. If problem(s) persist, restore this value to its default and continue with the next step.

 

Latency at 64 samples.png

Latency at 1024 samples.png

Share this post


Link to post
Share on other sites

<So I don't understand why ASIO buffer size increases are required to accommodate plugin processing delay?>>

I agree. I don't think the ASIO buffer increase recommendation has much to do with the inherent processing delay of the plug-ins.

I am no expert, but my own little understanding (and experience) is that increasing the ASIO buffer gives the computer a bit more time to process all those CPU-intensive plug-ins,  etc. that may strain it and interfere with its job of turning ones and zeros into analog sound.  i.e. playing back the audio stream itself.  If it is strained and doesn't have that extra time to crunch all the digits, it just has to skip some samples and out come the pops and clicks. 

Occasionally, my projects will get to a size and complexity (with Neutron on many tracks, Ozone in the buses, various convolution reverbs in the FX bins, lots of soft synths, and multiple audio tracks) where they just start popping and clicking on playback.  At that point I push up the ASIO buffer from 64 to 128 or 256 (or, very rarely, 512) and the problem will go away.

Of course, there are other things to do that can lighten the load, as recommended above, but its all about giving you system a bit of breathing room to handle everything smoothly.  But I don't know why you are still having problems at your max 1024 setting.

  • Thanks 1

Share this post


Link to post
Share on other sites

I absolutely have to turn off the antivirus to get down to 64 or 128 in ASIO. If I don't, the settings before the snap, crackle, and pops disappear hover around 256 and 320 for tracking. I also have the internal soundcard disabled. As well as the wireless network turned off. BTW, I'm using the Windows Defender that came in Windows 10.

  • Thanks 2

Share this post


Link to post
Share on other sites

If you can keep grandma and grandpa and the kids away from your DAW computer, it's even possible to permanently disable Windows 10's realtime threat scanning.

If you're using Windows 10 Home Edition, you need to enable Group Policy Editor (which takes an extra bit of effort to do with Windows 10 Home, but is a useful tool):

https://www.majorgeeks.com/content/page/enable_group_policy_editor_in_windows_10_home_edition.html

Then once you've turned this feature on, you may use it to have better control over the other feature of Windows 10 than you are given by default:

http://slashgenie.com/permanently-disable-windows-defender-in-windows-10/

I learned how to do these things due to observing Cakewalk taking a performance hit from having Windows Defender running everything through its realtime scanning engine, which, according to my monitoring, included all of my plug-ins and the audio streaming off my hard disk. Since I consider the idea that my plug-in collection could be harboring malware, much less my newly-recorded audio, to be completely asinine, I concluded that Windows Defender was itself worse for my computing experience than any malware I had encountered in 35 years of using computers and that it needed to be brought under control. By which I mean "turned off."

  • Thanks 1

Share this post


Link to post
Share on other sites

BRainbow, Sidney Earl Goodroe, Starship Krupa, thanks for the explanations and suggestions. Though I haven't had a chance to try them yet, I'm sure they will all help. I to use Windows Defender and disable the Network Connection before turning Windows Defender off. I have Windows 10 Pro so have access to policies. 

Does anyone know if a DirectX execution time of over 0.5 ms is ok? Focusrite tech support thought that might be a problem.

Share this post


Link to post
Share on other sites
6 hours ago, Twisted Fingers said:

BRainbow, Sidney Earl Goodroe, Starship Krupa, thanks for the explanations and suggestions. Though I haven't had a chance to try them yet, I'm sure they will all help. I to use Windows Defender and disable the Network Connection before turning Windows Defender off. I have Windows 10 Pro so have access to policies. 

Does anyone know if a DirectX execution time of over 0.5 ms is ok? Focusrite tech support thought that might be a problem.

I don't turn OFF my antivirus software, I simply add folder paths to my sample libraries and such, to be skipped from scanning every time I access them in Cakewalk.  That works great, for me.  In Avast, those folder paths are called Exemptions.

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites

Also make sure you have the latest versions of plug-ins. When doing an S1 project with two instances of the Line 6 Helix (which admittedly, I max out by doing multiband processing with several amps), I couldn't understand why I was getting terrible crackling. The performance  monitor showed around 47% CPU for each instance. I went to the Line 6 website, and saw that I was several revisions behind. After updating, it went down to 32% for each instance - apparently someone has been doing optimizations :)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 4/11/2019 at 4:29 PM, Robert Bone said:

I don't turn OFF my antivirus software, I simply add folder paths to my sample libraries and such, to be skipped from scanning every time I access them in Cakewalk.  That works great, for me.  In Avast, those folder paths are called Exemptions.

Bob Bone

I exempt all wav files from scanning in addition to exes etc. I found that when I would stop a long recording the scanner would suddenly scan the waves. This would press processor for a few minutes and potentially cause IO driven dropouts.

Share this post


Link to post
Share on other sites
20 hours ago, Craig Anderton said:

Also make sure you have the latest versions of plug-ins. When doing an S1 project with two instances of the Line 6 Helix (which admittedly, I max out by doing multiband processing with several amps), I couldn't understand why I was getting terrible crackling. The performance  monitor showed around 47% CPU for each instance. I went to the Line 6 website, and saw that I was several revisions behind. After updating, it went down to 32% for each instance - apparently someone has been doing optimizations :)

Thanks Craig. I was only using the Izotope Production Suite and they're all up to date.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×