Jump to content

Robert Bone

Members
  • Content Count

    1,211
  • Joined

  • Last visited

Everything posted by Robert Bone

  1. If you find that temporarily bypassing all effects makes a noticable difference with latency, that means that one or more of the effects loaded into the project, are introducing enough latency to produce noticable lag between playing a note and hearing it. (the FX button on the right of the Transport Module, acts like a toggle, to have all effects either engaged or bypassed). There are some types of effects that are meant for mixing, rather than use in tracking/recording. Linear-Phase effects, which were noted in an earlier post above, and also convolution reverb effects are both notorious for this. A couple of quick and dirty workarounds are to either: Bypass the effects until done with recording and moving on to mixing, or temporarily swap out the effect(s) that need larger buffer sizes to process properly (convolution reverb and linear-phase types), with less resource hungry equivalent effects (different reverb plugin or non linear phase effect), until done with tracking, and then swap the other effects back in, where you can mix with a giant ASIO Buffer Size without needing to worry about the lag in playback, because you are no longer trying to play notes when the lag is present. I hope the above makes sense, and that it helps. Bob Bone
  2. It looks like each program 'slot' has a volume control. I just searched the manual for 'Master' and came up empty. I will keep looking for it, and will post back, should I find it. Also, I suppose you could turn down the Cakewalk MIDI track volume fader, instead of the audio track volume fader. Here is a screen shot of a page from the manual, describing 'Volume' for a loaded program:
  3. You can try changing the ThreadSchedulingModel to 2, which would be ideal for most newer processors. If you find that it doesn't help, you can always change it back to 1. Just avoid setting it to 3, as that value, last I knew, was advised to avoid, by Noel, because it was a work in progress, so stick with a setting of 1, or 2, with 2 being the likely better choice. It will not hurt anything to switch back and forth from 1 to 2, to figure out which seems to work better for you. I just caught the tail end of the thread, and will circle back to earlier posts in it, in case I see anything else that might make sense to comment on. Bob Bone
  4. I got an email from Guitar Center, regarding some sort of fire hazard for a Line 6 product here is the link to the Line 6 recall page: https://line6.com/g10recall/ Bob Bone
  5. I have multiple HDTV's to pick from - I generally use a massive 65" HDTV for my main computer display, but also have a 55", 40", and 32" available. Most of what I do is MIDI-based, and I record guitars or basses using my laptop, I typically track my keyboards using the 40", and use the larger 55" or the 65" when editing or mixing. I used to run as many as 3 monitors, but just don't bother with that anymore - a single screen works fine for most stuff I work on. Certainly, actual real computer monitors tend to give a more precise picture, but I don't mind the quality of the picture on any of my HDTV's, for Cakewalk. Bob Bone
  6. Thanks - it was a labor of love - and a one-shot type of project. I completely agree on the notion of not wanting to pour a bunch of money into a mix, for a cover song, and I could have skipped the studio mix and done it in the box at home - just chose to do that for the outboard gear that particular studio had. To do that, was like my gift to myself, and my friend. I mix most everything in the box, at home, so outside of that one song, the issue will likely not repeat itself, unless I feel like treating myself again, at some point. Bob Bone
  7. I had no idea, and never thought about it, as we weren't trying to do anything but measure our music performance and production skills, celebrating a beautiful song by a fantastic band. The Copyright Claim on our cover version did not ask/require us to take the video down - it only indicates that we would not be eligible to make any money through YouTube views (which we never sought to do - quite the opposite, as booking the time in one of the largest studios in Chicago, for the mixing (they have insane outboard gear), was not cheap - I sprung several thousand dollars on the mix/master process, trying to bring the best gear available to bear on the project. To date, we have around 1,400 views, and quite a few of those are from Mike and I, just circling back to hear it, and to look for and respond to any posted comments (there haven't been many, but we want to make sure we are timely in replying to anybody who took the time to listen to the song, and also took the time to comment on it. We also included text and links in the video description, encouraging folks to support the recording band, the Dixie Dregs, by purchasing their albums and songs, with direct links to where folks could do just that. Here is a screenshot of the relevant text from our video description: Bob Bone
  8. Howdy - I did a cover of a Dixie Dregs tune, called Night Meets Light, and several years ago, posted it to YouTube. In my video, I scrolled through a bunch of public domain pictures of the various Dregs band members, changing the pictures every 5 seconds as the song played. SOOOO - either Steve Morse or his management/label put a copyright claim against my video, and that has me wondering - if I record myself playing someone's song, like I did here, why would that be considered a copyright violation? I used ZERO part of the original recording by the Dregs - every last note in my cover, was played by me, for most of the tracks, and a friend of mine, who played only the guitar tracks. (I covered drums, bass, keys, and violin, using soft synths). If I perform someone's song, where I am not pursuing making any money off of it, am I still violating copyright laws? I hope someone can give me a good response on this. Here is the link to the cover of Night Meets Light, in case anyone wants to listen to it. It is quite a complex song, due to numerous, and sneaky, meter changes). The song is beautiful, and there is a bass and guitar unison section in the middle, that is flat out brilliant. Thanks, Bob Bone
  9. It may be possible that you moved the port the A-300 was connected to, and that can confuse Cakewalk, which will look like everything is fine, but really the internal identification of it has gotten whacky, and it won't respond to MIDI, but only in Cakewalk, meaning it will work fine in other programs, such as in stand-alone synths or a different DAW. I wish I could explain this potential cause better, but it has been several years since I have had this happen, because I never ever change which USB ports my keyboards are connected to. I am hopeful that someone else can weigh in on this issue for you - I would have to dig through stuff to go back and figure out what I did to fix it, from 3 years ago, and I have a pretty adventure-filled day today. If nobody else has helped you out by late afternoon or early evening, I will try to circle back to dig into my prior experiences with it. Bob Bone
  10. Sorry - I do not know - I have no familiarity with the nanoKontrol2, and all I did for my earlier post, was to pull up the blurb I posted - from the manual. Did you read the earlier post(s) with steps to follow? The only other thing I can think of is for you to contact Native-Instruments support. In the past, I had called them on 2-3 occasions, and they helped me right out. I called the main tech support in Germany, but there was one time where I called Native-Instruments in the states - might have been California, but the info for contacting them is on their web site - or at least it used to be. Bob Bone
  11. No trouble at all. All I did was to clean up things a bit. (still room for improvement). I uploaded what I have for CAL to Dropbox, in a compressed folder less than 6 MB in size, that contains CAL documentation and examples. an editor, and a bunch of CAL scripts. The download link is: CAL Documentation, scripts. and editor
  12. Good morning. I started to gather the CAL documentation I have, as well as a bunch of scripts, and an editor app, last night - but fell asleep. I will continue getting that stuff organized better, so it can be shared.
  13. Shoot me a private message with an email address, and I will send you what I have on the CAL language
  14. It is also important - and required by the terms of service for these forums, that we all be respectful of each other, and let's also all remember that we are indeed all on the same team, so let's make sure to remain positive and courteous in our posts, so us forum host folks don't have to wade into some flame war between folks. Try to resist arguing with folks, or escalating post wars - it is for the best, and certainly helps keep these forums the helpful place as intended. Just everybody be kewl, stay kewl, and live kewl. Bob Bone
  15. Yeah - I will concur with the other person that cautioned against using a ThreadSchedulingModel value of '3'. Noel had indicated, many months back, that we should NOT be using the aggressive mode (value of 3), because it was still a work in progress, and not stable. The default for that parameter is 1, and for most computers, you will likely benefit from changing that value to '2'. Here is a screenshot of setting that in Preferences, and you can always modify it back to a value of '1', if any issues arise with it set to '2'. Screenshot below - Bob Bone
  16. While CAL, as a language, has not been maintained for many many many many years, it DOES still work, and I write little scripts. or modify existing ones as needed, for little things that come up now and then, for which a script would come in handy. For example, I just wrote a little CAL script to help me edit MIDI data for drum tracks, where I had created the MIDI track using one drum library and its set of drum synth note numbers, and I wanted to switch to a different drum library that I liked better, which used different MIDI note numbers. While there are lots of ways of doing many things, I chose to whip up a little CAL script to allow me to enter one MIDI note number, and also enter a replacement MIDI note number, and the script would sweep the selected MIDI track/clip and replace all occurrences of the 1st entered note number, with the 2nd entered note number. Works like a champ, and I use the script whenever I replace one drum library with another. Yes, I could have done it using different methods - I just felt like doing it with a CAL script, and all is well. Another example - I have MIDI files for numerous pop songs, that I downloaded, where the entire score, for example, is written in the key of C. Unfortunately, that also includes the staves for instruments that are not tuned to a standard 'C' tuning (alto saxophone is an Eb instrument, trumpet is a Bb instrument, etc). SO, I wrote a CAL script to do custom transposition from whatever the starting key is, either up or down whatever number of helf-steps I enter, and then when I import the modified MIDI file in a notation program, even the free ones, it properly notates that MIDI track for the correct tuning for the associated instrument. In most cases, this is something I do for a friend of mine's wife, as she plays alto sax. I have a bunch of CAL documentation and example scripts, if anybody wants them - even a CAL editor. Just shoot me a private message with an email address and I will happily send you what I have. Bob Bone
  17. I always check freeware through the VirusTital web site, which sends URL's, or in this case, the Surge downloaded executable file, and it detects a single report of malware. Has anybody seen any malware problems with Surge?
  18. Exactly! Yup! ( I concur with what @Sidney Earl Goodroe said, above). It is important to keep one's latency low, during recording. Once the project moves into mixing/mastering, THAT is when you can enlarge the ASIO Buffer Size to something like 1024 or 2048, and load up linear phase plugins, or convolution reverb, or other resource intensive types plugins, because latency isn't an issue at that point in a project's life cycle. If you have finished recording, and started mixing, and loaded up the heavy-duty buffer-hungry effects, only to find out you have some additional recording to do - I suggest you either temporarily freeze tracks that use those effects, or temporarily turn off any effects that require a larger ASIO Buffer Size, and change your ASIO Buffer Size back down to 128 or less, if possible, so that your latency is low enough to properly record without lag or other audio issues. Then, once finished fixing the recorded tracks, you can turn those effects back on, or unfreeze the frozen tracks, and jack up the ASIO Buffer Size back up to 1024/2048 and resume mixing, etc..... So, 128 or less, if possible when recording, and 1024 or 2048, when mixing/mastering. It is pretty much the way of the world, forever. Bob Bone
  19. Well, I went the 'do it with style' option, and moved things around to where the instruments were expecting to find them, and it all worked out, though once I fired up a bunch of the different instruments from the various 8DIO freeware libraries, the only complete library I kept was the 8DIO_Free_Angels librariy. I kept one other instrument, the harmonic guitar sounds from the 8DIO_Appocalyptic_Guitar, or whatever it is called. Getting all the pieces in the right places was needed, to properly load the various instruments, Mini, Free_Radicals, etc., but the above are all that I ended up keeping. Thanks for the reply, Bob Bone
  20. Hey - I am a bit confused by the extraction process for this Free_Angels set of instruments and samples, and could use some guidance: There are 3 parts in what I downloaded, in .RAR compressed folders, 8DIO_Free_Angels.part1, 8DIO_Free_Angels.part2, and 8DIO_Free_Angels_539705. I extracted all 3 parts, which yielded the following folder and sub-folder nestings: From 8DIO_Free_Angels.part1, the extracted contents are all in a single folder, called 8DIO_Free_Angels Within the folder 8DIO_Free_Angels , there is a sub-folder, which is ALSO called 8DIO_Free_Angels Within the nested 8DIO_Free_Angels folder, there is a sub-folder, called Samples Within the above sub-folder, Samples, there are 2 sub-folders, Resources, and another sub-folder called Samples Within the Resources sub-folder, there are 2 sub-folders, Impulses, and another sub-folder, ALSO called Resources Within the Impulses sub-folder, there are 3 sub-folders: Default, Design, and Space - they have misc impulse files and no more sub-folders Within the additional Resources sub-folder, there are a couple of files, but also yet ANOTHER Resources sub-folder Within this 3rd-sub-level Resources sub-folder, there is a single sub-folder, called Pictures, which has only files, no other sub-folders From 8DIO_Free_Angels.part2, the extracted contents are all in a single sub-folder, called 8DIO_Free_Angels 2 Within the folder 8DIO_Free_Angels 2, there is a sub-folder, called 8DIO_Free_Angels Within 8DIO_Free_Angels, there is a single sub-folder, called Samples Within the Samples sub-folder, there is another sub-folder, ALSO called Samples Within this 2nd-level Samples sub-folder, there are a bunch of *.NCW files, and no more sub-folders From 8DIO_Free_Angels_539705, the extracted contants are all in a single sub-folder, called 8DIO_Free_Angels Within the above folder, 8DIO_Free_Angels, there are 2 sub-folders, Documents, and Instrument Within the above sub-folder Documents, there is a single PDF file, and no additional sub-folders Within the above Instrument sub-folder, there is a single Kontakt instrument, called 8DIO_Free_Angels.nki, and no additional files or sub-folders SOOOOO - the above is one giant mess, methinks. Just to see where the instrument itself was going to look for whatever it needed, I copied just the 8DIO_Free_Angels.nki Kontakt instrument, to a new 8DIO_Free_Angels folder in the folder I have Kontakt point at, for User Libs (freeware and purchased libraries for Kontakt, but I did not include anything else - just the instrument itself. I then launched Cakewalk, loaded up an instance of Kontakt, and loaded the 8DIO_Free_Angels.nki instrument, knowing it would display errors for missing samples. Here is the screenshot of what I got: So - I guess the above is where I need to move everything - I will give that a shot in the morning. If anybody else has a better solution to these issues, please do post, because so far, this has been rather annoying. Thanks, Bob Bone
  21. Hey there, fellow former mainframer! (says the keyboard player who worked in all levels of mainframe IT for 38 years, who then did a bunch of web work, and now just occasionally build little utility programs for Windows stuff, for myself)........ Here's one for you: There are 10 kinds of people in the world - those who understand binary, and those who do not. Ta Da
  22. For whatever the worth, I have the FaderPort 16, and love it for Cakewalk - using the MCU protocols, and essentially you set up 2 8-track MCU control surfaces, to get to where I can control 16 tracks. It is also true that not all of the FaderPort 16's buttons/functions work in Cakewalk, however I use it for tracking and mixing, at the track level, and it works great for that. It is also built like a tank. Best of luck to everyone, with any and all tools, software, and hardware, that assists in the realization of the sounds in your heads - creating and recording music is like breathing, to me. Bob Bone
  23. I can confirm that doing a Bounce to Clip, modifying the Events, and Converting to Step Sequencer works as expected, and that is the process I will follow. Bob Bone
  24. So any Step Sequencer data I wish to modify through a CAL script, should first be Bounced to Clip? Then, bug or not, I would be following the rules/intentions? (I am guessing that CAL is not likely to get updated, anytime soon)
  25. Howdy - I wrote a CAL script, to accept input of a number of half-steps to raise or lower note numbers in a selected MIDI clip, that was created by Step Sequencer. (Transpose based on user input number of half-steps). The CAL script dutifully applies the transposition, and this is reflected in the Event List, however, when I view the Step Sequencer, for that clip, it still shows the original Note Names/Numbers as they were originally enter - prior to running the CAL script. Am I losing my already feeble mind? If the Event List has the modified Note Events, how is it that Step Sequencer looks like the Note Events were never modified. If Step Sequencer created the Note Events that show up in the Event List, and the Event List shows the modified Note Events, properly, how is it that the Step Sequencer is also not modified? As I pondered the above, I converted the Step Sequencer data with Bounce to Clip, and the Piano Roll view correctly shows the modified Notes. I then Converted Clip to Step Sequencer, and viewed the Step Sequencer data, which then also correctly shows the modified Notes. SOOOOO - it seems like there is a bug with Step Sequencer, because when Note Events are modified in Event List, those modifications are not reflected in Step Sequencer, unless I Bounce to Clip, then Convert to Step Sequencer. Can anybody else confirm this, or enlighten me as to any errors in my thinking? Thanks! Bob Bone
×
×
  • Create New...