Jump to content
Sign in to follow this  
cclarry

Positive Grid Sale at Audio Deluxe

Recommended Posts

Can t believe i cliked on the link ...wtf ...

  • Haha 5

Share this post


Link to post
Share on other sites
1 hour ago, Zo said:

Can t believe i cliked on the link ...wtf ...

It means... 😛

Share this post


Link to post
Share on other sites

lol a chance positive "greed" offer is the most confusing and overlapping offer around lol !!

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah, Positive Grid upgraded me to BIAS FX 2 from FX1 for free due to some s#!t that went down and even the free upgrade wasn't a good deal. I really hate this software. 

Edited by Christian Jones
hate typos
  • Like 1

Share this post


Link to post
Share on other sites

BIAS FX 2 is not only still self-deleting an audio take right after I record it and watch it get drawn, but it's doing it just by virtue of having BIAS FX 2's octaver pedal on an aux track. Previously Noel et al here had confirmed that BIAS (FX1 and FX2) was hijacking the wave file after recording when it was loaded in a track template, but today it's happening in a track I created on the fly - and actually BIAS isn't even on the track but rather on an aux track that the audio track is being sent to. When I deleted BIAS FX 2 from that aux track then things immediately started functioning normally. Dude, I'm hating this software with a real passionate hate. I've always hated it actually, because this problem or some iteration of it has always existed for me. Recently I snapped and contacted Positive Grid and asked for a refund despite having purchased it a year ago. They refused but as a consolation upgraded me the BIAS FX 2 for free, and I *still* think they owe me dearly for making me think I was going nuts for a year, having witnessed countless deleted takes and questioning myself as to whether I actually pressed record or pressed play when I *knew* I pressed record lol. YMMV as with anything else but no, I really *hate* the software I don't mind telling you. /end of ran..  no, this was a legit gripe lol

Here's a video I just made of it happening. When I deleted BIAS out of the aux track down there the problem went away. 

https://my.pcloud.com/publink/show?code=XZGrULkZEsYdBO62LzfE8sXFf1yD8XPydM1V

Share this post


Link to post
Share on other sites

No such issues with BIAS Fx 1 or 2 or BIAS Amp 1 or 2 here, but then I don't use CbB.

They all work perfectly here. Apart from various omissions that PG in there wisdom decided to 'omit' (mainly quality of life stuff, but I can over look that most of the time) and a few other issues that don't really effect usage, for me they are the ones I use almost (99.9% of the time) exclusively, and I own (have owned, just gave away all my PA amp sims and PA Guitar related stuff) pretty much everything out there, Helix Native aside, but I hope to get that soon (on sale) to see how it fairs, demos aren't long enough for me, and I like to be able to easily revisit if desired.

 

Share this post


Link to post
Share on other sites

Bias FX works pretty great for me, sounds good too.

My only complaint is that I wish Bias FX, Amp and Pedal were one thing instead of three separate things.

Share this post


Link to post
Share on other sites

Yes, but they sort of are in the end, because all amps and pedals from Amp and Pedal show up in FX, just the tweakability is left behind, but once you make your tweaks and save amp or pedal they are available in FX, but yes, it would have been nice.

Share this post


Link to post
Share on other sites

Guys, do you have also ultra annoying issue with SG Amp2, that every new instance is prompting to login to Tonecloud?

I have it on every machine on every DAW. Tried to get help on support but well... Better to skip comments about it. Lots of wasted time and mindless re-installs.  :(

 

Share this post


Link to post
Share on other sites

just saw this at JRRSHOP ...to make it even more difficult lol ...choose one  .... ahahaha !!

 

image.thumb.png.ad8dbd37940baecfa599e7c874ccc8c1.png

Share this post


Link to post
Share on other sites

Yeah their sales can be pretty much non sales, and also a lot of different options to confuse.

Share this post


Link to post
Share on other sites
On 10/10/2019 at 3:53 AM, Piotr said:

Guys, do you have also ultra annoying issue with SG Amp2, that every new instance is prompting to login to Tonecloud?

I have it on every machine on every DAW. Tried to get help on support but well... Better to skip comments about it. Lots of wasted time and mindless re-installs.  :(

 

Yeah a lot of people complain about it. I just press skip or whatever it is and carry on and ignore it like the other things that I dislike about PG products, for me they are more than worth the annoyances I have with PG products, so I just deal with it, no real deal breakers. But I would be super happy if they added/fixed a lot of the things that people complain about, don't think it will happen though, as a lot of these 'issues' have been in all their products since the beginning. They are more like poor design choices than bugs or anything like that, annoying all the same, but still, the BIAS Family is still pretty much all I use, everything else just gathers dust.

  • Thanks 1

Share this post


Link to post
Share on other sites
58 minutes ago, ensonced said:

Yeah a lot of people complain about it. I just press skip or whatever it is and carry on and ignore it like the other things that I dislike about PG products, for me they are more than worth the annoyances I have with PG products, so I just deal with it, no real deal breakers. But I would be super happy if they added/fixed a lot of the things that people complain about, don't think it will happen though, as a lot of these 'issues' have been in all their products since the beginning. They are more like poor design choices than bugs or anything like that, annoying all the same, but still, the BIAS Family is still pretty much all I use, everything else just gathers dust.

Thanks for confirmation I am not the only person who is struggling with it :)

I even reported it to support but how support reacted is hard to believe... In short lot of my time wasted, mindless reinstall, mails etc... just like support guy din't even try to reproduce to check what I mean :(

Because of that I rarely use BIAS, especially if I plan to have amp sim on more than 1 track... So in my case this soft mainly on shelves :(

I also had an issue with another bug reported to them and also lots of wasted time... It is a pity... Plenty annoying bugs and support mostly advising 'please reinstall' no matter you claim the same story is on different machine and OS... They just don't listen... Maybe they have bots in support? :(

Share this post


Link to post
Share on other sites
On 10/8/2019 at 6:39 AM, Zo said:

Can t believe i cliked on the link ...wtf ...

Why ? It sounds amazing! Better than Nembrini!!

  • Like 1

Share this post


Link to post
Share on other sites
36 minutes ago, Carlos said:

Why ? It sounds amazing! Better than Nembrini!!

Nothing sounds better than Igor. His voice is glorious ;)

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, Piotr said:

Nothing sounds better than Igor. His voice is glorious ;)

I used purple sarcasm ;) 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...