Jump to content
Morten Saether

[CLOSED] Cakewalk 2021.04 Update 1 Release Candidate [Updated to build 170]

Recommended Posts

5 hours ago, Keni said:

What about a scenario where you want to copy the clip automation elsewhere?

That's an interesting question. The ideal scenario would be that we'd be able to copy/paste it or it's fragments between clips. But I can only make it work (sort of) if I select at least one note along with the envelope. It is then pasted as a new clip on top of anything that's there already so no way of copying just the automation between existing clips, AFAiK.

Edited by chris.r

Share this post


Link to post
Share on other sites
29 minutes ago, msmcleod said:

@chris.r / @David Baay  - hopefully this will explain things:

EnvelopeTimeBases.gif

Thanks, Mark. I understand all of the concepts. Where things go amiss is when you say 'Clip Envelopes are always Absolute Timebase'. That should not be the case for MIDI Clip Envelopes like Velocity Offset. Their duration should always be Musical Timebase, just like MIDI data. When you change the timebase of a MIDI clip to Absolute, it affects only its start time. I know this because I've been wanting an option to set MIDI Clip duration to Absolute for a long time. In the absence of this feature, MIDI Clip Envelope durations should always honor Musical Time just like MIDI data.

Share this post


Link to post
Share on other sites
3 hours ago, Keni said:

What about a scenario where you want to copy the clip automation elsewhere?

 

I copy is a separate entity by definition and can presumably be placed wherever you like, though I'm not sure the capability exists to paste a clip envelope into an existing clip...? This could get tricky when the target clip is shorter than the envelope.

In any case, I would expect the original envelope should stay locked to the clip unless you delete or cut it, given that the primary intent of a clip envelope is to be part of the clip rather than part of the track.

Share this post


Link to post
Share on other sites

Hi folks, thanks for your help in making this a great update. Update 1 has been officially released. Head to Help | Check for updates to download the final build.

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
17 minutes ago, Noel Borthwick said:

Hi folks, thanks for your help in making this a great update. Update 1 has been officially released. Head to Help | Check for updates to download the final build.

Thanks Noel!

Again for all the hard work, attention, and love you and the Bandlab Bakers continue to share with our beloved Cakewalk!

Share this post


Link to post
Share on other sites
On 5/16/2021 at 10:17 AM, Keni said:

Hi Noel!

 

I found my acknowledgement of receipt reply with a reference number of

526274

Is this what you refer to?

Thanks for being patient with me.

I looked at both your dump files there and they were reported with exception severity 7.  I couldn't fully figure out what was causing the exceptions from the dump file unfortunately. They didn't appear to be plugin related issues. The latest release shouldn't report those issues since we default to severity 1 now.

Share this post


Link to post
Share on other sites
5 minutes ago, Noel Borthwick said:

I looked at both your dump files there and they were reported with exception severity 7.  I couldn't fully figure out what was causing the exceptions from the dump file unfortunately. They didn't appear to be plugin related issues. The latest release shouldn't report those issues since we default to severity 1 now.

Thanks again Noel.

 

Interesting. It's a project that I never save unless some new overall mastering concept gets added to my mastering. This is a project I use much like a template. I "master" the song and export a finished file. No save. It has a simple volume envelope and numerous disabled plugins. Typically the only active plugins are the ProChannel bus compressor and Adaptive Limiter loaded in the ProChannel. I wonder what else might be involved if it’s not a plugin?

 

Oh well. Not terrible for me. Just a nuisance. I never lose any data and simply restarting after the crash returns to normal.

 

...but it would be nice to have it go away.

 

In the meantime, great update! Lots of features and fixes to please many people across the board!

 

Share this post


Link to post
Share on other sites

Once again, thanks everybody for your participation with Early Access! Build 175 is now available to all by going to Help | Check for Updates. You can now post any related feedback to the official release feedback thread.

 

 

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...