Jump to content

Ben Staton

Staff
  • Content Count

    87
  • Joined

  • Last visited

Community Reputation

70 Excellent

3 Followers

About Ben Staton

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @MrJackBarton Thanks for the report. We've been doing some more work on plugin menus and will shortly be releasing another build which will hopefully resolve your issues. Stay tuned!
  2. Hi Glenn, Thanks for the report. My immediate thought was that it looks like a custom theme issue. I realize you're using Mercury, but can I ask if you were using a custom theme before that? Nothing wrong with that, but if Cakewalk starts up with a custom theme that isn't up-to-date, it's possible you could run into this issue even after switching back to Mercury. One way to find out is to set Cakewalk to the original Mercury theme and then restart it. If that solves your problem, then you probably need to update your custom theme. We also introduced a theme compatibility warning in the latest release, which you should see on startup if your custom theme needs updating. Thanks, Ben
  3. FWIW, we can't reproduce it here. I also checked the code and it doesn't seem to be doing anything unusual or CPU intensive at all when moving the mouse over track names. Indeed, moving the mouse over track names actually does significantly less than moving it over some of the other controls nearby. Are there any other clues you can give us?
  4. @torhan Thanks for the report. Unfortunately, we can't reproduce it here, but we're aware that issues like this do happen in rare circumstances. If you see it again, please would you post a screenshot showing the entire Cakewalk window? That can often give us clues that a more localized screenshot can't, such as the general layout of all views at the time it occurred. Thank you! In the meantime, resizing the window (or un-maximizing it and then maximizing it again) usually fixes it.
  5. @Herve Maratrey I just PM'd you a link to a new installer. Hopefully, that will fix your problem. Please let us know how it goes. Thanks again, Ben
  6. @Herve Maratrey We're currently testing a fix for this, which looks very promising. Is it OK if we send you a new build to test?
  7. I'd also like to know which languages you have Windows and Cakewalk set to. It may be relevant.
  8. @Herve Maratrey Please would you also check the Arranger by opening the 'View' menu in the Track View, and then choosing 'Arranger Track Show/Hide'? We're wondering if that also causes a crash for you. Thanks!
  9. Hi @Herve Maratrey, Thanks for the report. The crash dump suggests there might be an issue with DirectX on your PC. Firstly, I would make sure that your graphics driver is up to date. If that doesn't fix the problem, you could try running dxdiag, which is the 'DirectX Diagnostic Tool' that comes with Windows 10. It might highlight any DirectX problems and help you to resolve them. Failing that, dxdiag has a 'Save All Information...' button at the bottom that will save a file containing information about your DirectX installation. If you send that file to us, it might give us some clues (check it first, to make sure you're OK with us seeing the information it contains). Please let us know how you get on. Thanks again, Ben
  10. Thanks for the report. This bug has been reproduced and logged. No guarantees, but hopefully we'll get to it soon.
  11. Hmm, this is a tricky one. Cakewalk literally does nothing at all to change or ignore the Windows scaling setting. It neither opts in nor out of it. Essentially, it just throws its hands in the air and says "Hey Windows, I know nothing about high DPI, so you take care of it!". Do you by any chance have multiple monitors? If so, do they have different resolutions? Do you always run Cakewalk on the same monitor? Do you ever run Cakewalk on another display, whether it's temporarily plugging in a different monitor/TV, or by running it remotely (via Remote Desktop or similar)? Do you change the Windows scaling setting occasionally (nothing wrong with that, but it might be a factor)? I'm also wondering why you're running Cakewalk with admin permissions all the time, which shouldn't be necessary. If Cakewalk is somehow affecting it (again, I fail to see how, but stranger things have happened), running it without admin permissions might prevent it from doing so. If anyone else is running into this, please let us know. I'd like to get to the bottom of it.
  12. Nice idea, but I don't think that's the problem. While we use some CJ stuff, most of the UI is built using other technologies, and this seems to be an app wide issue.
  13. I'm struggling to think how CbB could change your high DPI scaling override setting. I know we aren't doing anything out of the ordinary. On start-up, CbB just tells Windows to handle scaling on its behalf. I wonder if Windows is trying to be 'clever' and is changing it because it thinks it knows better?! A while back, I came across a plugin that was calling Windows DPI scaling functions, which it definitely shouldn't have been doing under any circumstances (it's the hosts job to worry about things like that). Maybe one of your plugins is misbehaving? That might explain it. I did some Googling, and app compatibility settings (of which high DPI scaling is one) are stored in the registry here: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers @jono grant If you're familiar with the registry, please would you send me a screenshot of the Cakewalk.exe entry in there? You might want to try deleting it to see if that makes any difference (at your own risk, of course). FWIW, I tried setting the high DPI scaling override and then deleted the corresponding registry entry with no ill effects.
  14. Hi Jono, That's very odd. I haven't heard of anything like this, apart from maybe one guy who had to set some custom DPI settings or CbB would crash on startup (which should now be fixed anyway, at least in the latest Early Access release). When you say "I'm continually going in and having to set the scaling over and over again", what is it that you're doing specifically? Are you going into Windows Settings to set it to 150% again, or something else? Also, what version of Windows are you using? Thanks, Ben
  15. A fix for this will be in the next release!
×
×
  • Create New...