Jump to content
  • 0
MitchNC

No MIDI input

Question

Boy did I pick the wrong time to get back into it.  Or maybe the right time?

I've been a Cakewalk/Sonar user since floppies.  I've been out of it for a few years.  After pulling out my hair trying to get Sonar to work on my new PC I installed Cakewalk by Bandlab.

Here's my issue.  My keyboard is a Yamaha MOXF8.  I'm using the latest Steinberg/Yamaha USB driver.  When I create an instrument and MIDI track, I get no MIDI input activity on the meters.  However I DO get the little flashing lights in the systray MIDI icon.  As an addition check I can run MIDI OX and show that all my MIDI data is being received from the keyboard.

I can use the mouse on the GUIs of the various VSTs and the notes play.  I can paste midi data into the MIDI track and it plays through the VST just fine.  I can also step sequence and it plays fine.

I'm just getting no MIDI input between the OS and Cakewalk (Wow, it's hard not to type Sonar).

I'm using Win 10 64-bit.  I have the latest Steinberg drivers, and I have uninstalled/reinstalled them just as a check.  I have MIDI echo enabled.  

I have rebooted the PC and keyboard many, many times over the past 24 hours.
Edit:  I also removed my WiFi adapter and closed all other apps.

Here's the thing:  IT WORKED YESTERDAY!!!!!!!!!!!!
It stopped working in the middle of a session and hasn't worked since.

Anyone have a magic bullet that I'm just not seeing?  Sweetwater says switch to Cubase.  But I've been a loyal Cakewalk user since before Ted Perlman was talking about Celery.

Edited by MitchNC

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
Quote

 

O holy cow.  I did this yesterday, but apparently I must have copied the INI file and didn't delete the original

I just did this and it works!  Thank you so much.

Is this something I'll have to do from time to time?

Share this post


Link to post
Share on other sites
  • 0

Maybe

Don't see many threads like this but allowing the program to restore the default file seems to work every time.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, MitchNC said:

When I create an instrument and MIDI track, I get no MIDI input activity on the meters. 

For future reference, MIDI meters are always output meters, even when the MIDI track is armed to record.  My first guess would have been that input echo was not enabled so there would be no output from live input and thus no meter activity.

Share this post


Link to post
Share on other sites
  • 0

MIDI Echo was always enabled, as part of my troubleshooting before ever posting here.

I tried a hundred things.  It was the .ini file that did it.

Now on to the next issue...

Share this post


Link to post
Share on other sites
  • 0

So it turns out I have to delete the TTSSEQ.ini file every time I run Cakewalk or I have no MIDI.
I guess if that's what I have to do I'll do it.  But I don't believe that's intended behavior.  :)

 

Share this post


Link to post
Share on other sites
  • 0

No, this is not normal. Possibly related to the stability issues you have reported elsewhere.

Share this post


Link to post
Share on other sites
  • 0

You're not alone with the Midi problem...I've had to delete TTSSEQ.ini every time I start Cakewalk...or Splat for that matter. It started probably 3 or 4 updates back in Splat. I'm just used to deleting TTSSEQ.ini, opening Cakewalk(or Splat), and re-choosing my Midi interface. Thought I was the only one with this problem...welcome to the club! 😉

Bill

Share this post


Link to post
Share on other sites
  • 0

I am having this issue as well, and had opened up another thread (sorry, hadn't seen this one first).  I am out of nowhere forced to rename or delete TTSSEQ.ini now, every time I want to launch Cakewalk, or I have no midi data detection by Cakewalk for any midi data coming from my Roland A-800 Pro midi controller.

I am continuing to experiment and debug, and if I come across anything that seems to work better, I will post here, as well as in the thread I started.

Bob Bone

 

Share this post


Link to post
Share on other sites
  • 0

OK here is an update - I do not know how to get a permalink to paste here, so I will paste in a link to my other thread.  Please scroll down to the bottom of that, to see my update, as for ME, something in a few things I tried seems to have gotten things back to working properly:

Bob Bone

Share this post


Link to post
Share on other sites
  • 0

I know I'm very late to this game, but hopefully my reply will help others. I just had this issue happen to me also on Sonar Platinum Producer Edition after years of it working perfectly. I too went crazy trying to figure it out, which luckily I did fairly quickly. The problem in my case started after I unplugged my NanoKontrol2. Just like everyone else experiencing this issue, I could see MIDI activity in the task bar and also stand-alone virtual instruments worked fine outside of Sonar.  I've had an AlphaTrack for years and regardless of if it was plugged in or not this had never happened, so it took me a minute to figure out the issue. Now that I think of it, I had also used the NanoKontrol2 before and unplugged it, and I didn't have this issue.

In my case the culprit was MMcL Mackie Control which I downloaded and installed a few weeks back. Now, I'm not 100% sure if the problem was caused by this program specifically or if this happens when you're using other control surfaces that use Mackie Control and then disconnect them from your system, but MMcL Mackie Control reassigned its midi input to my USB MIDI cable once the NanoKontrol2 wasn't plugged in. I downloaded the software following a link on this forum from one of our fellow users, msmcleod, and it works beautifully with the NanoKontrol2, so kudos to msmcleod. The solution is very simple. Go to Preferences and under Controller/Surface find MMcL Mackie Control (or any other control surface) and make sure that under input it isn't using the input your MIDI controller is connected to. In my case it was my USB MIDI cable. Like I said, I'm not sure if the issue is specifically with MMcL Mackie Control or with the Mackie protocol in general, but I had used my NanoKontrol2 before and unplugged it and this had never happened until I installed MMcL Mackie Control a few weeks ago. Hope this helps someone and thanks to msmcleod for the NanoKontrol2 software. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...