Jump to content
sapfir

Vocoder for a beginner

Recommended Posts

Hello, I am trying to get TAL Vocoder to work on Cakewalk, but even though I am following all the instructions (http://forum.cakewalk.com/TAL-Vocoder-setup-in-Sonar-7PE-m1662193.aspx is my main source) I cannot get it to work. I'm a relative beginner in audio editing (haven't used buses yet), so maybe I'm missing something really obvious. Would you recommend a different vocoder to start with? Any help would be much appreciated!

Share this post


Link to post
Share on other sites

TAL Vocoder is a good one to start with.

I would not rely on any posts older than SONAR Platinum for signal routing. Better yet, search this forum for current info before going to the old forum.

The trick is learning about routing MIDI in Cakewalk. I posted a general guide here

And here are a couple of more recent threads about TAL Vocoder that may help

 

  • Like 3

Share this post


Link to post
Share on other sites

For some reason, I am not able to select "Enable MIDI Output" or select the MIDI track's output.

Share this post


Link to post
Share on other sites

"Enable MIDI Output" is located on the standard header above the plug-in UI

WBoEAIf.png

It is selected by default for synths but not for FX like TAL Vocoder..

After adding the plug-in to the FX rack, open the plug-in UI and select the option.

Without "Enable MIDI Output" selected, there is no way to send MIDI data to the plug-in.

Share this post


Link to post
Share on other sites

The "Output" option is gray and unavailable. I've been trying to select "Input", but the checkmark never appears. Should I try reinstalling Cakewalk?

Share this post


Link to post
Share on other sites

Not all plug-ins can send or receive MIDI data.

The TAL Vocoder does not send MIDI data so "Enable MIDI Output" is disabled.

It can receive MIDI data so "Enable MIDI Input" is available. This is the option that needs to be enabled for the plug-in to appear in a MIDI track's output drop down. IOW, the plug-in must be set to receive MIDI data in order for a MIDI track to send it data.

I doubt re-installing the DAW will make a difference but you can always try it.

 

 

Share this post


Link to post
Share on other sites
16 hours ago, sapfir said:

For some reason, I am not able to select "Enable MIDI Output" or select the MIDI track's output.

You don't need MIDI Out. You only need MIDI In.

Share this post


Link to post
Share on other sites

For Cakewalk:

Drop the TAL Vocoder into an FX Bin on an audio track. Enable MIDI in on the plugin.

Add a MIDI track and make sure it is receiving input from your controller. Set the output to TAL Vocoder.

Play an audio source through the audio track (you can also loop an audio clip to test), that is your modulation source. Play your controller (send MIDI to TAL), by default TAL uses the internal VCO as the carrier. Leave "Input mode" unselected on the TAL GUI.

Share this post


Link to post
Share on other sites

I still think cakewalk need to get this to be independent and not dependent on playing it live (if that make sense.) 

What I mean by this is: Let us do this in the daw as well with the piano roll. (Vitually too) like how FL and Logic does this. 

Unless i'm missing the boat, but for years I've been physically playing it in with the vocal. 

Share this post


Link to post
Share on other sites
6 hours ago, Will_Kaydo said:

I still think cakewalk need to get this to be independent and not dependent on playing it live (if that make sense.) 

What I mean by this is: Let us do this in the daw as well with the piano roll. (Vitually too) like how FL and Logic does this. 

Unless i'm missing the boat, but for years I've been physically playing it in with the vocal. 

I'm totally missing the boat with what you are trying to say. There is nothing in the current Cakewalk setup that prevents you from using the DAW the way that you wish.

The only requirement is that you send MIDI notes to the Vocoder to trigger the "carrier" oscillator. This could be done with the piano roll on a MIDI track, with output to the Vocoder.

So live playing is not necessary.

  • Like 1

Share this post


Link to post
Share on other sites

My problem is that I am unable to select either option. The "output" option is greyed out and cannot be clicked, and no checkmark appears next to the "input" option when I click on it. I've already uninstalled and reinstalled Cakewalk and nothing's changed.

Share this post


Link to post
Share on other sites
2 hours ago, sapfir said:

My problem is that I am unable to select either option. The "output" option is greyed out and cannot be clicked, and no checkmark appears next to the "input" option when I click on it. I've already uninstalled and reinstalled Cakewalk and nothing's changed.

The MIDI out MUST be greyed out because the vocoder has no MIDI output to enable.

If the tick doesn't appear try reinstalling the VST.

Share this post


Link to post
Share on other sites
9 hours ago, sapfir said:

My problem is that I am unable to select either option. The "output" option is greyed out and cannot be clicked, and no checkmark appears next to the "input" option when I click on it. I've already uninstalled and reinstalled Cakewalk and nothing's changed.

The "output" option is supposed to be greyed out on an effect like TAL Vocoder that has no MIDI output. The only MIDI output you need be concerned with is the one of the MIDI track you're going to use to send MIDI data to the plug-in.

So when you open the UI of the TAL Vocoder plug-in, and you click on the "VST2" button, you are unable to select "Enable MIDI Input" from the menu that appears? What should happen is that you pull the menu down, move your cursor to "Enable MIDI Input," then release. The menu will close. When you open the menu again, the menu should show "Enable MIDI Input" with a check mark.

I know of no circumstances where that wouldn't work, not from a damaged Cakewalk installation nor anything wrong with the plug-in (if you can see the UI, the plug-in is installed correctly). There are only 3 steps in my instructions, it doesn't require any special knowledge, there's no easier vocoder option than this. It's not complicated or difficult once you know how to route it, which you get from the steps I wrote.

After that, well, vocoders are kinda tricky to set all their levels up correctly, with the two different signals going in. But that's not the scope of what I wrote, I tell you how to install it correctly. Once you do that it's up to you to make sure that the audio on the track is good and that you're sending notes in the vocoder's appropriate range.

Are the other plug-ins on your system in the same condition, or will they allow you to enable their MIDI input?

Share this post


Link to post
Share on other sites
10 hours ago, sapfir said:

My problem is that I am unable to select either option. The "output" option is greyed out and cannot be clicked, and no checkmark appears next to the "input" option when I click on it. I've already uninstalled and reinstalled Cakewalk and nothing's changed.

TAL Vocoder doesn't need to output anything. The output should be grayed out. It is a effect VST that inserts on an audio track (that is the modulator for the vocoder). A MIDI input modulates it.

Did you do these steps exactly?

  • Drop the TAL Vocoder into an FX Bin on an audio track. Enable MIDI in on the plugin.
  • Add a MIDI track and make sure it is receiving input from your controller. Set the output to TAL Vocoder.
  • Play an audio source through the audio track (you can also loop an audio clip to test), that is your modulation source. Play your controller (send MIDI to TAL), by default TAL uses the internal VCO as the carrier. Leave "Input mode" unselected on the TAL GUI.

Share this post


Link to post
Share on other sites
4 hours ago, Starship Krupa said:

So when you open the UI of the TAL Vocoder plug-in, and you click on the "VST2" button, you are unable to select "Enable MIDI Input" from the menu that appears? What should happen is that you pull the menu down, move your cursor to "Enable MIDI Input," then release. The menu will close. When you open the menu again, the menu should show "Enable MIDI Input" with a check mark.

When I click on the VST3 button (I don't see VST2 anywhere), the menu doesn't open until I release the mouse. Then I click on the "Enable MIDI Input" and the menu closes. But when I open the menu again, I don't see any checkmark.

  • Confused 1

Share this post


Link to post
Share on other sites

Make sure to use the latest version of the TAL Vocoder from their website

The label on the drop down in the standard header depends on the plug-in format.

Share this post


Link to post
Share on other sites

The instructions are from when I was using the VST2 version, but it's the same thing for the VST3 version. I am stumped, I don't know why it's not allowing you to enable MIDI input.

One thing you can try is use Cakewalk Plug-In manager to force a re-scan of your plug-ins. It launches from the main Utilities menu. The button that triggers this is toward bottom center of the program's UI. It could be that Cakewalk somehow missed the fact that TAL Vocoder has MIDI input available.

Share this post


Link to post
Share on other sites
5 minutes ago, Starship Krupa said:

One thing you can try is use Cakewalk Plug-In manager to force a re-scan of your plug-ins. It launches from the main Utilities menu.

While the VST scanner may still be called from the plug-in manager, the recommendation for years now is run the scanner from preferences

The plug-in manager does not have access to all the features provided when running the scanner from preferences.

The OPs problem does not read like a scan problem but a VST Reset would not hurt.

  • Thanks 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
1 minute ago, scook said:

The OPs problem does not read like a scan problem but a VST Reset would not hurt.

Thanks for the heads-up on scanning from Preferences.

I'm just clutching at straws at this point. Do you have any ideas as to what might actually be going on here, not being able to turn MIDI input on?

Share this post


Link to post
Share on other sites

This is the first time I have read a report like this.

I would make sure to  download the latest version of the plug-in from the manufacturer.

After installing and scanning, retry setting up the plug-in in a new project created from the CbB basic project template.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...