Jump to content
Sign in to follow this  
Lee D

Arturia Keylab MK2 in Cakewalk

Recommended Posts

Does anyone have a Keylab MK2 keyboard working successfully in DAW mode?  I am setting the Keylab to Mackie MCU protocol but Cakewalk refuses to connect to it.  The ACT just says "Connecting".    I tried various things for an hour last night such as re-installing, deleting the mapping files in the %appdata% folder, but nothing works.

I have my MIDI inputs set to the MK2 Input and the MIDI IN 2 and the output set to MIDI OUT 2.  The Mackie Control Universal control surface is set to use the MIDI IN 2 / MIDI OUT 2.

If I remove the Control Surface from Cakewalk setup, I can verify that note data is being received when I push the various transport control buttons on the MK2.

I know there's a workaround to get the transport controls working but I want the whole thing working where the sliders control volume for the different tracks, etc.  

Works OK in other DAWs (Studio One, Reaper, FL Studio).  

Share this post


Link to post
Share on other sites

Replace mackiecontrol.dll with the one from https://github.com/msmcleod/Cakewalk-Control-Surface-SDK/tree/master/Bin/x64

That is a mod from msmcleod, more advanced then my own (since I do not have any mackie device). It has "disabled handshake" setting, once set you will not longer see "Connecting".

If you ever hit the limit with what you can do in using Mackie plug-in, you can dive into AZ Controller programming. But I guess you do not need that long way 😉

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

Replace mackiecontrol.dll with the one from https://github.com/msmcleod/Cakewalk-Control-Surface-SDK/tree/master/Bin/x64

That is a mod from msmcleod, more advanced then my own (since I do not have any mackie device). It has "disabled handshake" setting, once set you will not longer see "Connecting".

If you ever hit the limit with what you can do in using Mackie plug-in, you can dive into AZ Controller programming. But I guess you do not need that long way 😉

Thanks!  Is there a way to configure the same in the Cakewalk settings or editing a file myself rather than downloading a .dll file.  Makes me a little nervous.

Share this post


Link to post
Share on other sites

Unfortunately I tried this evening with no success. . . still giving the "Connecting" message no matter what I do :(

Share this post


Link to post
Share on other sites
8 hours ago, azslow3 said:

Replace mackiecontrol.dll with the one from https://github.com/msmcleod/Cakewalk-Control-Surface-SDK/tree/master/Bin/x64

That is a mod from msmcleod, more advanced then my own (since I do not have any mackie device). It has "disabled handshake" setting, once set you will not longer see "Connecting".

If you ever hit the limit with what you can do in using Mackie plug-in, you can dive into AZ Controller programming. But I guess you do not need that long way 😉

Does this also get rid of the mackie heartbeat, you know how it constantly transmits a midi signal.

Share this post


Link to post
Share on other sites
2 hours ago, Lee D said:

Unfortunately I tried this evening with no success. . . still giving the "Connecting" message no matter what I do :(

Have you opened its GUI (f.e. from Utilities Menu) and set "Disable handshake" option? When everything is correct, there should be no more "Connecting..." (even without any device attached).

2 hours ago, Tezza said:

Does this also get rid of the mackie heartbeat, you know how it constantly transmits a midi signal.

I do not remember exactly, at least some Mackie devices can think that the connection no longer exist and so there is no reason to work when there is no heartbeat. But I think that was HUI, not MC.

8 hours ago, Lee D said:

I guess you're a computer programmer of some sorts, eh? :)

Some of us are more programmers then musicians (I mean professional programmer and hobby musicians). I am a one of such kind 😉

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

As far as I can remember there was no heartbeat for the MCU, but there's definitely one for HUI.

The handshake was a specific bit of SysEx on startup that was in the original MCU protocol. Mackie got rid of this in subsequent revisions, but the Cakewalk code was never updated at that point.

The MCU clones that support SONAR/CbB have a specific mode to react to the SysEx message that SONAR/CbB sends to it on startup, but all the ones I've seen work fine if they never receive that message. Disabling handshake just removes that whole sysex procedure altogether.

@Lee D - where are you seeing the "Connecting" message? Is this in CbB or on the KeyLab itself?

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, azslow3 said:

Have you opened its GUI (f.e. from Utilities Menu) and set "Disable handshake" option? When everything is correct, there should be no more "Connecting..." (even without any device attached).

 

I'm not sure where that would be located?  I opened the ACT controller configuration where it shows the various settings for the Mackie controller in Cakewalk and didn't see an option to disable handshake.  Which "Utilities menu" are you referring to?

6 hours ago, msmcleod said:

 

@Lee D - where are you seeing the "Connecting" message? Is this in CbB or on the KeyLab itself?

It's in the ACT Controller box in the ribbon/console at the top of Cakewalk.  

Share this post


Link to post
Share on other sites

@Lee D - to set things up:

First of all, make sure you've got your Control Surface type set correctly within Preferences, using the MMcL version:

mmcl_mackie.png

Here's the difference between them:

image.png.24b4ef1480b38e308d9a0418454e71f5.png

Next, use the Utilities menu to bring up the Mackie Control dialog (it should be at the bottom of that menu), and make sure Disable Handshake is checked:

(ignore the fact it's unchecked in this example - I'm at work, and haven't got CbB available so I'm using the only screenshots I have available!):

image.png.31f6aa8f332f8da3ff767f6962c03735.png

Then, save this as a preset by giving it a name in the dropdown in the top left, and clicking the save icon. Then click OK to close the dialog.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, msmcleod said:

@Lee D - to set things up:

First of all, make sure you've got your Control Surface type set correctly within Preferences, using the MMcL version:

mmcl_mackie.png

Here's the difference between them:

image.png.24b4ef1480b38e308d9a0418454e71f5.png

Next, use the Utilities menu to bring up the Mackie Control dialog (it should be at the bottom of that menu), and make sure Disable Handshake is checked:

(ignore the fact it's unchecked in this example - I'm at work, and haven't got CbB available so I'm using the only screenshots I have available!):

image.png.31f6aa8f332f8da3ff767f6962c03735.png

Then, save this as a preset by giving it a name in the dropdown in the top left, and clicking the save icon. Then click OK to close the dialog.

 

Ah OK I didn't notice the "Disable Handshake" there. . . I will try it later, thank you!

Share this post


Link to post
Share on other sites
16 hours ago, msmcleod said:

As far as I can remember there was no heartbeat for the MCU, but there's definitely one for HUI.

 

Thanks for clearing that up. I had an issue with a Novation Launchkey, when I looked at my midi monitor (I don't know what DAW I was using at that time) it showed a continual pulse, c2 note off I understand. At the time I didn't know what it was but it filled up my midi monitor and I couldn't see anything else. At first I thought it was a faulty keyboard and then found out about the "heartbeat". After that experience I said no more to "mackie control" because that's what I thought was causing it. When I see keyboards that only offer "mackie control" as a means for the keyboards onboard transport etc  to communicate with the DAW, I look elsewhere. I wasn't aware of the difference between HUI and MCU.

Share this post


Link to post
Share on other sites
13 hours ago, msmcleod said:

@Lee D - to set things up:

First of all, make sure you've got your Control Surface type set correctly within Preferences, using the MMcL version:

mmcl_mackie.png

Here's the difference between them:

image.png.24b4ef1480b38e308d9a0418454e71f5.png

Next, use the Utilities menu to bring up the Mackie Control dialog (it should be at the bottom of that menu), and make sure Disable Handshake is checked:

(ignore the fact it's unchecked in this example - I'm at work, and haven't got CbB available so I'm using the only screenshots I have available!):

image.png.31f6aa8f332f8da3ff767f6962c03735.png

Then, save this as a preset by giving it a name in the dropdown in the top left, and clicking the save icon. Then click OK to close the dialog.

 

Fantastic!  Works great now.  The transport buttons all work except for the "loop" button, the track select buttons, faders, and knobs all work as well. 

Some of the buttons are mapped a little bit incorrectly for the controls. .  i.e. the loop button doesn't seem to do anything but the "metronome" button enables loop mode, etc.  I can't edit the messages the Arturia is sending in this mode, is there a way to edit the configuration on the receiving end to interpret it as a different command?

Thanks so much for the help, that makes a huge difference.

Share this post


Link to post
Share on other sites
5 hours ago, Lee D said:

Fantastic!  Works great now.  The transport buttons all work except for the "loop" button, the track select buttons, faders, and knobs all work as well. 

Some of the buttons are mapped a little bit incorrectly for the controls. .  i.e. the loop button doesn't seem to do anything but the "metronome" button enables loop mode, etc.  I can't edit the messages the Arturia is sending in this mode, is there a way to edit the configuration on the receiving end to interpret it as a different command?

Thanks so much for the help, that makes a huge difference.

The Mackie Control Universal, and the Mackie MCU Pro both come with a set of overlays for different DAW's which re-label the buttons to better map to the functions available on each DAW.

One of these is an overlay for SONAR/Cakewalk, which is what the MackieControl DLL expects the buttons to be mapped to. Any MCU compatible control surface that has a SONAR mode will map their buttons to this configuration. 

With no overlay, the buttons are as follows:

image.png.17ee8e90a959abf2b61ea792c35618fb.png

The SONAR/Cakewalk overlay looks like this:

image.png.7cb35bc3dc0b4da3915e55b10e530505.png

So as you can see, the CLICK button on the standard button configuration is the same as LOOP ON/OFF on the SONAR overlay. This is why the "Metro" button on the KeyLab controls looping.

Automation read looks like it's mapped the same, but there's no equivalent for automation write. "In" and "Out" also have no Cakewalk equivalents.

There's no way of configuring the button mapping at present. To do so would require a fair amount of work, and would make setting a control surface up even more complicated than it already is. Although its possible to have presets for various control surfaces, given I don't have all of them, it's not something I'd want to commit to code without actually testing it.

In the meantime, you could try setting the KeyLab to ProTools mode and changing the protocol to HUI within the MMcL MackieControl dialog.

I can't guarantee that all the buttons will work (as mentioned earlier - not all of them have Cakewalk equivalents in the MackieControl DLL), but they may more closely match the buttons on the KeyLab.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
On ‎8‎/‎8‎/‎2019 at 2:56 AM, msmcleod said:

The Mackie Control Universal, and the Mackie MCU Pro both come with a set of overlays for different DAW's which re-label the buttons to better map to the functions available on each DAW.

One of these is an overlay for SONAR/Cakewalk, which is what the MackieControl DLL expects the buttons to be mapped to. Any MCU compatible control surface that has a SONAR mode will map their buttons to this configuration. 

With no overlay, the buttons are as follows:

image.png.17ee8e90a959abf2b61ea792c35618fb.png

The SONAR/Cakewalk overlay looks like this:

image.png.7cb35bc3dc0b4da3915e55b10e530505.png

So as you can see, the CLICK button on the standard button configuration is the same as LOOP ON/OFF on the SONAR overlay. This is why the "Metro" button on the KeyLab controls looping.

Automation read looks like it's mapped the same, but there's no equivalent for automation write. "In" and "Out" also have no Cakewalk equivalents.

There's no way of configuring the button mapping at present. To do so would require a fair amount of work, and would make setting a control surface up even more complicated than it already is. Although its possible to have presets for various control surfaces, given I don't have all of them, it's not something I'd want to commit to code without actually testing it.

In the meantime, you could try setting the KeyLab to ProTools mode and changing the protocol to HUI within the MMcL MackieControl dialog.

I can't guarantee that all the buttons will work (as mentioned earlier - not all of them have Cakewalk equivalents in the MackieControl DLL), but they may more closely match the buttons on the KeyLab.

 

 

Thanks again.  I tried the ProTools mapping as well with the HUI.  The loop button was correctly mapped but some of the other buttons didn't work as well, so overall I think the Standard MCU is the better fit.  Really appreciate your help and also your efforts on making that software!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...