Jump to content
Sign in to follow this  
Raj G

WASAPI Exclusive issue

Recommended Posts

Hi,

I am using the latest Cakewalk by Bandlab. I have Lynx E22 sound card that has 2 Analog outs and 2 Digital outs. There are 2 device outputs Play 1+2 and Play 3+4. I want Cakewalk to use Play 1+2 and windows default sound output device is Play 3+4.  Lynx Mixer then combines both of them and sends sound via analog outs. This works just fine with ASIO and I can hear both Cakewalk and windows sound together.

There are some driver issues with ASIO at >=96kHz sample rate (which are not related to Cakewalk). So, I switched to using WASAPI Exclusive. In WASAPI exclusive, I am only using Play 1+2 (and I have deselected Play 3+4 as output). However, Cakewalk also 'locks up' Play 3+4 and I cannot hear both Cakewalk and Windows sound together.

Any suggestions on how to fix this?

Osho

Share this post


Link to post
Share on other sites

Most Windows programs do not use ASIO. It is not unusual for Windows programs to work along side a program using an ASIO driver.

AFAIK WASAPI Exclusive is just that...a driver for exclusive use of one program with the device.

To share the device a different driver must be selected.

 

Share this post


Link to post
Share on other sites

A couple of things:

1. WASAPI Exclusive isn't supported by all sound devices.

2. In WASAPI Exclusive mode, Cakewalk takes exclusive control of the sound device... which means it won't share it with Windows.

You've two choices:

1. Use WASAPI Shared; or
2. Continue to use WASAPI Exclusive, but check "Suspend Audio Engine When Cakewalk is not in Focus"

Share this post


Link to post
Share on other sites
Posted (edited)

I am a pianist and use Cakewalk for piano VST live playback and recording. WASAPI Shared is not an option due to much higher latency. Suspending Audio Engine when Cakewalk is not in focus is not an option because I need to hear Windows sound (from pianomarvel.com) when playing Piano VST.

Reaper does not have this problem with WASAPI Exclusive, i.e. Reaper just uses Play 1+2 and Windows sound come via Play 3+4. No issues. Similarly, if I use a Piano VST software directly (e.g. Pianoteq), this issue does not exist. Reaper and Pianoteq can use Play 1+2 without locking Play 3+4. So, it is certainly possibly to only use Play 1+2 in exclusive mode.

I prefer to use Cakewalk - works much better for my usage (and I just like its GUI better). It would be great if it only locked the output devices that are checked in the preferences when using Windows exclusive mode.

Osho

Edited by Raj G

Share this post


Link to post
Share on other sites

So the reason you can't use the configuration that works (ASIO) is that there are problems with 96 KHz and above? Is there a reason why you need to run the interface at 96 KHz? Does Pianoteq sound better at the higher rate, or are you just doing it for the lower latency?

Share this post


Link to post
Share on other sites
2 hours ago, bitflipper said:

So the reason you can't use the configuration that works (ASIO) is that there are problems with 96 KHz and above? Is there a reason why you need to run the interface at 96 KHz? Does Pianoteq sound better at the higher rate, or are you just doing it for the lower latency?

Pianoteq does sound better at 96kHz and 192kHz. The latency is fairly comparable though. And, I bought a relatively expensive PCIe card - Lynx E22 - just so I could use it at 96kHz or 192kHz.

Osho

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...