Jump to content
  • 0
Tim White

Project audio sounds horrible now

Question

hello all, 

I'm loving everything that Bandlab is doing to cakewalk, I'm a long-time user. However, I updated to 2019.11  (build 54, 64 bit)about an hour ago and opened a project I've been working on and it sounds HORRIBLE. It's as if there's an 8-bit effect, or KT granulator effect (low-res, distorted, maybe even slowed-down) on the entire project.  I've opened other projects and they all sound like this.  However, when I export to .mp3 it sounds fine, so I can't let you hear what i'm hearing. 

I've looked at my drivers and bit rate and I have made no changes since I last mixed this project.

Windows 10 64-bit

ASIO drivers

Focusrite, Saffire pro 40 interface

let me know what other info you need from me, i've added a screenshot

any help is appreciated!

 

Capture.PNG

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 1

As a user (not staff or even a power user) and on the outside chance that my experience yesterday might help one or two  cases of noise/distortion, I add my experiences from yesterday: 

image.png.dcfbb00f02d823923e61de00c8977f1a.png   image.png.0efdca18517dbb944bdd9dfbc3e31756.png  image.png.49070bc43040fe9e420a0feaf7af5f37.png

 

Edited by User 905133
to fix a typo

Share this post


Link to post
Share on other sites
  • 0

@Tim White - we've had a handful of reports from users with similar issues, and we're currently investigating the cause.

In the meantime, there's a few things you could try:

1. If Windows is set to use the same audio device as Cakewalk, check the sample rates & bit depths within Windows are set to the same as Cakewalk.

2. Change your driver mode to something else, then back again (i.e. if you're using ASIO, change to WASAPI, play a project, then set it back to ASIO again)

3. Come out of Cakewalk, go to %APPDATA%\Cakewalk\Cakewalk Core, rename AUD.INI to AUD.INI.bak and restart Cakewalk. Note after doing this, you'll have to check the following are correct within in Preferences:

  • Audio / Audio Driver Settings - particularly Audio Driver Bit Depth
  • File / Folder Locations
  • File / Audio Data - particularly, the Global Audio Folder, Picture Folder and File Bit depths.

If any of these solves your issue, please let me know so we can advise other users.

Share this post


Link to post
Share on other sites
  • 0

@User 905133 THANK YOU!

I only changed the buffer size to 20.0 msec and 882 samples and that fixed it!  

to @msmcleod FYI, I changed the AUD.INI file name as you suggested, but that didn't make a difference. 

 

I'm assuming the update changed the Buffer size?

 

thank you

Edited by Tim White

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, David Baay said:

That's a high buffer setting. Is the project pushing your CPU that hard?

@David Baay Thanks for opening up the opportunity for me to clarify.  I should have emphasized the method, not the specific numbers.  The method was to start low with problematic  audio and increase each of the two parameters a notch until the problem went away and to confirm the solution by backing the numbers down.  I had those graphics handy from looking at MME mode (based on another noise issue, IIRC).

@Tim White Sorry if I misled you with those specific numbers. 

I am sure at some point I used the same process to set the settings for ASIO mode.  I recall tweaking numbers to get rid of an audio glitch that occurred when I had audio playing back and switched Workspaces (formerly Lenses).  Generally, I have my sound card's ASIO Control Panel set to the lowest value possible--usually 2.  For many tasks, that is sufficient.  (See screenshots below.)

I will change it notch at a time depending of what else my computer is doing--such as when I am designing a Workspace and I don't want the glitch.  For that I moved the setting to 3 then 4, again using the ASIO Control Panel for my Sound Card. (See screenshots below.)

Today, I discovered something unusual with a Workspace I have been working on and decided to grab real time video using OBS Studio. That upped the distortion quite high since my PC was working much harder running both.  I didn't grab any screenshots, but I did bump up my settings so Cakewalk would play smoothly and I could capture the visual oddity I was experiencing.

After that I put back the lower settings.

Again, apologies for not spelling out the method and appearing to be recommending what is probably a higher latency than you need.

image.png.92a01467014673a463027c1ed85d70eb.png    <== My usual ASIO panel setting      image.png.3448ccb5312d7ae79ee59e5a56264a29.png  <== Cakewalk's settings based on 2 ms in ASIO panel [44.1KHz]

   image.png.f6de10a27e2a965e472702490b8ba3cc.png  <== Manually upped as needed         image.png.b1b307eb9bebe8c66b0f2551706b619e.png<== Cakewalk's settings based on 4 ms in ASIO panel [48KHz]

Please note: These screenshots are from 2 different projects, one at 44.1 KHz and another at 48 KHz.  Not suggesting you use these numbers; just trying to show one method (I am sure there are others!) for reducing noise/distortion while trying to maintain low latency as needed for specific tasks.

If this helps meet your specific needs, great.

Steve

Edited by User 905133
to delete "to"

Share this post


Link to post
Share on other sites
  • 0

I think Mark will confirm that Cakewalk has no mechanism to force a buffer size change. Though it might not be the whole story behind the issues you've encountered, any change in the buffer size wasn't directly due to the update.

Share this post


Link to post
Share on other sites
  • 0

@David Baay that makes sense, probably just a coincidence. I didn’t mention that this also occurred with audio (.wav) imported into cakewalk which I found even more strange. I had digitized some old 4-track cassette recordings in Audacity which sounded fine, but when I imported those files into cakewalk they sounded horrible. 

Share this post


Link to post
Share on other sites
  • 0

@Tim White I don't think your problem had anything to do with the update. The fact that increasing your latency fixed it means that you had set the latency too low at some point or some other app changed the driver latency.

When you opened Cakewalk it picked up the change since ASIO latency settings are global. The distortion is because buffers are being skipped. There is a DropoutMsec value in settings that controls this. It's quite high by default so the app doesn't drop it but you can hear noise. If the latency is too low.

I plan to add a notification when this happens for better troubleshooting.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...