Jump to content
David Terry

Presonus Faderport Classic - Issue not addressed any where I can find.

Recommended Posts

I've already done a search on the forums and through google for this and spent nearly 3 hours trying everything I can think of to get the Presonus Faderport Classic to work with Cakewalk by Bandlab, and could sure use some help if anyone can help.

First, I have tested the FaderPort in Pro Tools and it worked exactly as expected after following instructions on the first go, so I do not think the problem is the hardware itself.

I will give more detail on steps I have taken below, but the TL:DR version is that everything seems to go as manual instructs when setting up in Cakewalk MIDI preferences except when I go to the "Add new Controller/Surface" window with the yellow button.  The FaderPort does not show up in the first "Controller/Surface dropdown list, although it does show up in both the "Input Port" and "Output Port" dropdowns.

I have tried using the "Mackie Control" option under "Controller/Surface" dropdown since I had read that should work, but nothing.

Yes, I have made sure the "Key Aftertouch" and "Channel Aftertouch" options are both checked.

Does anyone know why the Presonus FaderPort wouldn't show up in the dropdown list?  Any potential solutions apart from simply repeating back to me the steps I have already followed a dozen times would be much appreciated.  Thanks in advance!

_________________________________________________

In case someone suspects I missed a step, below are the steps I have followed:

Downloaded and installed latest driver from Presonus

Faderport shows up with Universal Control app

I've gone into Cakewalk settings and done the following (this is just an exact repeat of what is in the manual and many places online, but I will list it to make sure you understand I have followed all steps.

1. In Sonar, go to Options | MIDI Devices and select USB Audio Device for both the Input Port and the Output Port. Click "Apply"

2. Go to Options | Control Surfaces and click the yellow plus sign.

3. Tried to select PreSonus FaderPort as Controller/Surface - DOES NOT SHOW UP IN LIST

4. Selected "Mackie Control" instead to see if that would work.

5.  Select USB Audio Device for both Input Port and Output Port.  Click "Apply"

6. Go to Playback tab made sure both Key Aftertouch and Channel Aftertouch are checked. Click "Apply"

Nothing works.

 

Share this post


Link to post
Share on other sites

I think the issue is that the FaderPort classic integration is 32 bit only  (see page 6 of the user guide).

This is why PreSonus FaderPort isn't appearing in the list.

If it's working in ProTools however as HUI device, you could try my own version of the Mackie Control surface, which has basic HUI support:
 

After installation, there's a pdf guide in C:\Program Files\Cakewalk\Shared Surfaces\

 

 

Share this post


Link to post
Share on other sites

Wow, thank you so much for the super-quick reply!  You made that post you linked on the day I bought my used FaderPort (#timelyas*****). 😃

Originally, I was still not able to get it to work, but I finally found the right combo of settings (took me forever to find out where the Mackie Control plugin options were!  Seems to be working perfectly now!  The timing of your release is impeccable.  I was worried I was gonna have to drop a lot more money on something newer when literally all I want is a motorized fader because I'm tired of drawing volume automation after 100 years, and transport control at this point will be nice.  I started with Cakewalk on version 3... as in Pre Sonar, Pre Pro Audio.  I think it was the first version that supported audio at all.

  Again, thanks so much!

 

Edited by David Terry
I figured out what I was doing wrong, so erased all of my questions.
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

Another option: http://www.azslow.com/index.php/topic,163.0.html

If buttons do not work as expected (but fader does), in the CbB preferences, MIDI, Playback and recording enable Key aftertouch.

And here I had your forum and a pertinent topic all queued up to post here...beaten to it by the maestro himself. Better you than me, anyway. Now the OP knows who to talk to (via your forum)!

Share this post


Link to post
Share on other sites

Seriously guys thanks so much for all the help.  I have been away from Cakewalk forums for a few years, and it's very cool that on my first post I got helpful replies and not trolling (as is more common on other forums these days!)

I got it working and have bookmaked both solutions.  Thanks again for the help!

Share this post


Link to post
Share on other sites

One thing about the Faderport Classic (and maybe the other models) to keep in mind is that it sends out a keep-alive MIDI message about 1/sec. I've had to be more careful to not use MIDI Omni. That keep-alive was triggering whatever VI was armed. Took me awhile to figure out. Now I explicitly specify the MIDI Input source for every VI.

Share this post


Link to post
Share on other sites
3 hours ago, John Maar said:

One thing about the Faderport Classic (and maybe the other models) to keep in mind is that it sends out a keep-alive MIDI message about 1/sec. I've had to be more careful to not use MIDI Omni. That keep-alive was triggering whatever VI was armed. Took me awhile to figure out. Now I explicitly specify the MIDI Input source for every VI.

If it does and AZ Controller is in use, Options/"Block all channel messages" and "Block all SysEx messages" should filter our the keep-alive (or dummy control can be assigned to it).

In HUI mode that is a different story, still that is the job of control surface plug-in to tell Cakewalk which messages should be filtered.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...