Jump to content
Jesse Jost

[CLOSED] Cakewalk 2019.09 Early Access

Recommended Posts

13 hours ago, TheSteven said:

Just started checking this out - first thing I've noticed is that this version of CbB starts up 10x faster than current release.

If you had tons of 32 bit plugins this is expected. There are optimizations to cache the inventory preventing too many registry accesses.

Share this post


Link to post
Share on other sites
19 hours ago, Noel Borthwick said:

@Jeremy Jensen I was mistaken. I had an experimental build with some other stuff that isn't compatible with Arturia synths.
I am not seeing any issues with Piano -V in the early access build.  Which version of the synth are you running exactly. I have Piano V2 from VCollection 7 Version 2.4.1 and this is working fine here. I saved a project from an earlier release and opened it up in 09 and it plays fine.

If you are still seeing this please reply to this post or contact me with a link to a project file that has this issue and I can troubleshoot further with you. 

Don't bother, I managed to work around this bug in older Arturia plugins. They go silent if we forward parameters to them when loading despite the plugin requesting the forwarding! I had to hack our code just for Arturia to avoid this.

Share this post


Link to post
Share on other sites
On 9/28/2019 at 10:26 AM, JL said:

i used to be able to hold shift and extend multiple clips by specific duration but i cant seem to do it in this version. Not sure if this is a feature that requires additional step to turn on in this release. here's a gif trying to show the issue. 

UPDATE: just realised its because of this new feature:
Holding SHIFT on Comp track (lanes collapsed) now allows for adjusting split location across lanes

is there a way to keep this feature, but still have the ability to extend the multiple clips by a specific duration?

clips.gif

@Noel Borthwick is there to bypass that new feature or has the key modifier for adjusting multiple clips at once been changed?

Share this post


Link to post
Share on other sites
3 hours ago, Noel Borthwick said:

@marled I cannot repro your clip selection issue. Can you post a short video or upload a small project that exhibits this?
Is this with the smart tool or another tool?

Sorry, but I am very old-fashioned, I do not have/use a video screen capture at the moment, even if it was convenient in such cases! 😆

Yes, I use(d) the Smart Tool. Having done some more tests I realized that it only happens when you click on the clip title for selection! It is very easy to reproduce:

  1. New project with one audio clip
  2. Split the clip
  3. Select the both clips
  4. Click with the Smart Tool on either clip title bar (with lanes closed or in a lane, it does not matter) => the selection is not changed!

In previous versions this did change the selection to the chosen clip. In the new release this is only possible if you click into the upper part of the clip under the title bar (first I did not realize this, because I was used to click the title bar for selection).

Share this post


Link to post
Share on other sites
2 hours ago, marled said:

Sorry, but I am very old-fashioned, I do not have/use a video screen capture at the moment, even if it was convenient in such cases! 😆

Yes, I use(d) the Smart Tool. Having done some more tests I realized that it only happens when you click on the clip title for selection! It is very easy to reproduce:

  1. New project with one audio clip
  2. Split the clip
  3. Select the both clips
  4. Click with the Smart Tool on either clip title bar (with lanes closed or in a lane, it does not matter) => the selection is not changed!

In previous versions this did change the selection to the chosen clip. In the new release this is only possible if you click into the upper part of the clip under the title bar (first I did not realize this, because I was used to click the title bar for selection).

What you were seeing in previous versions was actually a side effect of a bug which has now been fixed in 2019.09.

Notice that when you're clicking on the header using the smart tool, it's the Move tool that is engaged.

The bug was that when you cancelled a move operation, your selection was lost. So previously, clicking on the clip header whilst using the Move tool had the same effect of cancelling the move and clearing the rest of your selection.

Now this issue is fixed you can no longer use this side effect.

EDIT: Found a way for these to coincide. It'll be fixed for the general release, so clicking on the clip header will clear the previous selection.

  • Like 3

Share this post


Link to post
Share on other sites

Not sure if this was broken before: ALT +Z is not working in the PRV. You can use the Zoom tool (Z), but you can not undo with ALT +Z. 

 

Share this post


Link to post
Share on other sites
52 minutes ago, JoseC said:

Not sure if this was broken before: ALT +Z is not working in the PRV. You can use the Zoom tool (Z), but you can not undo with ALT +Z. 

 

 I believe this has been true for a long time ...

Share this post


Link to post
Share on other sites
1 hour ago, JoseC said:

Not sure if this was broken before: ALT +Z is not working in the PRV. You can use the Zoom tool (Z), but you can not undo with ALT +Z. 

 

are you sure it should be ALT-z and not CTRL-z? CTRL-z is the windows standard for undo

Share this post


Link to post
Share on other sites
4 minutes ago, pwalpwal said:

are you sure it should be ALT-z and not CTRL-z? CTRL-z is the windows standard for undo

I meant Undo Zoom (ALT-Z)

  • Like 1

Share this post


Link to post
Share on other sites

I appreaciate you have added SHIFT+ESC to clear selection

It's not a very easy key combo though IMHO ,  quite a stretch and I can't do it without looking at the keyboard- what was wrong with just using ESC on it's own ? It seems intuitive and can be found without looking . 

Share this post


Link to post
Share on other sites
Just now, CosmicDolphin said:

I appreaciate you have added SHIFT+ESC to clear selection

It's not a very easy key combo though IMHO ,  quite a stretch and I can't do it without looking at the keyboard- what was wrong with just using ESC on it's own ? It seems intuitive and can be found without looking . 

Speaking of which, it does not work in the PRV either here.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/27/2019 at 5:07 PM, MarianoGF said:

I know that the following is previous to the 2019.9 Early Acces, but it could be great you consider to adressing it for the upcoming release:

When I edit real time stretched clips, everything sounds fine. But when I bounce them or the whole project, it appears clicks on the former edit points or crossfades between those time stretched clips.

Here I attach a .cwp example file with audio.

This issue occurs even if I choose Elastique Pro as the stretch method for both online and offline renders. And it happens with any kind of bouncing: bounce to clips, to tracks, freeze and even export (fast bounce or not).

The workaround I can do in the meantime is to bounce those clips INMEDIATELLY AFTER stretch, and BEFORE any subsequent editing.

If I'm not the only one experiencing this, hope you consider it for fixing.
Thanks!

@MarianoGF we managed to solve this issue for the 09 release. It was actually unnecessarily pre rendering the stretches during export. 
Unlike Radius, Elastique doesn't require the stretches to be pre-rendered so I have removed that. It fixes the clicks and also makes export much faster since its all processed in one go.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
45 minutes ago, CosmicDolphin said:

I appreaciate you have added SHIFT+ESC to clear selection

It's not a very easy key combo though IMHO ,  quite a stretch and I can't do it without looking at the keyboard- what was wrong with just using ESC on it's own ? It seems intuitive and can be found without looking . 

I agree it's not an ideal key combo (although better than ctrl-shift-A), and I too wondered about using just ESC. Shortly afterwards I accidentally dragged a clip, realized before I let go of the mouse, and automatically hit ESC. So now I know why it can't be ESC. ESC is used in many programs to abort, cancel or stop the current operation before it is complete. It is ingrained into my automatic reactions and I didn't even realize!

Cheers, Peter.

Share this post


Link to post
Share on other sites

Exactly. We can't use ESC to clear something specific like selection. Its not standard Windows behavior and would be unexpected since users hit esc to get out of edit fields, dialogs and many other operations. It would be annoying to hit esc one extra time only to have it clear your selection.

  • Great Idea 1

Share this post


Link to post
Share on other sites

Minor UI stuff, and possibly not introduced in this version:

The top level Views menu has a tick mark and highlight for the Inspector regardless of its state. Also, the Control Bar looks identical when it is active.

 

viewmenu.png

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, PeterMc said:

The top level Views menu has a tick mark and highlight for the Inspector regardless of its state.

Collapsing it doesn't completely close the view. If you undock it and close it, the check mark will clear. But you should probalby be able to close it by unchecking it in the menu, which isn't possible.

Share this post


Link to post
Share on other sites
20 minutes ago, Noel Borthwick said:

Exactly. We can't use ESC to clear something specific like selection. Its not standard Windows behavior and would be unexpected since users hit esc to get out of edit fields, dialogs and many other operations. It would be annoying to hit esc one extra time only to have it clear your selection.

Point taken. I still think there' s a better one key solution..somewhere 

I was about to find it in Preferences-Keyboard Shortcuts but the ' Locate Key ' function doesn't help because ESC closes the dialog box even when shifted

My vote would be move it to the opposite side then and use NUM SUB ( minus key ) ..seems to be unassigned by default

 

Edited by CosmicDolphin

Share this post


Link to post
Share on other sites
1 hour ago, JoseC said:

Speaking of which, it does not work in the PRV either here.

Also Shift-ESC doesn't work in the Staff View or Tempo View. It seems to only work if the Track View has the focus. However, ctrl-shift-A does work in all views with a timeline.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...