Jump to content
Colin Nicholls

"Audio Dropout" toast occuring frequently at random times

Recommended Posts

Nothing has changed of any significance in 07 that would impact this area. Though Echo made great products, you are running a discontinued 15 year old device that doesn't have officially supported Windows 10 drivers. It's not surprising that it might behave sub-optimally in Windows 10.
I suspect something environmental in your system is affecting driver performance leading to the dropout rather than CbB. In ASIO mode all audio is driven by the  ASIO driver's thread rather than managed by Cakewalk. If the ASIO thread is starved for some reason it will cause a dropout. Most modern ASIO drivers take extreme precautions to guarantee real time performance of the driver, setting their thread priorities to realtime and other kernel tricks. 

Regarding why your dropouts seem more likely to happen when idle, its hard to say since there are many variables.  PCI devices especially legacy ones, are prone to interference from other devices on the system and can require tuning. Some things you can try:

Do you have MMCSS enabled in preferences? If enabled Cakewalk will try and change the driver thread priority to the MMCSS pro audio priority.  Check whether toggling that flag makes any difference. 

Try playing with the DropoutMsec variable in Aud.ini. This allows adjusting the tolerance for the drop out.

Do you have share audio devices enabled? Try toggling that off to let CbB exclusively use the driver.

 

 

Share this post


Link to post
Share on other sites

Thanks for the insights, Noel.

Quote

Do you have MMCSS enabled in preferences? Check whether toggling that flag makes any difference

Yes, I do. I'll run some tests on that.

Quote

Do you have share audio devices enabled? Try toggling that off to let CbB exclusively use the driver

In Windows configuration settings, Sound > Device Properties > Additional device properties > Advanced  there are two check-boxes:

Exclusive Mode:
[X] Allow applications to take exclusive control of this device
[X] Give exclusive mode applications priority

I assume this is what you are referring to; let me know if there is a different setting.

Quote

Though Echo made great products, you are running a discontinued 15 year old device that doesn't have officially supported Windows 10 drivers.

I hear what you're saying.  I appreciate the support Cakewalk have given me over the years despite this fact. FWIW, this interface and driver have been rock-solid for me since Windows 10 rolled out in 2015.  I've never wanted to be "that guy" that locks down his DAW to Windows 7 (although I've been tempted).

One thought, though, I will try re-installing the driver, in case something has gotten out of whack.

 

Share this post


Link to post
Share on other sites

I don't know if this has any bearing but here goes... In my project in the tracks view I've got
 3 synths (primary output & midi tracks) , 2 with midi input set, 1 with input echo on.
 3 aux tracks associated with 1 synth that has no midi input set..
 and a bunch of FX plugins.

In the PRV I was editiing the midi track for the synth set with input echo on, which was shown selected in the PRV & the track view. On switching from the PRV to the track view the dreaded audio dropout toast popped up which I ignored... Now this is the  weird part, at this point I stepped away from the DAW to briefly take care of something else, after a few minutes I heard a chord  of random notes from the selected synth with input echo on. I returned to the DAW stopped the audio engine and on restarting it heard the decaying chord notes and in the PRV a random set of piano roll keys were greyed out and could not be reset!

Fortunately I could save my changes & rebooted the DAW to clear the greyed out keys. This feels like something strange is going on in the output stream, quite what I've no idea.. Any suggestions??

Monday FYI just found out the latest w10 monthly update "August 30, 2019—KB4512941 (OS Build 18362.329)" did do something! It caused a 20% cpu spike due to a cortana bug, because I had searching the web from Windows Desktop Search  disabled. It's enabled now & the cpu is back to normal, will see if this bug was affecting the dropout frequency, who knows what was behind the spike & what, if any, side effects were caused...

Edited by Tez

Share this post


Link to post
Share on other sites
On 9/8/2019 at 12:27 PM, Colin Nicholls said:

I assume this is what you are referring to; let me know if there is a different setting.

@Colin Nicholls No I was referring to the setting in CbB itself under Preferences | Playback and recording, to "Suspend audio engine when Cakewalk is not in focus"

Please also try the DropoutMsec setting mentioned above.

Share this post


Link to post
Share on other sites
On 9/8/2019 at 5:00 PM, Tez said:

I don't know if this has any bearing but here goes... In my project in the tracks view I've got
 3 synths (primary output & midi tracks) , 2 with midi input set, 1 with input echo on.
 3 aux tracks associated with 1 synth that has no midi input set..
 and a bunch of FX plugins.

In the PRV I was editiing the midi track for the synth set with input echo on, which was shown selected in the PRV & the track view. On switching from the PRV to the track view the dreaded audio dropout toast popped up which I ignored... Now this is the  weird part, at this point I stepped away from the DAW to briefly take care of something else, after a few minutes I heard a chord  of random notes from the selected synth with input echo on. I returned to the DAW stopped the audio engine and on restarting it heard the decaying chord notes and in the PRV a random set of piano roll keys were greyed out and could not be reset!

Fortunately I could save my changes & rebooted the DAW to clear the greyed out keys. This feels like something strange is going on in the output stream, quite what I've no idea.. Any suggestions??

Monday FYI just found out the latest w10 monthly update "August 30, 2019—KB4512941 (OS Build 18362.329)" did do something! It caused a 20% cpu spike due to a cortana bug, because I had searching the web from Windows Desktop Search  disabled. It's enabled now & the cpu is back to normal, will see if this bug was affecting the dropout frequency, who knows what was behind the spike & what, if any, side effects were caused...

I heard about that Cortana bug. A big CPU spike from a background process like that could certainly cause dropouts.
I'm not sure what you mean by grayed out PRV keys however. A dropout shouldn't cause keys to get grayed out. Is this reproducible and can you take a screenshot? Regarding the burst of sound after resuming a dropout, that can happen. If the engine has been stopped the synth still has unplayed buffers or tails that it will spit out once playback is resumed. VST doesn't provide a way to reset internal synth buffers.

Share this post


Link to post
Share on other sites
7 hours ago, Noel Borthwick said:

I was referring to the setting in CbB itself under Preferences | Playback and recording, to "Suspend audio engine when Cakewalk is not in focus"

Ah, got it. Yeah, that's always off. I think I experimented with it once when it first appeared, and then left it disabled. I'm quite okay with Cakewalk owning the audio hardware while it's running.

Quote

Please also try the DropoutMsec setting mentioned above.

I will but...

I don't want to jinx it, but... the idle audio dropouts have almost completely stopped happening since I re-installed the audio driver! Since our last correspondence, I un-checked the [  ] Use MMCSS option, and then decided that it wouldn't hurt to re-install the ECHO driver.

Well... since then, I've only seen the idle audio dropout a couple of times, and in situations where I don't consider them unusual. If this was the only times I saw them, I'd never have considered writing a post about it.

I've re-checked [X] Use MMCSS to see if that has a detrimental effect, but so far it still looks good.

I hesitate to call this issue SOLVED (because I can still see idle dropouts, just not nearly as frequently) but if nothing changes over the next few sessions, I think I will do so.

Share this post


Link to post
Share on other sites
8 hours ago, Noel Borthwick said:

I heard about that Cortana bug. A big CPU spike from a background process like that could certainly cause dropouts.
I'm not sure what you mean by grayed out PRV keys however. A dropout shouldn't cause keys to get grayed out. Is this reproducible and can you take a screenshot? Regarding the burst of sound after resuming a dropout, that can happen. If the engine has been stopped the synth still has unplayed buffers or tails that it will spit out once playback is resumed. VST doesn't provide a way to reset internal synth buffers.

Play a chord of random notes say on a midi keyboard and the PRV piano keys corresponding to the notes turn grey until a "midi note off" occurs for each key and then it reverts to its key color... In the case where the random chord was heard as I described in the above post,  the corresponding keys for the notes heard turned grey and stayed that way and only rebooting CbB would clear them back to their initial key color. So it feels like some midi buffer spewed out a bunch of random "midi notes on" and no "midi notes off" & that got the PRV piano keys stuck, as I mentioned above the  the random chord continued sounding until it decayed, that is no "midi notes off".  

When this happens, and with any luck it won't since fixing the cpu spike, it's sporadic & not reproducible, but if it happens I'll take a  screenshot! If I recall after the dropout the audio engine icon remained blue...

Share this post


Link to post
Share on other sites

@Noel Borthwick Hi,

  GreyedKeys.png.b8f0602156690b44b5d3bae0f76c50a1.png

This is an image of the random piano keys that became greyed out:  g#6, c5, g#4, c0...  The thing to note is "c0", no note scored in the PRV was c0 and my midi keyboard doesn't have a c0, the lowest note is e2.

I was editing the volume automation in the track view on an aux track when the audio dropout toast popped up, the audio engine icon was indicating 'stopped' that is not blue. I then checked the PRV and found the greyed keys, at the time 2 of the midi tracks were assigned to a midi input, but only one had input echo on and the keyboard was switched on but not being used.

The only way to clear these greyed keys was to reboot CbB. The only way I'm aware of, that a PRV piano key turns grey is if there is a midi track assigned to an input source and has received a "midi note on" and it will stay that way until a "midi note off" is received... So how is it that these keys became irreversibly grey? It's a mystery! Mysterious or not it's become irritating as the project has be saved and CbB has to be restarted.

There's question on which you might be able to shed some light. On opening this project which has an instance or Rapture Pro,  it sporadically crashes CbB with an access violation caused by the plugin, I'd say about 1 in 10 times. Is this a known issue with Rapture Pro, since it also occurs with Splat?

Edited by Tez

Share this post


Link to post
Share on other sites

I'm going to keep posting my findings here. The driver re-install did not resolve the issue... I guess I just had a good day following the reinstall.

I still think this stems from my install/update to Windows 1903. I realize this is perhaps just confirmation bias but I found these posts interesting:

https://www.techpowerup.com/forums/threads/windows-10-1903-has-a-nasty-audio-stutter-bug-microsoft-hasnt-managed-to-fix.258611/

I realize that my Echo 3G drivers are almost archaic at this point, and this backs up Noel's point that older drivers can be affected by recent changes in Windows. I have actually downloaded an .ISO of 1809 and I'm prepared to re-install at a point in the future. (Unfortunately I can no longer roll back to my previous windows installation).

In the meantime, the latest thing I have tried is this tweak mentioned in the post I've referenced:

  bcdedit /set disabledynamictick yes

As usual, every time I change something on my DAW configuration, it seems to have a positive effect but I'll let you know if this is a permanent change 🙂

 

 

 

Share this post


Link to post
Share on other sites
6 hours ago, Noel Borthwick said:

Thanks we'll look into it. You shouldn't need to restart cbb however. What happens if you just press play the again? Do the notes not get reset?

As I said before in that instance "The only way to clear these greyed keys was to reboot CbB." It may be on that on some occasions this occurs one could clear the keys without restarting CbB by some other method,  but most times no, pressing play doesn't do the trick...   Thanks for looking into this!

And once again pretty please can  you shed some light on Rapture Pro sporadically crashing CbB with an access violation,  if you have any knowledge on it, it would much appreciated... 

7 hours ago, Chuck E Baby said:

have you tried The Reset MIDI button in the transport module ?

Yes indeed I have... The worst consequence of doing this is, if the project wasn't saved before doing a "Reset MIDI",  some synths which have specific parameters set either arbitrarily or precautiously via a preset can get zeroed out and also doesn't do the trick... 😵

Share this post


Link to post
Share on other sites

If you send a link to a crash dump I can verify that the crash is actually in rapture.

However we are not shipping rapture presently so I can't give you a timeline for plugin related fixes. 

Share this post


Link to post
Share on other sites

It sounds to me like woes related to the Windows update. I know that you reported no issues in latency monitor. I presume you left it running for hours, but if not, try that. 

I suggest restarting you pc, not sleeping and checking for Windows updates to make sure you have them all.

Also, make sure your power settings indicate not to suspend USB. Check your network cards in device manager and uncheck power related settings so your pc doesn't power them off.

I'm guessing you might have tracks with input monitor checked and that would be like streaming audio. If there is a timer from the last time you used your network card to the time it powers it down due to idleness that could cause this. 

Anther thing to check is usb hubs. Look for power settings on those too and disable.

Keep a list of the things you change. Once cakewalk starts working properly, you can undo steps until you discover what was causing the problem.

Share this post


Link to post
Share on other sites
On 9/14/2019 at 1:33 AM, Tez said:

@Noel Borthwick Hi,

  GreyedKeys.png.b8f0602156690b44b5d3bae0f76c50a1.png

This is an image of the random piano keys that became greyed out:  g#6, c5, g#4, c0...  The thing to note is "c0", no note scored in the PRV was c0 and my midi keyboard doesn't have a c0, the lowest note is e2.

I was editing the volume automation in the track view on an aux track when the audio dropout toast popped up, the audio engine icon was indicating 'stopped' that is not blue. I then checked the PRV and found the greyed keys, at the time 2 of the midi tracks were assigned to a midi input, but only one had input echo on and the keyboard was switched on but not being used.

The only way to clear these greyed keys was to reboot CbB. The only way I'm aware of, that a PRV piano key turns grey is if there is a midi track assigned to an input source and has received a "midi note on" and it will stay that way until a "midi note off" is received... So how is it that these keys became irreversibly grey? It's a mystery! Mysterious or not it's become irritating as the project has be saved and CbB has to be restarted.

There's question on which you might be able to shed some light. On opening this project which has an instance or Rapture Pro,  it sporadically crashes CbB with an access violation caused by the plugin, I'd say about 1 in 10 times. Is this a known issue with Rapture Pro, since it also occurs with Splat?

@Tez the only way those keys could get set is if your controller spuriously sent those notes. I suspect you have a flaky USB port or the controller itself is sending bad data under some conditions. The PRV UI is responding to MIDI input exclusively so the bad data couldn't come from CbB. I was able to replicate the problem artificially by holding down some keys on a MIDI controller and yanking the USB cable while the notes were held down. I've fixed it now so that pressing the Reset button (panic) will also reset the PRV notes so in the future if this happens you have a simple way to clear it.

 

  • Like 2

Share this post


Link to post
Share on other sites

@Noel Borthwick Thank you for looking into this, it might be my old O1/Wpro keyboard, that's the 1st suspect, hope it's not the Fastlane USB midi interface, I have the latest driver.  When you yanked the USB cable did it cause an audio dropout?

Oh and I found another "Windows 10 May 2019 Update version 1903"  known issue, namely "Error Event 455, ESENT" errors occurring with high frequency for Logging, due to a missing folder, and there were a lot... Fixed it now, don't know what side effects this might have caused if any.

Share this post


Link to post
Share on other sites
On 9/14/2019 at 7:05 PM, Noel Borthwick said:

If you send a link to a crash dump I can verify that the crash is actually in rapture.

However we are not shipping rapture presently so I can't give you a timeline for plugin related fixes. 

@Noel Borthwick Here's a link to the crash dump which just occurred, it's a "dropbox"  link: 

               https://www.dropbox.com/s/rjlngbt805afzj5/_09162019_214556.dmp?dl=0

I just wanted to get a handle on what was happening here, and hopefully using Rapture Pro doesn't have any negative effects in my projects, other than this random crash. Many thanks T... 

Share this post


Link to post
Share on other sites

I figured I'd post an update and wrest this thread back on track from @Tez's successful hijack... 🙂

To recap, my last post described my use of  "bcdedit /set disabledynamictick yes" in my Windows 10 1903 environment to see if this improved things...

The result is a definite "maybe". It didn't eliminate my random Audio Dropout toast notifications but it might have reduced them somewhat. Not enough for me to think that the problem was resolved.

This week I decided to bite the bullet and revert my OS drive to an earlier version. I used the vendor's OS Recovery Partition to bring my workstation back to the out-of-the-box Windows build 1803 environment.

I've spent the last couple of days re-installing all my applications and sample libraries and VSTs, and co-incidentally,  yesterday Bandlab also dropped the 2019.09 release of Cakewalk, which I'm now running. Many thanks to @Noel Borthwick , it includes improved audio dropout notification diagnostics!

So... with my current environment of Windows 1803 and CbB 2019.09, after a solid session working in Cakewalk, I have not observed any random audio dropouts. Yet!

(OK, not quite true. I did experienced a (0) and a (13) last night when I was getting things set up, but nothing since then.)

The difference (so far) is night and day.

I wish I could say definitely what the root cause is, but given that I've just reinstalled EVERYTHING, and also a new release of Cakewalk... it's perhaps not quite fair but I think I'm gonna point the finger at Windows 1903.

Needless to say I have disabled Windows Update (using WinAeroTweaker which has worked for me in the past) and it will be a while before I'm willing to enable it again.

I'll let y'all know how I get on in the coming days.

Share this post


Link to post
Share on other sites
3 hours ago, Colin Nicholls said:

I figured I'd post an update and wrest this thread back on track from @Tez's successful hijack... 🙂

 

Mr @Colin Nicholls, I just thought misery loves company... 😪 Meanwhile  under Windows 1903 & CbB 2019.09 I'm getting the occasional dropout while doing some activity in the track pane, no audio (play stopped, no audio input), no midi input (keyboard off) and no midi editing and the reason code is so far (1) : "Audio processing took longer than the buffers allotted time slice", which is a puzzle, unless "Always Stream Audio Through FX" being checked has something to do with it and... Dum ta dum dum... Aux tracks, of which there are several, but only being fed by synth outputs that have no midi inputs assigned  and echo off on those synth tracks. So my question to you is do you have Aux tracks in your projects that get or got the toast??  I'm sure you've been following forum "dropout saga" as I have 😴...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...