Jump to content
Bad Mac

VST3 synths supported in Cakewalk?

Recommended Posts

Posted (edited)

There is something wrong with the new EZD3. Who's fault it is is pending the finger pointing session. EZD 1 and 2 still work fine.

Edited by Terry Kelley

Share this post


Link to post
Share on other sites
36 minutes ago, noynekker said:

All I can offer is sympathy for the OP Bad Mac . . . as I have had an issue for many years with FabFilter ProQ3 VST3, a very mainstream + widely used VST Effect . . . load it up, instant Cakewalk crash out, yep workaround VST2 version works just fine . . . no one has been able to offer help or explain why ? Yes, FabFilter ProQ3 VST3 loads up nicely in my other DAW, which actually BTW sucks in so many ways compared to my Cakewalk. As Bad Mac says  . . . Not everything works, reasons unknown.

Tech support just says re-install, that's all they got.

It is hard to offer suggestions without details.

It was not clear from the OP until the image of the crash dialog was posted that the crash message was coming from the plug-in. 

 

I posted a link to a primer posted by @Noel Borthwick  on how to report crashes that happen in CbB.

 

A new variable called ExceptionHandlingSeverity  was added to Cakewalk.ini in CbB 2021.04 to better report badly behaving plug-ins.

Read about the variable here and in the 2021.04 release notes.

Preferences > File > Initialization File may be used to maintain this variable. 

Share this post


Link to post
Share on other sites
21 minutes ago, Terry Kelley said:

There is something wrong with the new EZD3. Who's fault it is is pending the finger pointing session. EZD 1 and 2 still work fine.

It's a new plug-in and Toontrack only recently starting publishing VST3 plug-ins.

While not definitive, these are pretty good indications Toontrack may need to address the issue. 

I have not seen the error messages generated by EZD3 but the one in this thread generated by SD3 was from the plug-in.

Share this post


Link to post
Share on other sites
Posted (edited)

Of course.

The error is the standard memory violation: c0000005. Seen one ...

Changing the Exception Severity just makes Cakewalk blow it off but TT EZD3 still crashed with the violation. The fault is in EZdrummer 3.vst3.

D u m p   F i l e :   C : \ U s e r s \ t e r r y \ A p p D a t a \ R o a m i n g \ C a k e w a l k \ C a k e w a l k   C o r e \ M i n i D u m p s \ P l u g i n s \ U n t i t l e d _ 0 5 0 3 2 0 2 2 _ 2 0 2 3 5 7 . d m p
 E x c e p t i o n   C o d e :   c 0 0 0 0 0 0 5 d
 F a u l t i n g   M o d u l e :   c : \ p r o g r a m   f i l e s \ c o m m o n   f i l e s \ V S T 3 \ E Z d r u m m e r   3 . v s t 3
 A p p   V e r s i o n :   2 8 . 0 2 . 0 . 0 3 9
 U s e r :   t e r r y
 S e r i a l :  **************************************
 P r o j e c t   F i l e :   D : \ C a k e w a l k   s o n g s T B K \ U n t i t l e d
 I s P l u g i n C r a s h :   1
 T o t a l   P h y s   M e m   1 6 7 1 4 5 1 2   K B
 A v a i l   P h y s   M e m   1 0 3 1 2 2 2 4   K B

Side note: It works on my friends W8.1 machine running 2021.12. Go figure. :) I did a rollback to that version and it still crashed.

Edited by Terry Kelley

Share this post


Link to post
Share on other sites
3 hours ago, Bad Mac said:

you are the first person to verify any particular VST synth that works in cakewalk, thank you!  everyone just says their works fine. and tells me to do the things i have already done.

I'll just go with some freeware ones that are easily obtainable. You can check the Favorite Freeware Instruments thread for more.

Surge, TAL-Noisemaker, Vital, Sampletank 4, Stringya 2, Orchestools ROMplers, Vienna Synchron Player, Atmos 2, Numa Player, sforzando.

All work perfectly in Cakewalk for me.

Share this post


Link to post
Share on other sites

thanks to scook for helping. i agree it appears to be a toontrack issue as that plugin came out today. also, to the other person suggesting i read the fuiopcking manaul. i did look for that information in the online documentation under plugin browser thinking thats where it would be. if you know where to find it, feel fee to point me in that direct, otherwise kma!

Share this post


Link to post
Share on other sites
2 hours ago, John Vere said:

Like I said in your other post, your issue is not Cakewalk, your issue is with the vendor of the plug in. Your obsessing over the plug in icons?? that is just plain weird. We have all told you that is what they look like, that is nothing to do with a plug in not working.

E mail support for the plug ins that are not working it takes a lot less time than you are spending posting here.  I am honestly sorry we really can't help. All those VST 3 plug ins work just fine for the rest of us. I use as many VST 3 plug ins as available from vendors. They are all working great.  

well, many different software applications grey out text and or options that are not available. for example buttons my be greyed out and you are not able to click on them as they are not in focus or you may not have permission on websites or in other software programs. and many time the software will also display icons as an indication that something is not right. so my "obsession' with the icons is not weird. it simply wondering if 2 plugs not connected meant something was wrong, and the text appeared to be greyed out to me. apparently it was grey on purpose and the 2 plugs are apparently the symbol for VST3. Which i did not know.  But thanks for your remarks....

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, Bad Mac said:

thanks to scook for helping. i agree it appears to be a toontrack issue as that plugin came out today.

6 hours ago, Bad Mac said:

. . . to the other person suggesting i read the fuiopcking manaul. i did look for that information in the online documentation under plugin browser thinking thats where it would be. if you know where to find it, feel fee to point me in that direct, otherwise kma!

Now that there is agreement, can this thread be closed before the hostilities escalate?

Edited by User 905133

Share this post


Link to post
Share on other sites
6 hours ago, Bad Mac said:

the text appeared to be greyed out to me

The solution to plug-in names being "greyed out" is to either switch your theme back to Mercury or better still, try one of my custom ones. If you like it dark, I suggest Racing Green or Midnight Blue.

Share this post


Link to post
Share on other sites

It doesn't help when the tone of the communication is belligerent. I know how stressful is to have a problem and not getting a solution, but never forget that most people here is genuinely trying to help - for free.

  • Like 2
  • Great Idea 1

Share this post


Link to post
Share on other sites
Posted (edited)

Well, whether or not Cakewalk supports VST3 is in fact covered in the documentation as are plugin icons and their coloration....

Edited by bdickens

Share this post


Link to post
Share on other sites

@Bad Mac EZDrummer 3 and EZBass (VST2 & VST3) are working fine here in CbB.
I've inserted both into existing projects (one in particular that started out in Sonar, just to be sure) and created new projects.

No issues (so far).

t

just to be clear I have had "issues" in the past with IKM VST3's and avoid VST3 in IKM like the plague...

Share this post


Link to post
Share on other sites
19 hours ago, John Vere said:

...your issue is with the vendor of the plug in...

Well, that can't quite be accurate if he can't get ANY VST3 instruments to work. However, the best course of action is still to send Toontrack the dump. They will probably be able to diagnose the problem even if it isn't SD3's fault. 

Bad Mac, I hope you post back here after you've figured it out, as I'd be curious to know what the problem turned out to be. I checked dependencies for a handful of VST3 instruments and found none that weren't also dependencies of VST2 instruments. IOW, I couldn't find a single point of failure that would apply to ALL VST3 instruments and ONLY VST3 instruments.

If you want a specific VST3 instrument that's known to work, but won't cost you anything to acquire, I'd suggest Spitfire LABS.

 

 

Share this post


Link to post
Share on other sites
59 minutes ago, bitflipper said:

If you want a specific VST3 instrument that's known to work, but won't cost you anything to acquire, I'd suggest Spitfire LABS.

Or any of the 10 I listed.

One thing that nobody has mentioned is that Cakewalk has to have C:\Program Files\Common Files\VST3 in its scan paths in order to pick up VST3's, whereas most programs scan that folder automatically, due to its being a canonical location.

OP should check their scan paths to see if somehow those lines aren't in there:

image.png.e77b0a230605d02489a293fffd1a37aa.png

Share this post


Link to post
Share on other sites

That was the first thing I thought of, too. However, if one of the vst3 paths was missing , that would affect vst3 effects, too. Not just instruments. The OP says vst3 fx work. That's what makes it a mystery.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Starship Krupa said:

OP should check their scan paths to see if somehow those lines aren't in there:

Since the vst3s are in the OP's Plug-in Browser, doesn't that mean they were scanned?  Related Question:  does the Plug-in Browser show plug-ins that were not scanned? 

Or are you suggesting that if the default scan paths are not in the list, other plug-ins that have been scanned might show up in the Browser but might not work? 

Edited by User 905133
to add some related questions

Share this post


Link to post
Share on other sites
5 hours ago, User 905133 said:

Since the vst3s are in the OP's Plug-in Browser, doesn't that mean they were scanned?

Right, of course. I forgot about that. But hey, this is a mystery issue, innit? Anything's possible. I really have no idea, this is a really unusual situation. All VST2's work and no VST3's do? That was pretty standard in 2014 or so. 😄

Share this post


Link to post
Share on other sites
12 hours ago, Starship Krupa said:

Or any of the 10 I listed.

One thing that nobody has mentioned is that Cakewalk has to have C:\Program Files\Common Files\VST3 in its scan paths in order to pick up VST3's, whereas most programs scan that folder automatically, due to its being a canonical location.

OP should check their scan paths to see if somehow those lines aren't in there:

image.png.e77b0a230605d02489a293fffd1a37aa.png

That’s not accurate. Cakewalk adds that folder by default to the scan path.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...