Jump to content
Matt Dunn

Cakewalk auto-saving too often

Recommended Posts

Hi, apologies for this as I know it's been discussed multiple times in the past, but I've yet to find a solution that actually works, nor any clear explanation for why it happens.

Between 9:30 and 9:41 this morning, Cakewalk 1) autosaved my project, 2) saved my project per my Ctrl+S, 3) auto-saved the project a second time, and 4) auto-saved the project a third time. Too much saving can't be a bad thing, right? I guess not, but only to a point. When you're working with very large projects that often take quite a while to save, it just becomes a distraction and an unwanted workflow delay.

I've taken all the advice I've seen posted here in the past, except for turning off auto-save altogether. I've been burnt too many times to risk that. So I've changed the interval from 2 minutes to 5, 10, 20 and 30 minutes. I've turned the number of changes right down to zero so that, theoretically, nothing I do will trigger auto-save. Currently I have it set to every 20 minutes or 9,000 changes. Yes, 9,000!!! And yet I still just got 3 auto-saves in 11 minutes, 2 of which came right after a manual save — the first of those within 60 seconds of that manual save and after all I'd done was delete two tiny records from the middle of the project.

Am I doing something wrong? Or missing something obvious?

Any further ideas or advice would be hugely appreciated coz, frankly, this has gotten pretty annoying.

Cheers,

Matt

 

 

Share this post


Link to post
Share on other sites

If you have a plugin in your project that has a lot of parameters and its notifying every parameter as a change it could add up quickly.
What happens if you set the number of changes to 0 to make it only respect the number of minutes?
 

Share this post


Link to post
Share on other sites

Same thing. I thought it would stop and only respect the time, but even when changes were set to zero it kept happening. I do use plugins, most often just Cakewalk defaults but I guess some of the others might be fairly chunky (iZotope, Korg, Excalibur and the like), though I wouldn't really know tbh. Either way, would 9,000 parameter changes even be possible within a matter of 30-60 seconds?

Share this post


Link to post
Share on other sites

Its not normal so worth investigating. If you can send a link to a small project that has this issue we can look into it. I doubt that it would even require sending the audio files.

Share this post


Link to post
Share on other sites

Thanks Noel. I'll keep experimenting with time and change for a week so I have a definitive record of results, then send through.

Share this post


Link to post
Share on other sites

I have found this to be the case as well.

Auto-saving set to 0 changes and time based only, and auto-saving still happens outside of the time limit.

Share this post


Link to post
Share on other sites

Any update on this? This just started happening to me on a new song I created. It just autosaves randomly every couple of minutes, even I don't make any changes. Timer is set to 30 minutes. Number of changes doesn't seem to matter. I can set it to 0 or 1000 and it just keeps autosaving. I saw another thread that this was a bug several years ago that was fixed. Did it get reintroduced in a recent update???

Share this post


Link to post
Share on other sites

Sorry for not having followed up with this since posting in February. I set the auto-save to 10 minutes and the maximum number of changes, just to try to avoid it auto-saving based on number of changes. I then monitored for a few days and it seemed like it was doing what it was meant to do -- i.e. auto-saving every 10 minutes -- so... was Cakewalk gaslighting me? :)

But soon enough it was back to it's old tricks again, just as I reported back in February. e.g., it will auto-save literally within 10-15 seconds of me having saved previously. Or, if I save the project and go away for some extended period, when I come back and unlock my computer, it auto-saves almost immediately after the very first thing I do, regardless of what that might be -- hitting record, clicking mute, duplicating, adding FX, adding a track, deleting a recording, moving the playhead, exporting, changing view, quantizing, processing an effect -- seemingly anything will trigger an immediate auto-save.

This is especially annoying if I've gone away from the project to get myself 'in the zone' and I run back when I suddenly find myself in said zone with an idea I want to do something with before I forget it, but I have to sit through one of these way-too-slow unprovoked auto-saves before I can do anything!

Share this post


Link to post
Share on other sites

Here's an example of one of the auto-save quirks I've been observing and which I don't think is behaving as it should:

Cakewalk had been auto-saving my project every 10 minutes, as per settings. At 22:18 I manually saved the project, yet at 22:20 it auto-saved itself again. Is this expected behaviour, simply because the auto-save setting is every 10 minutes? Surely the next auto-save time is (or should be) reset at the point of manually saving a project? Logically another auto-save shouldn't have been triggered on my project until 22:28?

Or am I missing something obvious? 

image.png.eaff0854493c07368043b87412385225.png

Share this post


Link to post
Share on other sites

@Matt Dunn - just curious as I have been dealing with this too.

Do you notice a difference if, leaving your  Auto save time setting as it is,  you set the changes setting to 0 as opposed to the maximum number of changes? (which is what exactly?)

Share this post


Link to post
Share on other sites

Autosave and Save are two different files. Autosave is going to save every ten minutes regardless of the Save status. Furthermore Autosave is not going to clear a "dirty" project.

FWIW I have Autosave disabled. There is no setting for it that is not annoying. Instead I have learned to hit "Cntrl-S" every time I even look at the keyboard.

  • Great Idea 2

Share this post


Link to post
Share on other sites

I, too have autosave disabled as it will interrupt what I am doing.

Hitting "Ctrl+S" is like a nervous tic.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/25/2021 at 4:05 AM, winkpain said:

@Matt Dunn - just curious as I have been dealing with this too.

Do you notice a difference if, leaving your  Auto save time setting as it is,  you set the changes setting to 0 as opposed to the maximum number of changes? (which is what exactly?)

@winkpain oddly enough, the maximum number of changes allowed is 65,535. Odd, but then there have always been many aspects of Cakewalk (and Sonar, as was) that I've found a bit odd. But no, no difference noted. Believe me, I've tried every permutation of this that I can think of.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/25/2021 at 6:39 AM, bdickens said:

I, too have autosave disabled as it will interrupt what I am doing.

Hitting "Ctrl+S" is like a nervous tic.

@bdickens and @Base 57I'm gonna go with you both on this -- disable Auto-save, develop my nervous tic, and just be a bit pragmatic about the possibly of taking a hit with lost work until such time as I've fully refined said habit.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...