Jump to content

Kontakt 5 & 7 get volumes lowered to -54 db as soon as I edit the piano roll in Cakewalk, how to fix??

Recommended Posts

Currently I have to reload the instrument every time I make a change in the piano roll as it continues to make volume changes to the instrument where I can't figure out how to undo it!

I literally have to reload the instrument with a new instrument just to hear it again!!

Any ideas how to fix this issue??

Link to comment
Share on other sites

When this happens there is a volume event involved somewhere in the midi data and you should be able to see it in either the event list or down in the controller pane of PRV.
But there’s sometimes a hidden event and  I often run into this with download midi files. 
Example is I need the Ample P bass lite set at 1.0 on its level control in the GUI. I set it to 1.0 The minute you hit playback it jumps back to 2.0 and there’s no sign of any controller data anywhere. 

Sometimes changing the midi channel fixes it. But the easiest solution is to use the  track fader and set it at 64 which seems to correlate to 1.0  on the instrument.  Track inspector settings overrule midi events. One more thing to check is if another midi instrument has its output set in the GUI to output midi data this can loopback to any midi tracks that have all inputs selected. Either disable all midi outputs from instruments or set track inputs to your controller or none. The controller is my choice because none seems to get reset. 

Edited by John Vere
  • Like 1
Link to comment
Share on other sites

Several common issues regarding unplanned MIDI response from Kontakt instruments that you may want to examine:

1. The default setting for many instruments in Kontakt allows for several MIDI messages you may not realize to affect playback. -Generally, unless you want to allow those, I recommend turning off the defaults.


In Cakewalk for instance, the most common factor is the CC#7 - Volume response, since the MIDI track volume fader/automation setting will send this every time playback is started.

-in Cakewalk there are Preferences - Project - MIDI settings that can also address automatic playback defaults on some of those particular controls, but in those recent versions of Kontakt I find it best to apply the preventive measures here 1st. Then also save & close the project & re-open to apply.   -Your mileage may vary.

2. Check your MIDI tracking for any other embedded MIDI commands, and/or see if you have any envelopes assigned, that may be causing changes.

3. Very often even the Kontakt instrument itself can also be set to receive MIDI commands for certain functions, so this and all the other steps here can be related. -In the post context here for instance, CC#11 - Expression will change volume (expressively!) in many instruments by default.


Since Kontakt setup can contain any number of variables, and it's not clear from your original post whether the MIDI you are sending from Cakewalk is straightforward (notes only, for instance), the above tips, along with the information @John Vere has posted, is the first line of troubleshooting I would suggest. I hope this helps!

Edited by JnTuneTech
additional clarifications
  • Like 3
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...