Jump to content
Twaddle

Can't run latest cakewalk

Recommended Posts

Posted (edited)

Hi

I've been having issues since upgrading to windows 11 and they just got worse with the latest update and now cakewalk  won't launch at all.

When I did the windows 11 upgrade I noticed that it took about one minute or more to launch, this is compared to it taking about 2 seconds prior to upgrading. I still have Sonar Producer 8.5 and it's been the same with that too.

Now I find that the latest update has various error messages during install and once installed it just doesn't launch. It doesn't show up in the task manager so absolutely nothing is happening.

I've attached an image of the first error message, it's looking for something that I may or may now have.

 

Steve

 

Steve

Cakewalk installer error.jpg

Edited by Twaddle

Share this post


Link to post
Share on other sites

I googled the error message and found some instructions to uninstall ALL of my Microsoft Visual C++ versions.

So I did that and it still didn't work. Then I discovered that nether cakewalk or my Producer 8.5 would launch WTF!!?

 

So I went to use windows restore and now my computer has gone into Automatic Repair mode but it's not working some I'm pretty screwed and not happy right now.

Just created a USB repair disk so hopefully that will fix whatever damage has been done but I'm dreading the thought that it might require a complete reinstall.

Not a good day.

 

Steve

Share this post


Link to post
Share on other sites
2 hours ago, Twaddle said:

I googled the error message and found some instructions to uninstall ALL of my Microsoft Visual C++ versions.

I wonder what moron said to do that!

Share this post


Link to post
Share on other sites

I suspect you're on a one-way Highway to Hell trying to fix this and the only way to do the job properly is go back to base zero with a full system re-install of Windows.

I know it's a tough choice, I had something similar a while back with my laptop constantly blue screening, and in the end I bit the bullet and went for the full nuclear reinstall. 

Assuming you have sound and up to date backups, it's probably going to be your fastest path back to sanity.

I hope you get it back up and running soon.

Andy

  • Great Idea 1

Share this post


Link to post
Share on other sites
Posted (edited)

I am not an expert on Windows, but everything I have ever seen says that newer Visual C++ Redistributables don't eliminate the need for older ones.  For example:

Quote

There are multiple different versions of Visual C++ Redistributable. Unfortunately, newer ones don't supersede older ones.

Quote

Please do not uninstall any of those C++ Redistributable packages, every one of those are required on your PC

When a software developer writes software, they target a specific version of the C++ Redistributable, then when you install that software, that version of the re-distributable is also installed

So, if you delete one of those, what ever software relies on that version will stop working . . .

from: https://answers.microsoft.com/en-us/windows/forum/all/can-i-uninstall-all-these-microsoft-visual-c/86216e8c-2cb1-4517-9d52-b1303eec4e05

 

Edited by User 905133

Share this post


Link to post
Share on other sites

We install all redists that are REQUIRED by Cakewalk so using the installer provided should address any Cakewalk related issues.

Share this post


Link to post
Share on other sites

My Cakewalk also keeps crashing after updating to the new version and also turns out, it is somehow not compatible with the new VIsual C+ from Microsoft. I had to delete the new Visual C+ and install it again numerous times to make Cakewalk running as I am in the middle of a project and this is getting frustrating.

Any suggestions pls to go back from the previous version without losing my Cakewalk current setups as I fear I have to install every plugins and VSTs all over again.

Many thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/15/2022 at 11:20 AM, Noel Borthwick said:

We install all redists that are REQUIRED by Cakewalk so using the installer provided should address any Cakewalk related issues.

Should, but strangely doesn't Noel.

I wish I could figure out what the issue was.

I don't think the 2 things are related but it was very noticeable that after upgrading to windows 11 bother Sonar Producer 8.5 and Bandlab took up to 2 minutes to appear whereas previously it had been instant.

I'm not at all convinced that reinstalling windows from fresh will even fix the issue and it's a solid 2 days work to get everything installed and configured to where it is now. Bit of a Hobson's choice right now.

 

Steve

 

Edited by Twaddle

Share this post


Link to post
Share on other sites

The error message you list is not ours but from the Microsoft installer from the redist itself.
This link seems to indicate that your windows installers may need repair.
https://thegeekpage.com/the-feature-you-are-trying-to-use-in-on-a-network-resource-that-is-unavailable-in-windows-10-fix/

Also read this. https://answers.microsoft.com/en-us/protect/forum/all/the-feature-you-are-trying-to-use-is-in-a-network/80d4be22-aab6-47f0-a7dc-8a3131fc8df0?page=2

It seems that a registry entry on your pc may be pointing to a non existent drive which may be confusing the Microsoft installer. Check the path that it lists in the error message and follow those links.

Share this post


Link to post
Share on other sites
On 3/18/2022 at 1:11 PM, Twaddle said:

I don't think the 2 things are related but it was very noticeable that after upgrading to windows 11 bother Sonar Producer 8.5 and Bandlab took up to 2 minutes to appear whereas previously it had been instant.

Did you whitelist all the Cakewalk folders in your virus scanner?

If running Windows Defender is ransomware protection (Controlled folder access) enabled?

Share this post


Link to post
Share on other sites

Thanks for your help.

 

I went with the clean install of windows 11 and so far so good.

 

I think an issue I may have discovered with the new bandlab taking over a minute to launch might be to do with setting it to run as administrator.

This is something I did a long time ago when you needed to be the administrator to register Sonar producer.

I noticed it was taking a long time to launch just like it was before, turned off the, 'run this program as administrator' in the properties box and it launched immediately.

Possibly a bug but needs more investigation and as there's no need to be launcing it as admin anymore I'll leave that to someone else.  🙃

 

Steve

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...