Jump to content
Sign in to follow this  
Starship Krupa

Super-muted MIDI clip

Recommended Posts

I'm now on day 2 of trying to punch in an organ part, an 8 bar chorus, one-handed block chords.

Loop recording multiple takes of MIDI has been a fraught process for me since I first tried it with Cakewalk, but I figured I have a lot more experience with the program now, so I'd give it a try.

This is a screenshot of part of the results of this attempt. I'm not going to talk about the territory around this clip looking like the aftermath of the Battle of Gettysburg, that's for another time, after the combatants have had a chance to heal. I just want to focus on this one clip, which is indicated inside the red ellipse:

image.png.1924aebb24f6b05cdd057370a862dfe3.png

This clip is part of one of a dozen or so takes. It's in a "selected" state. none of the other lanes are solo'd, but the track itself is. Over in the Inspector, you can see that I've set the foreground to orange and the background to blue.

My issue with this clip is that I can't get it to play sound no matter what I try. "K" or right-click to mute/unmute, no go. Soloing the lane, nope. It. Just. Won't. Sound. There's not another clip on top of it or underneath it, I know to check for that. It's just sitting there by itself, with notes in it that won't play. I can play the onscreen keyboard and my MIDI controller and it makes a sound, I can un mute the clips in adjacent lanes and they will play, but just not this one for whatever reason.

Notice it looks weird for a non-muted clip in the Mercury theme: the background is correct, it's the light grey that indicates a selected clip, but the MIDI data/events are plain white. In its selected state the data should have the foreground color. Unselected, it should obey both color settings. If I hit "K" to mute it, it takes on the look of other muted clips, but in its (supposedly) un-muted state, the color ain't right.

Any ideas, what may have caused this, did I put it in some known locked state by accident?

This is unfortunately characteristic of my life with MIDI in Cakewalk: it usually goes smoothly (except for the weird loop recording/clip behavior), but about 33% of the time I lose an hour or more to "this one thing," which is sometimes a MIDI track and a synth track that have stopped communicating and nothing I do will bring them back together so I wind up saving the synth's settings as a preset, then deleting it and adding it back, or somehow during the process of recording and editing I end up with an extra clip entirely overlapping and hiding another clip, or I can't get the editing cursor to grab the edge of the clip or change to the tool I want, or something that brings my project to a halt while I untangle the ball of yarn.

It could be 100% pilot error, but I'd at least like to know what I'm doing wrong.

Share this post


Link to post
Share on other sites

This happened to me a couple of days ago.  I had to save, close the project and reopen.  Then it was fine.  As you say, nothing else would wake it up.

Share this post


Link to post
Share on other sites
Posted (edited)

Individual MIDI events can be muted. Check the PRV and click 'whited out' notes with the  Mute mode of the Erase tool (there's probably a modifier key option for the Smart tool, but I don't know it offhand). You may also be able to use the region muting tool. IIRC region muting is used in audio when punching in Overwrite rather than Comp Recording mode; I presume MIDI is the same.

 

CORRECTION: It's enabling the Mute Previous Takes option for punch in that causes this. Sweeping with the Mute tool in the upper half of the clip will undo the region muting without having to go into the PRV.

Edited by David Baay
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...