Jump to content
jimlynch22

CPU usage 50% when idle

Recommended Posts

Check the task manager. 50% at idle doesn't mean it's Cakewalk. Might be anti-virus running fast because you ARE idle.

Just a thought.

Share this post


Link to post
Share on other sites

Just because playback is stopped does not mean it's idle. Any plug-ins (especially amp sims) in the project can still be running unless you suspend the audio engine.

Share this post


Link to post
Share on other sites
10 hours ago, Terry Kelley said:

Check the task manager. 50% at idle doesn't mean it's Cakewalk. Might be anti-virus running fast because you ARE idle.

Just a thought.

 

10 hours ago, Terry Kelley said:

Check the task manager. 50% at idle doesn't mean it's Cakewalk. Might be anti-virus running fast because you ARE idle.

Just a thought.

Yep, I'm looking at task manager

Share this post


Link to post
Share on other sites
8 hours ago, Base 57 said:

Just because playback is stopped does not mean it's idle. Any plug-ins (especially amp sims) in the project can still be running unless you suspend the audio engine.

Yep. culprit turns out to be cakewalk Adaptive Limiter plugin.  Just closing the plugin window reduces CPU to 0 when not running.  Playing back with Adaptive Limiter functioning but not displaying a GUI  yields CPU =12 %

Share this post


Link to post
Share on other sites

SO .. I have a similar issue. In my case I have a collab project with other band members supplying wavs back and forth so all the tracks are Audio .. some using FX plugins like compressors, and quiet a few with incidents of Waves scheps omni channel on tracks.

CPU at 100% while project idle. SO, turned off audio engine and it dropped like a stone to 2, 3%.

Mmm I said. I then turned on the audio engine again, back up and fan going. SO this time I disabled all the EFX plugins on each track. CPU back down to around 8%. 

Next I re-enabled JUST the Waves scheps omni channel on the tracks it  is on. CPU up to and around 40% ( 9 incidence of it ). Fan behaving. Next its a case of individually enabling the others like Neutron 3 Elements, Guitar Rig, Blueverb DRV 2080, TR5 Tape echo, Ozone 9 elements, Royal Compressor

So outside of doing it this way is there any other way of finding the "errant" effect or VSTi that might be causing CPU to go nuts? 

And a general Q - WHY do these plugins still use CPU cycles when just sitting there in a project that is not running?

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah, that does seem high.

I am a VST/plugin hog and I am looking at a 45 track song at idle and I am pulling 11% CPU in the task manager and 773MB of memory. Part of the CPU usage it the number of cores and processor speed. Slow it down and it needs more CPU time to get things done. Also, various VST/plugins do run at idle due to the way they work and if they are being told to play tails (like finish the reverb after you press stop), etc. But 100% just sitting there seems beyond expectations. What does the CPU meeting in Cakewalk show in the Performance window for Audio, System and overall App?

We need Noel or MSMcLeod to give us the specific scoop.

Edited by Terry Kelley

Share this post


Link to post
Share on other sites
Posted (edited)

@Terry Kelley @Noel Borthwick 

Further to my post above .. I then decided to freeze certain tracks .. especially with guitar rig on them. This has improved things somewhat, CPU for CW sitting at about 38% idle ( in WINDOWS Task manager/Processes )

I made a mistake above actually .. the CPU with CW Idle was at about 60% for CW not 100%. I was looking at over all CPU usage .. my bad. But still High I Imagine.

If I switch off the Audio Engine CW CPU usage  drops to 2%. The project itself has 26 Audio tracks - No Soft synths or Midi

One other thing I do notice. If I export / mixdown this project in CW via File/Export/Audio THEN CW CPU usage alone goes to 90%+

I also wonder is this as a result of Audio I/F and ASIO drivers? ( In my case an Audient Evo 4 )

Machine Spec .. Core i5, 16GB Ram, 2TB Samsung Evo SSD Drive

 

Edited by aidan o driscoll

Share this post


Link to post
Share on other sites

Small tip✔️ For years, I have had a custom keyboard shortcut for "Start/Stop Audio Engine" bound to ALT + X. It has become second nature for me to stop the audio engine when not needing an immediate response from Cakewalk. I also always stop the audio engine before saving a project, that way saving goes faster as well.

Is idly running plugins and instruments an issue in all DAW's?

I know the VST3 standard does include some kind of feature for plugins to to not draw CPU cycles when no audio is passing through... wasn't support for that implemented in Cakewalk recently?

  • Like 1

Share this post


Link to post
Share on other sites

By default cakewalk is streaming audio to plugins even when the transport is not running (there is a setting in preferences)
VST3 has a setting for telling the  plugin that its a zero buffer but its up to plugins to implement it.
You can find out which plugin is consuming cpu by bypassing them one by one in the fx rack.

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

By default cakewalk is streaming audio to plugins even when the transport is not running (there is a setting in preferences)
VST3 has a setting for telling the  plugin that its a zero buffer but its up to plugins to implement it.
You can find out which plugin is consuming cpu by bypassing them one by one in the fx rack.

@Noel Borthwick Are you referring to "Always Stream Audio Through FX" setting in preferences/playback and recording?

And with respect to the CPU going to 90%+ for CW alone when exporting ... is a good fix to disable audio engine while exporting? Why does this happen, just curious .. 

Share this post


Link to post
Share on other sites

Yes that is the option. Regarding exporting why are you concerned with the CPU meter? Its normal for Cakewalk to use as much CPU as possible when exporting because its doing the export faster than realtime.

Share this post


Link to post
Share on other sites
Posted (edited)
27 minutes ago, Noel Borthwick said:

Yes that is the option. Regarding exporting why are you concerned with the CPU meter? Its normal for Cakewalk to use as much CPU as possible when exporting because its doing the export faster than realtime.

Nope, I dont rely on the CW CPU meter. I use Windows TASK MANAGER / Processes tab.

Im just curious why it would go this high in Task manager - to near 100%. And afraid that may cause articfacts/glitches in the export + I am sure its not good to have precessor at sustained 100%?

My original concern was working on a 26 track project with FX plugs in many that the CPU was near 100% with CW making up 60-70% of that & even at this state when not working on same project, just open . 

From here I learned it most likely plugins still active even though project not being worked on. I realise this is most likely the plugins themselves, not CW

AND In practical terms what happens if I disable "Always Stream Audio Through FX"? 

Edited by aidan o driscoll

Share this post


Link to post
Share on other sites

I have yet to hear any artifacts in an export even when I am doing other things on the computer and maxing out the CPU. It might take longer but it works. I like that the CPU gets maxed out during export to get it done faster.

When my exports do wrong it usually flat out missing something or I had a wrong selection.

Share this post


Link to post
Share on other sites

@Noel Borthwick 

I just decided to try this and WOW. With Always Stream Audio Through FX disabled in prefs CPU for CW in Task Manager Processes tab dropped to 2%. Enable Always Stream Audio Through FX and CPU for CW goes up to 50%+

So In practical terms what happens if I leave "Always Stream Audio Through FX" disabled? How would it impact on my projects which are a mix of audio tracks and soft synths where I add FX per track outside of prochannel 

 

Share this post


Link to post
Share on other sites
32 minutes ago, aidan o driscoll said:

Nope, I dont rely on the CW CPU meter. I use Windows TASK MANAGER / Processes tab.

Im just curious why it would go this high in Task manager - to near 100%. And afraid that may cause articfacts/glitches in the export + I am sure its not good to have precessor at sustained 100%?

My original concern was working on a 26 track project with FX plugs in many that the CPU was near 100% with CW making up 60-70% of that & even at this state when not working on same project, just open . 

From here I learned it most likely plugins still active even though project not being worked on. I realise this is most likely the plugins themselves, not CW

AND In practical terms what happens if I disable "Always Stream Audio Through FX"? 

Not at all. Export is SUPPOSED to try and max the CPU by design. This is how it can do it as fast as possible. There will be zero artifacts due to this because the audio driver is not involved. In practice it almost never hits 100% because there are other factors that gate performance such as the hard drive speed.

Disabling stream audio through FX will not utilize the effects unless the track is streaming audio through the effect. Its not on by default because tempo based effects will not respond to changes in transport position unless the transport is rolling. Among other things.

Share this post


Link to post
Share on other sites
Posted (edited)
38 minutes ago, aidan o driscoll said:

Im just curious why it would go this high in Task manager - to near 100%. And afraid that may cause articfacts/glitches in the export + I am sure its not good to have precessor at sustained 100%?

I'll let @Noel Borthwick give more details if he wants too, but there is a lot of misconception about the CPU running at 100%.

1. If you are doing real time stuff, like recording for example, 100% CPU usage will be detrimental because it will not be able to keep up and will miss some samples and the recorded audio will have clicks and pops. This is to be expected. If the CPU is too busy doing other things it will not be available to catch every sample of the incoming audio.

2. If you are exporting, which is not real time stuff, 100% CPU is fine. Actually it is what you want. We all want the export to take as little time as possible. The fact that exporting is actually just a non real time calculation, it can go as fast as it wants without causing any degradation whatsoever. In fact it will be at different speed on different machines, depending on their respective CPU power, and end up creating the exact same export. Speed has no real relevance other than how much time you personally waste waiting for the outcome.

3. As for having a CPU sustained at 100% for the time of an export being detrimental, it shouldn't. Many virus checkers can run your CPU to a very high % for quite a while. Unless the cooling is deficient, it is just using what you have paid for.

 

Edit: just saw Noel beat me to it. 😋

Edited by Jacques Boileau
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

 

2 minutes ago, aidan o driscoll said:

@Noel Borthwick 

I just decided to try this and WOW. With Always Stream Audio Through FX disabled in prefs CPU for CW in Task Manager Processes tab dropped to 2%. Enable Always Stream Audio Through FX and CPU for CW goes up to 50%+

So In practical terms what happens if I leave "Always Stream Audio Through FX" disabled? How would it impact on my projects which are a mix of audio tracks and soft synths where I add FX per track outside of prochannel 

 

Im not sure why the cpu use is a concern when not playing, unless you are trying to conserve battery power. Using the CPU doesnt cause any harm. In fact irrespective of this setting when you start the transport it will use the plugins.

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Noel Borthwick said:

 

Im not sure why the cpu use is a concern when not playing, unless you are trying to conserve battery power. Using the CPU doesnt cause any harm. In fact irrespective of this setting when you start the transport it will use the plugins.

@Noel Borthwick OK. In my case its not a brand new laptop. Its about 7 years old but still a Core i5 with 16GB ram and 2TB SSD drive with Nvidia + Intel GFX cards. More than enough, it handles all CW stuff great, however when CPU goes to 80 - 100% the system fan gets loud, Im trying to avoid that.

Of course, as mentioned, it could be age here and maybe the fan heat gum onto proc needs replacing. In general usage other than CW and Audio it never reaches 100% or even 80%.

But now with "Always Stream Audio Through FX" I am having a quiet life when using CW :D .. so wondering can I leave this off? It is BTW on by default ala CW manual?

Edited by aidan o driscoll

Share this post


Link to post
Share on other sites

Sure as I said if you want to control energy use then you can do that. Turning off the engine manually could also help.
Additionally if you enable the "suspend audio engine when cakewalk is not if focus" feature it will automatically stop background engine activity when you switch focus away from Cakewalk.

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...