Jump to content

Recommended Posts

I am new to Bandlab and cakewalk,

When I export the sound is different to when I master. I don't add any effects and just use midi tracks which produces a neat clean tight sound, but the WAV and MP3 all acquire reverb and a hollow timbre. I have tried many combinations and it is the same whthter I split tracks busses etc.

I feel I must be missing something and need to press a button or something in the console mode but honestly cant see where I am going wrong. Been at this for 3 days straight with no result. I see none else has this problem so I am sure its me not the software - so can someone tell me the secret?

 

Rgds

 

Allan Jennings

 

 

 

Share this post


Link to post
Share on other sites

Hi Allen, 

I have found that there is a bug still, that when you go to export audio, and say select just the master mix to export, Cakewalk will still add in the F/X buss, Phones Buss, Phones F/X buss and other buses that have anything on them to the final output mix! 

This causes the level to increase and clip and will muddy up and add way more reverb or effects to y our final output file!

You MUST mute everything that you don't want being added on your console view before exporting or it will sneak those additional buses in on your mix!

I hope this helps.

Bruce

Share this post


Link to post
Share on other sites
Posted (edited)

@Bruce Searl

I think i know what you are describing. In cakewalk, if you solo a track, other tracks mute but their sends do not.

This is not the behavior for export. If you select a single track to export, it will not send from tracks not selected through their busses.

The most common mistake is to bounce your final mix to track. The new track will likely be routed to the master bus. When you export, you will be applying the fx on the master bus again, messing up your track.

If you set your bounced track to output to your interface, you will not have this problem.

Also if you solo the master bus with your track you can listen without adding in from the buses.

Edited by Gswitz

Share this post


Link to post
Share on other sites

@Bruce Searl and @Gswitz selecting a bus for export will include all other buses that send to that bus. This is by design and is not a bug.
If you choose the Master bus in the export you are telling it to export everything that goes to the master including other buses that route to it such as the metronome or your reverb bus etc. The only way to exclude those is to mute them manually. 

In your example your phones bus will not get included in the mix unless you are also routing it to the master bus. To avoid this, route the phones bus to a hardware out rather than the master.

The Export UI could be improved, but that would add more complexity to that already advanced dialog. 

>>I think i know what you are describing. In cakewalk, if you solo a track, other tracks mute but their sends do not.

This only happens with pre fader sends and is because pre fader sends are computed before mute is applied. There is an ini setting that controls this called LinkPFSendMute in aud.ini. I suppose we can change the default behavior since some users find it unexpected.

Share this post


Link to post
Share on other sites
Posted (edited)

I didn't mean to say it was a bug.

I'm not at my pc. 

Tonight I'll retry and make a video if i think it could be at all interesting to you.

There is behavior that sometimes surprises me. I think i can demonstrate it. 

I definitely have no feature requests around this.

Edited by Gswitz

Share this post


Link to post
Share on other sites

@Noel Brothwick, that would make sense and be what I would expect. But... When I only select the main mix, and expect it to include the FX buss in that mix, but it also includes the phones mix the instrument mix, the phones FX mixes also... thus causing the main mix that should be perfect... to be too loud and clip and too wet with more FX, and even though I've only selected the main mix... that seems more like a bug. I have to actually go mute any and all other busses that I don't want to include into the mix or they get added in. It's a pain and I never had to do it with Sonar.

 

Share this post


Link to post
Share on other sites

Bruce I really doubt this is a bug. Please send me an example project so we can see the routing in the project. There is no difference in this regard from any prior SONAR version.If you are hearing other buses when picking Master there is somehow something from those buses being routed to the master via a send or aux track or something. 

Share this post


Link to post
Share on other sites
Posted (edited)

@Noel Borthwick This is what I was describing.

Please remember you can listen at high-speed in you tube. I record in real-time and it's kinda boring and not orchestrated or planned in advance, but I hope it's still helpful.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Thanks for the video  @Gswitz The behaviour you demonstrate is expected.

At 3:25 in the video the main reason why the export doesn't include the doubled reverb from the pre fader send is because you SELECTED track 2. When you do that the bounce is omitting track 1 completely from the mix as if it didn't exist. (Behind the scenes bounce actually makes a copy of just the elements of the project that are selected) If you did the export with all tracks selected you would get identical behavior to playback.

The reasoning behind prefader sends working independently even when a track is muted (in this case as a result of another track being soloed) is rooted in use cases such as setting up headphone mixes. Suppose the engineer has set up prefader sends for headphone mixes to the musicians. i.e. In this scenario you don't want the act of soloing or muting another track in the control room to cut out the sound from the headphones. IOW the engineers mix needs to be independent from the cue mix.

The ability to select elements for export is powerful but can be confusing if you don't follow the underlying routing.

 

  • Great Idea 1

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, I didn't think it was a bug. It only caught me by surprise and when I saw this post I thought maybe this is what the OP was describing.

I also think the pre-post fader difference in behavior might have led him to believe this is a new behavior and not long-time-existing. To me this behavior has been around forever, but not at first obvious why it differs as it does.

When I was first noticing it, I double checked the export to make sure my exports were ok and they were, so it has not worried me.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Perhaps the behavior of prefader sends being fully independent is too advanced for be a default behavior? 
The problem is if we change it some projects may sound different and unexpected for someone who actually has set up for headphone mixes.

We could try and expose UI to select the pre fader send behavior...

Share this post


Link to post
Share on other sites
Posted (edited)

I'd hate for you to spend any time on this.

The behavior is consistent. With a single solo'd track selected, I checked fast-bounce compared to regular bounce and in both cases the result doesn't include the sound from the non-selected track.

When listening in real time, the non-solo'd track routes through the buses into the master and may ultimately merge at the output with a solo'd track routed direct to the interface outputs.

With both tracks selected, this is the behavior in either a real-time bounce or a fast bounce.

I didn't mean for this to be a bug discussion. I was trying to help the OP with something I thought might be related to his issue or might help him understand behavior so that he could see what behavior to expect and act accordingly.

Edited by Gswitz

Share this post


Link to post
Share on other sites
Posted (edited)

I sometimes use the pre-fader sends to mix different amounts of tracks into the reverb bus. I realize you can do this post-fader too - pre-fader can be interestingly expressive.

I've never used them for real-time monitoring. I do that through TotalMix.

I think there are a bunch of us who don't do real-time monitoring through Cakewalk but might still use pre-fader sends at times and in those cases, I think the behavior isn't obvious.

When you explained the real-time monitoring use-case, the behavior suddenly made sense.

Edited by Gswitz
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

 

15 hours ago, Noel Borthwick said:

We could try and expose UI to select the pre fader send behavior...

I've always enabled LinkPFSendMute for more intuitive behavior since the performance space and control room are one and the same for me, as is probably the case for the majority of users. But since changing the default would foul up users who have come to depend on it being disabled, giving access to it from the UI would be helpful, if only to help make users aware that the option exists.  It might also be helpful to explain the use case for having it disabled in the Ref. Guide.

Edited by David Baay
  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...