Jump to content
jono grant

Attention - Noel Borthwick

Recommended Posts

Hi Noel, I've been trying to contact you about this cakewalk issue I've been trying to solve for years now. Could you please take a look at this post? You began to help me with it via email but your co-workers never got back to me with any results after I sent them info and test files on the subject.

Thanks, Jono Grant

 

 

Share this post


Link to post
Share on other sites
30 minutes ago, jono grant said:

Thanks, not sure how to do that...

 

When you address a post to someone, just start it with the "at" symbol, and then start typing their name (with no space after the 'at' sign) You will see their name resolve, then just press enter and complete your post like normal. The purpose is that they are alerted that their name was used, and it (hopefully) brings them to the post sooner.

 

I 'at mentioned' you in my reply. You can see your name at the bottom like a tag. It's a social media feature.

  • Like 1
  • Thanks 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
3 minutes ago, razor7music said:

When you address a post to someone, just start it with the "at" symbol, and then start typing their name (with no space after the 'at' sign) You will see their name resolve, then just press enter and complete your post like normal. The purpose is that they are alerted that their name was used, and it (hopefully) brings them to the post sooner.

 

I 'at mentioned' you in my reply. You can see your name at the bottom like a tag. It's a social media feature.

@razor7music

Like that? Cool! Thanks very much!

Share this post


Link to post
Share on other sites
2 hours ago, razor7music said:

When you address a post to someone, just start it with the "at" symbol, and then start typing their name (with no space after the 'at' sign) You will see their name resolve, then just press enter and complete your post like normal. The purpose is that they are alerted that their name was used, and it (hopefully) brings them to the post sooner.

 

I 'at mentioned' you in my reply. You can see your name at the bottom like a tag. It's a social media feature.

Hey @razor7music thanks for the tip! I was wondering how to do that!

Share this post


Link to post
Share on other sites

Hi @jono grant we're aware of this issue. The issue is has to do with how MPEG4 audio files or MP3 files are encoded. It is very common for "padding silence"  to be added at the beginning of the audio with compressed formats for encoding delay.  This padding can vary depending on what encoder is used to compress the file. Encoders are supposed to write a special tag in the file to notate what this delay is in samples. However there are many encoders that do not write this information to the file and there is no standard tag for this. For example ITunes does it one way and other encoders write different tags or may or may not write this data at all.

Additionally the Microsoft's SDK we use to decode the audio from these files provides no way to deterministically know what this padding delay is. Since the padding can vary for different sources, even if we guessed a compensation value it wouldn't work for different formats.  In summary, it's not an easy problem. For now I'm afraid that the best solution is to manually trim silence from encoded audio files.

  • Thanks 6

Share this post


Link to post
Share on other sites

Thanks Noel.

I wonder if they analyzed some of the other programs or DAWs on PC to see why they don't have the same issue if they might come across something. Or offer a work around somehow. It's been happening for so long and MP4s or QT files seem to be the standard when it comes to scoring for picture. Cakewalk is such an awesome program, it might be worth trying to solve. It's the only symptom I've ever come across that would deter a film/tv composer from using it.

Perhaps they could look into what mp4/QT codecs will work and publish a list, so we could request those formats when receiving video files?

Anyhow, thanks for getting back to me. I'll check back at some point to see if there has been any progress with the issue.

Cheers

Jono

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 2/27/2019 at 9:40 AM, razor7music said:

When you address a post to someone, just start it with the "at" symbol, and then start typing their name (with no space after the 'at' sign) You will see their name resolve, then just press enter and complete your post like normal...

I've tried using that feature in this forum before but it didn't work for me. But I've been experimenting just now and discovered that it only works if I do it the way that you described. It doesn't work if you type the name first and insert the @ symbol later, which is what I did.

  • Like 1

Share this post


Link to post
Share on other sites

Years ago when HD space was far more expensive. I would send my guitarist an mp3 mix and he'd add guitars and send me his mp3's back. I always put the count off on my files and he'd add about a bar of my count off to the beginning of his fies. This way I could line it up easy. If he forgot to add the count off, I could always move his guitars 51 msec earlier to get rid of the lag time, which I think is actually about 26 msec each way so in my case it was doubled. 

In my case it was very predictable, yet Noel said it depends on the encoding how much delay there is. I'm curious if there are DAW's that have solved this. I'd be surprised, so please let us know if this is a fact or just something you heard.

Share this post


Link to post
Share on other sites
18 hours ago, jono grant said:

Thanks Noel.

I wonder if they analyzed some of the other programs or DAWs on PC to see why they don't have the same issue if they might come across something. Or offer a work around somehow. It's been happening for so long and MP4s or QT files seem to be the standard when it comes to scoring for picture. Cakewalk is such an awesome program, it might be worth trying to solve. It's the only symptom I've ever come across that would deter a film/tv composer from using it.

Perhaps they could look into what mp4/QT codecs will work and publish a list, so we could request those formats when receiving video files?

Anyhow, thanks for getting back to me. I'll check back at some point to see if there has been any progress with the issue.

Cheers

Jono

 

 

Who is "they"?  :)
This is a universal problem and MP4's from different sources may have different padding so there isnt a simple universal solution I'm aware of.

Share this post


Link to post
Share on other sites
On 2/28/2019 at 3:54 PM, Noel Borthwick said:

Who is "they"?  :)
This is a universal problem and MP4's from different sources may have different padding so there isnt a simple universal solution I'm aware of.

@Noel Borthwick

Hi Noel.

Sorry... "They" would be the fine folks at Cakewalk who create new updates. :)

This is a different issue than MP3s, they will export out-of-sync in any program, agreed. That doesn't really matter though as MP3s aren't really used in professional post production, whereas MP4s are widely used for scoring to picture. 

This is in relation to MP4s and compressed QuickTime files, which; when loaded into a DAW session, the DAW will export audio in sync with the original MP4 in other  workstations but NOT Sonar/Cakewalk.

Please see the screen shots I just made (below) - each one is a screen shot of the resulting audio after opening an mp4 with a different PC DAW or editor, the same audio from the MP4 exported out of each program and then brought back into an all together different program (in this case Vegas) along side the same mp4 with it's original married-audio.

I should mention that it also works in the reverse. So, if I get sent an audio track, after-the-fact, say a new dialogue track (broadcast wave) from the post facility, it will be out-of-sync with the master video file and it will be early on the time line rather than late (like it is when exporting). And this is NOT the case when they are brought into other DAWs or editors on the PC, only Cakewalk.

*The exported audio is on the lower track in the images. You can clearly see, the other programs exported proper audio files that were in sync with the video file (and time code) and you can see how Cakewalk is out of sync and not like the rest... This is an issue in Cakewalk/Sonar... not a universal problem, after years of dealing with it, I'm pretty positive. 

That's why I thought Cakewalk might be able to go back and look at this. If other DAWs on a PC have no issue, why does Sonar/Cakewalk? It could be a very simple thing - inside the world of really complex things :)

I'm happy to do tests with other programs. I have a friend with Cubase and another with Nuendo. I have a feeling they will export in sync though.

________________________________________________________________________________________

SCREENSHOTS:

Audio Exported from MP4 within Protools and brought back into Vegas Pro (zoomed in pretty close)>

100709823_Audioexportfrommp4inprotools.jpg.b34df0f52377aacd7076931c57ff8ab1.jpg

.Audio Exported from MP4 within Sound Forge and brought back into Vegas Pro (zoomed in pretty close)>

557385183_Audioexportfrommp4inSoundForge.jpg.8fd76a9b23f90ed68bd838a28aed3b3f.jpg

.Audio Exported from MP4 within Cubase and brought back into Vegas Pro (zoomed in pretty close)>

1206967015_Audioexportfrommp4inCubase.jpg.be6922ea4f2d78713fe41a8b033d9246.jpg

 

Audio Exported from MP4 within CAKEWALK and brought back into Vegas Pro (out-of-sync) I had to zoom out to be able to see the exported wave:

290560985_Audioexportfrommp4inCAKEWALKoutofsync.jpg.d38facca0c8496bef37dcaf14dc245cb.jpg

 

 

Edited by jono grant

Share this post


Link to post
Share on other sites

It's worth noting that a video file contains two codecs: one for the video, and one for the audio. An MP4 is a container for the video & audio, where both the video & audio have their own codecs. 

It's quite common for MP4 files to use MP3 as the codec for the audio.

 

Share this post


Link to post
Share on other sites
9 hours ago, msmcleod said:

It's worth noting that a video file contains two codecs: one for the video, and one for the audio. An MP4 is a container for the video & audio, where both the video & audio have their own codecs. 

It's quite common for MP4 files to use MP3 as the codec for the audio.

 

Generally, MP4s used in post production are encoded with AAC audio codec.

If I create an MP4 using Vegas, it's the only option in the audio export preferences.

I'm quite sure none of the MP4s I get have mp3 audio.

J

Edited by jono grant

Share this post


Link to post
Share on other sites

I do not work with video, so that last picture caught me offguard. I was expecting to see "sample offset" but that appears to be "ms offset." It looks like it is off half a frame (~16.7 ms)... Am I interpretting that correctly? Is that offset exactly a frame interval (1/2, etc.)... meaning if the audio was shifted by a frame interval, would it be synced properly?

Share this post


Link to post
Share on other sites
56 minutes ago, mettelus said:

I do not work with video, so that last picture caught me offguard. I was expecting to see "sample offset" but that appears to be "ms offset." It looks like it is off half a frame (~16.7 ms)... Am I interpretting that correctly? Is that offset exactly a frame interval (1/2, etc.)... meaning if the audio was shifted by a frame interval, would it be synced properly?

Cakewalk exported audio is late by a full frame.

Share this post


Link to post
Share on other sites

Here is yet another DAW that doesn't have this problem. My friend uses Cubase and I asked him to do the same test.  Sample accurate sync. Screen shot below.

J

Audio export from mp4 in Cubase.jpg

Edited by jono grant

Share this post


Link to post
Share on other sites
7 hours ago, jono grant said:

Cakewalk exported audio is late by a full frame.

Thanks for the clarification. It made me think when I saw that picture that indexing errors can lead to such situations, especially if off by an integer value. Index values start at zero, and that picture looks like the audio is set one frame forward (index starting at 1, rather than zero). It may be coincidence, but I was led to believe the padding was akin to an audio buffer in size, but a full frame is 1600+ samples, which is far more than I expected to see. I am not sure if an indexing error is at play here, but "one full frame" is suspicious.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...