Jump to content
Robert Bone

Cakewalk doesn't seem to see *.midi even though the extension is set to open with Cakewalk

Recommended Posts

Quite bizarre - 

Tonight, I wanted to play around with a MIDI file a friend made, and sent me. 

Firstly, I double-clicked on the file, and it was opened in CbB, and configured to play using TTS-1, as expected. (Beautiful piece)

Secondly, after listening to it, per the above, I decided to set up a new project and import the same MIDI file to an empty MIDI track. to play around with it.  Denied.  CbB does not 'see' *.midi files as being something it can open, despite the fact that *.midi files are set in Windows default apps by file type, to open in CbB.  CbB just does not have the *.midi extension in its list of files it can open/import.

I can rename the file to have a *.mid extension, which IS in the list CbB presents for opening files, but it sure seems strange that when CbB was installed, (unless I changed this and do not recall doing so), it DID know enough about *.midi files to set the default app to open such files, to CbB.  So, that being the case, why isn't the *.midi extension included in CbB's known file types, in its 'Open' dialog box?

Can someone else please confirm this behavior, so I can rule out having set that file/app association, with no recall of having done so?

THANKS! :)

Bob Bone

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Robert Bone said:

Quite bizarre - 

Tonight, I wanted to play around with a MIDI file a friend made, and sent me. 

Firstly, I double-clicked on the file, and it was opened in CbB, and configured to play using TTS-1, as expected. (Beautiful piece)

Secondly, after listening to it, per the above, I decided to set up a new project and import the same MIDI file to an empty MIDI track. to play around with it.  Denied.  CbB does not 'see' *.midi files as being something it can open, despite the fact that *.midi files are set in Windows default apps by file type, to open in CbB.  CbB just does not have the *.midi extension in its list of files it can open/import.

I can rename the file to have a *.mid extension, which IS in the list CbB presents for opening files, but it sure seems strange that when CbB was installed, (unless I changed this and do not recall doing so), it DID know enough about *.midi files to set the default app to open such files, to CbB.  So, that being the case, why isn't the *.midi extension included in CbB's known file types, in its 'Open' dialog box?

Can someone else please confirm this behavior, so I can rule out having set that file/app association, with no recall of having done so?

THANKS! :)

Bob Bone

 

I remember a previous discussion.  Not sure your question is answered here (I haven't looked for it yet), but it might have some overlap with your question.

 

Edited by User 905133
to add a few more words
  • Like 1

Share this post


Link to post
Share on other sites

Yup. Same issue, confirms it for me. No current fix, because it is in the CbB Open dialog box that this issue occurs, and it is something only controlled by CbB.

Bob Bone 

Share this post


Link to post
Share on other sites

As a result of this thread, I have added the extension to Launchpad.

If you wish, I will publish a new version now with this change.

 

Share this post


Link to post
Share on other sites
5 minutes ago, scook said:

As a result of this thread, I have added the extension to Launchpad.

If you wish, I will publish a new version now with this change.

 

Howdy - thanks - as I understand it, the change you made, would launch CbB with the ability to open a midi file with the *.midi extension.  I do not think that is the issue, as CbB can already be launched to open a file with that extension because of Windows being told to associate CbB with files with that extension.

The issue I am referring to, is that if I launch CbB, and want to import a midi file to a track in a project, OR, if I am in CbB but not in a project and click File > Open, neither dialog box that opens has the list of files, used as filters, set to include the *.midi extension, so neither dialog box ever displays any of those midi files with that extension, thereby preventing either dialog box from being able to open or import them.  They are just not shown to select.

SO - I put a feature request out there a couple of minutes back, simply asking them to add the *.midi extension to the filters used in the Open and Import MIDI dialog boxes - no other programmatic changes or logis is needed.  CbB can indeed properly attempt to open those files, if one were to double-click on the midi file outside of CbB, because Windows has the association of using CbB to open *.midi files, so this is really a super duper easy programmatic change for them to implement, if they get a minute.

The workaround, for the time being, is to rename those *.midi files to *.mid, but it would be more complete for them to just fix the 2 dialog boxes.

Bob Bone

Share this post


Link to post
Share on other sites

Launchpad does nothing WRT import but can serve as a replacement for File > Open and the Start Screen using the Select source to populate the main file display.

 

Share this post


Link to post
Share on other sites
30 minutes ago, scook said:

Launchpad does nothing WRT import but can serve as a replacement for File > Open and the Start Screen using the Select source to populate the main file display.

 

I forgot - those files also do not show in the Media Browser.  I will add that to my feature request.

Share this post


Link to post
Share on other sites

They will if "Show All Files and Folders" is enabled under Views in the Media tab

Unfortunately "Show All Files and Folders" is a session setting

IIRC, persistent browser settings is a longstanding FR

 

  • Like 1

Share this post


Link to post
Share on other sites

Robert and Steve know this, but for anyone reading who has perhaps not spent as much time at a DOS/Windows command line, if you have a lot of these files to rename, you can do a folder full with "ren *.midi *.mid" from a command prompt.

You must of course navigate to the folder that contains the .midi files you wish to rename before executing the command.

I find renaming multiple files from the GUI to be very tedious and hope that this may spare someone.

  • Like 1

Share this post


Link to post
Share on other sites

before batch renaming files, be sure they're not being referenced by other apps ;)

  • Like 2

Share this post


Link to post
Share on other sites
1 minute ago, pwalpwal said:

batch renaming files

misses the point of the thread

  • Like 1

Share this post


Link to post
Share on other sites
Just now, scook said:

misses the point of the thread

was in response to the previous comment, feel free to delete

  • Like 1

Share this post


Link to post
Share on other sites

I understand. My point was about the same reply. It was easier to quote your post than type it out.

 

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Out of curiosity, are *.midi files standard midi files?

I renamed my *.smf with a *.midi extension and evidently I already had another *.midi file from somewhere.  Both open up in Cakewalk from "Everything" - a file searching/listing tool I have used for a while.

image.png.443d65839225ead4aed52e829d8bf3ba.png  image.png.fd0d97d99c532f9fc1be695ccae36a21.png

I understand the issues you raise, @Robert Bone --esp. the suggestion that other extensions should be accessible via Cakewalk itself. I totally get that!!!  I also get that renaming file extensions is not necessarily anyone's first choice.

With that in mind, this is just another possible work-around for opening the files without having to rename them--for the time being. 

Personally, I think that if the developers decide to allow for other extensions to be seen and opened from within Cakewalk, perhaps there could be something in Preferences so users can choose which extensions they want Cakewalk to see and access.

We all have personal workflows. For example, I like being able to have file filters for various things, including different types of Cakewalk files. There are probably other tools that do the same thing, too.

image.png.596e40dc8163a47f7c7a94ac6c4aef55.png for example: image.png.c73ef02930b2bea7f0d5bca1be77ae70.png

Not trying to distract from the suggestion; just offering some ideas on work-arounds. 

Edited by User 905133

Share this post


Link to post
Share on other sites

Where are you getting .midi files from? the standard extension is .mid not .midi. And CbB sees .mid files fine in the file open dialog if you pick "files of type MIDI"

  • Thanks 1

Share this post


Link to post
Share on other sites
12 minutes ago, Noel Borthwick said:

Where are you getting .midi files from? the standard extension is .mid not .midi. And CbB sees .mid files fine in the file open dialog if you pick "files of type MIDI"

I first heard about it from this (in the thread I linked above):  

On 8/2/2019 at 4:22 PM, Jean Corivo said:

Add the .midi extension to those recognized by Cakewalk when you try to open a midi file. These files come from the OSX platform. These are simple midi files but because of the extension are not visible when we try to open them through the Cakewalk application. You have to change the extension from .midi to .mid  so that it can be read by CbB..

I don't have anything that runs OSX, so I have to assume that's where its coming from.  I have no idea if there are massive amounts of *.midi files available on the internet.  I will defer to others who have used OSX. 

Share this post


Link to post
Share on other sites

Still it is in my Windows registry and looks like an MIDI file extension

 

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

Where are you getting .midi files from? the standard extension is .mid not .midi. And CbB sees .mid files fine in the file open dialog if you pick "files of type MIDI"

A friend of mine sent me some *.midi files that were created in Cubase.

So - can you guys please just add *.midi to the Fie Types for the Open dialog box, to the Import Midi dialog box, and to the Media Browser?  Literally, that would be the extent of it - no logic needed, just expand the filters for File Types in those 3 places, to include type *.midi - that is all I am looking for.  I DO have a workaround of renaming the extensions back to just *.mid, and would just like to not have to do that, if possible.

THANKS

Bob Bone

Share this post


Link to post
Share on other sites
2 hours ago, Noel Borthwick said:

Where are you getting .midi files from? the standard extension is .mid not .midi. And CbB sees .mid files fine in the file open dialog if you pick "files of type MIDI"

When I receive midi files from Cubase or Nuendo on OSX, the extension is .midi.
As far as I know, the same is true for files from Logic Pro.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...