Jump to content
razor7music

Dropout First Couple Plays Then Fine

Recommended Posts

Posted (edited)

Hello Group

This post is part of a series of issues I have since upgrading my os to W10.

I have the beginning of a new project with just about a dozen audio tracks. No fx. Really basic.

I also have one instance of Addictive Drums and that midi groove starts on measure 9. Once I hit play, I get dropouts as soon as the drum part starts, but only for the first 2 or 3 times I hit play. After that, it all plays fine.

I deleted the AD tracks and inserted a kontakt drum, and the exact same thing happens.

It acts like my memory buffer isn't utilized until the 4th or 5th play - if that makes any sense.

Recording is fine.

Any ideas?

Edited by razor7music

Share this post


Link to post
Share on other sites

Did you bump your midi buffers up? I set mine to 1,000. The defaulty is too low at 200. 

Preferences/ MIDI/ playback and recording

  • Great Idea 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have been having many of the same issues that you are having since win 10.  They just rewrote the #3 thread stuff  I was struggling just to here a few measures without skips.  So... i tried #3 a few times  and it was worst than #2.  Just for the heck of it I tried again tonight.  I can’t tell you how glad I am that i did.  No more pops and clicks, everything is running great.  You should try it.

 

Max Arwood

Try the new beta  and thread scheduling #3.  Hope it works for you too!  

Edited by Max Arwood
can't spell can't type

Share this post


Link to post
Share on other sites
16 hours ago, John Vere said:

Did you bump your midi buffers up? I set mine to 1,000. The defaulty is too low at 200. 

Preferences/ MIDI/ playback and recording

I have not. I'll try it. I'm surprised at how many settings changed or need to be changed after the upgrade.

Many thanks!

Share this post


Link to post
Share on other sites
12 hours ago, Max Arwood said:

I have been having many of the same issues that you are having since win 10.  They just rewrote the #3 thread stuff  I was struggling just to here a few measures without skips.  So... i tried #3 a few times  and it was worst than #2.  Just for the heck of it I tried again tonight.  I can’t tell you how glad I am that i did.  No more pops and clicks, everything is running great.  You should try it.

 

Max Arwood

Try the new beta  and thread scheduling #3.  Hope it works for you too!  

Hey Max

I'm not sure I understand what your suggesting. The early access program?

Would like to know.

Share this post


Link to post
Share on other sites
6 hours ago, razor7music said:

I have not. I'll try it. I'm surprised at how many settings changed or need to be changed after the upgrade.

Many thanks!

Thanks @John Vere

That was it!

Share this post


Link to post
Share on other sites

It's real dumb how that is probably a default setting that was from like 2008 and they never fixed it. It should stay once you set it even if the OS updates. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, John Vere said:

It's real dumb how that is probably a default setting that was from like 2008 and they never fixed it. It should stay once you set it even if the OS updates. 

It fixed this playback issue on this project, but I still get dropouts on a previous project that I completed just prior to the OS upgrade. There is no toast message with a code for what's causing the dropouts.

Hopefully, I won't have to remix the previous project and it stays fixed for future projects.

Anyway, thanks again.

Edited by razor7music

Share this post


Link to post
Share on other sites
On 5/22/2020 at 4:45 PM, John Vere said:

Did you bump your midi buffers up? I set mine to 1,000. The defaulty is too low at 200. 

Preferences/ MIDI/ playback and recording

MIDI buffering was revised a couple releases ago. The default now is 50, and is generous where 250 was marginal and 500 was needed in most cases under the old scheme. I've been running mine at 20 without a problem. 

 

Share this post


Link to post
Share on other sites

So I have mine at 1,000? Is this not advisable now?  And I just did a fresh install on a new OS drive and when I looked it was at 200. That is with the latest version. I then bumped it to 1,000 like I've always done. Certainly working just fine. 

Share this post


Link to post
Share on other sites

Is it possible that your hard drive is failing to deliver the sample file data in a timely enough fashion, to keep up with Cakewalk?

This can be caused by having a single hard drive on the computer, where programs, and program data, and app data, and sample libraries, all live on the same drive, and this issue can also be caused by antivirus software scanning every single file that is opened (even in read mode), by default, and for sample library files, that can just murder streaming audio performance.

Most antivirus software, might be all, comes with a means of adding a series of file/folder paths to a list of exceptions/exclusions, where the antivirus software will skip the scanning of any file and folder, and sub-folder, for any of the paths entered into that exceptions/exclusions list.  There is no need to scan all of those files over and over and over, every time you trigger a sampled sound.  ALL of those files and folders, and sub-folders, were already scanned when the sample libraries were installed, they are safe to skip.

I also add exceptions, to Avast on my system, for:

C:\Program Files\Cakewalk\*
C:\Program Files\Common Files\VST3\*
C:\Program Files\VST64\*
C:\Users\rober\AppData\Roaming\Cakewalk\*
E:\*
G:\*

Please note that in the above list, the E: drive is a sample drive (I have several other such drives as exceptions, just no need to list them as that only applies to my system, which has 4 separate hard drives with nothing on them but sample libraries.

And, the G: drive is the drive where I have all my Cakewalk Content folder, and the Cakewalk Projects folder, so I just have that whole drive as an exception in Avast.

Bob Bone

Share this post


Link to post
Share on other sites

I posted solved too soon. I still get dropouts when the drum sampler starts the first couple times I hit play, then it's fine for the rest of the session.

Ideas?

Share this post


Link to post
Share on other sites

Is your antivirus off?  That’s what I do. Also turn off the internet in large projects. Which drum sampler?

 

Max Arwood

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/23/2020 at 11:28 AM, razor7music said:

Hey Max

I'm not sure I understand what your suggesting. The early access program?

Would like to know.

Current release now!  Try Plugin  load balancing off and/or on the see which is best for your projects/machine.  Its in preferences / playback and Recording. 
 

Max Arwood 

Edited by Max Arwood
Siri

Share this post


Link to post
Share on other sites
4 hours ago, razor7music said:

I posted solved too soon. I still get dropouts when the drum sampler starts the first couple times I hit play, then it's fine for the rest of the session.

Ideas?

He's talking about the early access 2 release. It's not officially released yet.

I'm not sure I follow. If you get a dropout there is always a toast message displayed telling you that. 

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, Noel Borthwick said:

He's talking about the early access 2 release. It's not officially released yet.

I'm not sure I follow. If you get a dropout there is always a toast message displayed telling you that. 

That's another issue. I don't get a toast message to tell me the dropout code. Toast messages for loading the project, etc. but the dropout is a mystery.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/30/2020 at 2:17 PM, Max Arwood said:

Is your antivirus off?  That’s what I do. Also turn off the internet in large projects. Which drum sampler?

 

Max Arwood

Never affected with W7, but I'll try it.

kontakt 6 player with NI session drums samples. Same thing happens with AD 2.

-EDIT-

Hey @Max Arwood Shutting off AV protection had no effect--but worth a try. Thanks

Edited by razor7music

Share this post


Link to post
Share on other sites
On 5/30/2020 at 8:21 PM, Noel Borthwick said:

What version of cbb are you running?

Can you share the project?

Hey @Noel Borthwick

I'll be back in studio tonight and will provide those answers. All these issues started when I upgraded to W10. In fact, I have dropouts on a finished project that had no problems with W7--now I can't even play one measure in W10--no toast message there either.

Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, razor7music said:

Hey @Noel Borthwick

I'll be back in studio tonight and will provide those answers. All these issues started when I upgraded to W10. In fact, I have dropouts on a finished project that had no problems with W7--now I can't even play one measure in W10--no toast message there either.

Thanks!

Are you running the original 04 release or the latest early access build? What is your thread scheduling model set to?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...