Jump to content
jono grant

Cakewalk randomly changing high DPI scaling setting

Recommended Posts

Hi, I use a 4 K display and need to set Windows at 150% to be able to see everything large enough.

Cakewalk is randomly changing the setting (under compatibility) no matter what I have it set to. 

Annoying bug in Cakewalk. Anyone else have this issue?

J

 

Share this post


Link to post
Share on other sites
19 hours ago, jono grant said:

Cakewalk is randomly changing the setting (under compatibility) no matter what I have it set to. 

ui scaling has caused issues for some while now, maybe the "randomly changing" is deliberate code to keep some bits still working/readable when they would otherwise fail if not at 100%? do you see a pattern as to when it gets c hanged?

/fwiw

Share this post


Link to post
Share on other sites
21 hours ago, jono grant said:

Hi, I use a 4 K display and need to set Windows at 150% to be able to see everything large enough.

Cakewalk is randomly changing the setting (under compatibility) no matter what I have it set to. 

Annoying bug in Cakewalk. Anyone else have this issue?

J

 

I don't think that Cakewalk supports DPI scaling. I seem to recall reading that in a thread on using 4K monitors. At the time I was thinking of buying a larger 4K monitor, but decided not to after reading that post.

Share this post


Link to post
Share on other sites

I have a 4K monitor. I use 150% scaling without any problem.

 

When you say 

22 hours ago, jono grant said:

under compatibility

What do you mean by that?

Share this post


Link to post
Share on other sites

- If you right-click the cakewalk program icon and select properties there is a tab for compatibility. You can do various things here like "always run as administrator" or in this case change "high DPI settings" > this is the one that keeps changing.

- I have all my programs to run as administrator so I don't think it has to do with that.

- Cakewalk is compatible with DPI scaling it just looks a little fuzzy as do many other programs that don't use vector type graphics.

This was working fine for a couple of months but just started happening. I open Cakewalk and it's overriding the setting and opening at 100%. It should be following the rest of the computer and opening at 150% DPI scaling.

I'm wondering if it's been happening since the latest update. I don't see any other pattern. It worked for some time and then didn't. It's completely random. If I open now it might be fine, or not. The setting in compatibility is to "override high DPI scaling" meaning it will override what's set in Windows but I just want it to do what's set in Windows so I leave it unchecked. i can also check it and choose to have the system or the application decide the DPI scaling, which I've tried "system" which should do the same thing. Bottom line is, it's changing randomly throughout the day.

@Noel Borthwick Perhaps you've heard of this behavior?

Thanks

Jono

1162251004_PDPIsetting.thumb.jpg.fc0d6e9ae77c790d60403040ff7b6f9c.jpg

Share this post


Link to post
Share on other sites
3 hours ago, reginaldStjohn said:

Those are windows settings. If they are not staying then it has something to do with windows and not Cakewalk. 

I usually don't have this check mark on, meaning there is no setting chosen normally. So every program in Windows should just have the 150% scaling. Cakewalk randomly does not. It's the only program I have that does this, so I don't think I agree that Cakewalk has nothing to do with this problem. Otherwise I would see other programs having the same issue. Only Cakewalk does this. 

Share this post


Link to post
Share on other sites
22 hours ago, Base 57 said:

I have a 4K monitor. I use 150% scaling without any problem.

I don't have a 4K monitor but would like to buy a 40" one once Cakewalk is updated to handle DPI scaling. @jono grant maybe the two post on previous threads below will help. It appears that the Cakewalk UI doesn't handle DPI scaling unless, it's been addressed since @Noel Borthwick post below.  @Matthew Sorrels is also using a 4K monitor and has some troubleshooting suggestions.

 

  • Like 1

Share this post


Link to post
Share on other sites

Out of curiosity (esp. since I might want another monitor myself one of these days), are these monitors special professional grade monitors or can I get by with a multi purpose TV that has a bunch of HDMI inputs?  Also, if it's the latter (consumer-grade TV), is it best to avoid a so-called "smart" TV, or does that not affect input from  an HDMI out?

(Apologies if this is a bit OT since this is not explicitly a set of problem-solution diagnostic questions, but some of you seem to have knowledge about this type of technology; plus it does follow in part from the previous post's reference to future purchases.)

Edited by User 905133

Share this post


Link to post
Share on other sites

What symptoms are you seeing in Cakewalk? Since the last Cakewalk version update, I am unable to see the little menu expansion arrow next to 'Insert Audio FX'  in the menu that pops up with you click the "+" on the bin, or right-click in the bin space. There are 3 little dots instead of the expansion arrow and I have to click on 'Insert Audio FX' to get the next menu with all my plugins to pop up and I can't walk backwards through the menu from that point. Minor annoyance, but seems like it may be a similar, scaling-type issue.

I have not made any changes to my system. Windows 7, 64-bit. 1920 x 1080 resolution (non-4k), which also has not changed...

Edited by Christopher H

Share this post


Link to post
Share on other sites
1 hour ago, Christopher H said:

What symptoms are you seeing in Cakewalk? Since the last Cakewalk version update, I am unable to see the little menu expansion arrow next to 'Insert Audio FX'  in the menu that pops up with you click the "+" on the bin, or right-click in the bin space. There are 3 little dots instead of the expansion arrow and I have to click on 'Insert Audio FX' to get the next menu with all my plugins to pop up and I can't walk backwards through the menu from that point. Minor annoyance, but seems like it may be a similar, scaling-type issue.

It may have to do with how many audio effects you have.  I seem to remember they changed this, but it was a long, long (years) ago.  Because the popup menu didn't work very well with 1000+ plugins.  I haven't seen pull off arrows for audio effects for a long time.

Share this post


Link to post
Share on other sites
1 hour ago, Bill Phillips said:

I don't have a 4K monitor but would like to buy a 40" one once Cakewalk is updated to handle DPI scaling. @jono grant maybe the two post on previous threads below will help. It appears that the Cakewalk UI doesn't handle DPI scaling unless, it's been addressed since @Noel Borthwick post below.  @Matthew Sorrels is also using a 4K monitor and has some troubleshooting suggestions.

 

The Noel post you sent was one of my posts! haha Bottom line was that Cakewalk looks great at 100 or 200% but not as good in between like 150 or 175.

You should go get the 4K monitor you want, Cakewalk will look fine on it. If your monitor will be 40" you'll likely be fine with 100% scaling. I'm on a 32" so I need to set it at 150%. I also wouldn't hold your breath on Cakewalk being updated for 4K, apparently that would be a massive task according to Noel.

Cakewalk is totally usable on 4K. I just have this strange little bug changing the scaling setting for some reason.

J

  • Great Idea 1

Share this post


Link to post
Share on other sites
1 hour ago, User 905133 said:

Out of curiosity (esp. since I might want another monitor myself one of these days), are these monitors special professional grade monitors or can I get by with a multi purpose TV that has a bunch of HDMI inputs?  Also, if it's the latter (consumer-grade TV), is it best to avoid a so-called "smart" TV, or does that not affect input from  an HDMI out?

(Apologies if this is a bit OT since this is not explicitly a set of problem-solution diagnostic questions, but some of you seem to have knowledge about this type of technology; plus it does follow in part from the previous post's reference to future purchases.)

4K monitors are surprisingly cheap nowadays. I don't think the TV is quite the same thing. Your video card needs to support it as well. The 32 inch 4K display I got was only like $350 or something. A smart TV is okay if you're just putting it up on the back wall to view videos but if it's a main display for computer programs you'd probably want a computer monitor. Some nice ones out there...

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Christopher H said:

What symptoms are you seeing in Cakewalk? Since the last Cakewalk version update, I am unable to see the little menu expansion arrow next to 'Insert Audio FX'  in the menu that pops up with you click the "+" on the bin, or right-click in the bin space. There are 3 little dots instead of the expansion arrow and I have to click on 'Insert Audio FX' to get the next menu with all my plugins to pop up and I can't walk backwards through the menu from that point. Minor annoyance, but seems like it may be a similar, scaling-type issue.

I have not made any changes to my system. Windows 7, 64-bit. 1920 x 1080 resolution (non-4k), which also has not changed...

I'm not sure what you mean. Here's a screen shot of my efx bin when I right click it or hit the + sign. It seems to be the way I remember it. Is yours different than this? 

FX bin.jpg

Share this post


Link to post
Share on other sites

@jono grant

I'm also using 4K monitors with Windows 10 at 150%, and haven't noticed CbB doing anything unusual (it always opens at 150%).

As far as high DPI support goes, CbB asks Windows to take care of scaling the UI, and that's all there is to it. We're not doing anything beyond that, so if there's a problem, it could be a Windows issue.

Firstly, are you using Windows 10? If not, which version? All bets are off if it's Windows 7 I'm afraid. As well as no longer being supported, high DPI support in Windows 10 is much improved over Windows 7.

Secondly, I notice the 'Override high DPI scaling behavior' checkbox is checked in your screenshot. Unlikely, but FWIW it's unchecked on my PC (which I believe is the default).

Edit: You mentioned that CbB is the only app with this issue, but if it's also the only app that you've changed high DPI settings for, then it could still be a Windows issue.

Edit 2: I see from your screenshot that you're on Windows 10, not 7 or 8, since I can see 'Windows 8' in the 'Compatibility mode' dropdown!

Share this post


Link to post
Share on other sites
On 1/29/2020 at 11:15 AM, jono grant said:

I'm not sure what you mean. Here's a screen shot of my efx bin when I right click it or hit the + sign. It seems to be the way I remember it. Is yours different than this? 

FX bin.jpg

'Insert Audio FX...' used to look like 'Insert Soft Synth' with the expand arrow next to it, but now it looks like yours. I'm going to do some plug-in cleanup as suggested above and see if that makes a difference. I'm pretty sure I don't have over 1,000 plugins, but I have many installed that aren't used. Will update after cleanup. 

Edited by Christopher H
typo

Share this post


Link to post
Share on other sites
37 minutes ago, Ben Staton said:

@jono grant

I'm also using 4K monitors with Windows 10 at 150%, and haven't noticed CbB doing anything unusual (it always opens at 150%).

As far as high DPI support goes, CbB asks Windows to take care of scaling the UI, and that's all there is to it. We're not doing anything beyond that, so if there's a problem, it could be a Windows issue.

Firstly, are you using Windows 10? If not, which version? All bets are off if it's Windows 7 I'm afraid. As well as no longer being supported, high DPI support in Windows 10 is much improved over Windows 7.

Secondly, I notice the 'Override high DPI scaling behavior' checkbox is checked in your screenshot. Unlikely, but FWIW it's unchecked on my PC (which I believe is the default).

Edit: You mentioned that CbB is the only app with this issue, but if it's also the only app that you've changed high DPI settings for, then it could still be a Windows issue.

Edit 2: I see from your screenshot that you're on Windows 10, not 7 or 8, since I can see 'Windows 8' in the 'Compatibility mode' dropdown!

I don't use that Override feature, it just happened to be on in my screenshot.  Yes I'm on Win 10. 

Share this post


Link to post
Share on other sites

I have a 65" 4K HDTV, and if I use the recommended resolution, I use 200% scaling, or cut resolution in half and run 100% scaling.  Seems to be OK at either.

Bob Bone 

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...