Jump to content
Noel Borthwick

[CLOSED] Cakewalk 2019.11 Hotfix Early Access 1

Recommended Posts

2019.11 Hotfix Early Access 1 (HFEA1) installer now available!

Thank you to everyone who has provided feedback on the official 2019.11 release! This hotfix addresses some key issues based on field reports and user feedback. We're releasing this early to unblock any users who rely on onboard audio devices using WASAPI mode. The public hotfix will be released soon but we're waiting for more feedback before final release. Please report any issues in the 2019.11 feedback thread.

Note: The HFEA1 installer will only update the official 2019.11 release.

Download Hotfix EA1

What's New

  • Glitchy audio playback with WASAPI on some devices - particularly with onboard audio since updating to 2019.11.
  • Crash if an ASIO device was disconnected while in use by the application

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Because when using shared wsapi because I have two input devices, you can't select both. if I want all A have to go to preferences, if I want to use b I have to go to preferences. when normal should be, choose directly from the input channel? Also if you choose the ISO drive has only latency and does not recognize the overall audio output, with wsapi is very good. aside from having to select from the menu p. thx

Share this post


Link to post
Share on other sites

You can't select two inputs or outputs from DIFFERENT devices in WASAPI shared mode. Its a limitation of how shared mode works.

If you want to use different devices simultaneously use WASAPI exclusive mode which has the ability to pick independent devices simultaneously. Of course this will only work if the two different devices support the common sample rate.

Share this post


Link to post
Share on other sites

Issues prior to the latest update  was crashing when using VST 3 instruments and plugins along with the ASIO  audio driver. You recommended solution was to use WASAPI driver and use VST2 instead. This worked. I installed the latest update and opened an existing project and the sound from my studio monitors was as if my speakers were blown. There was a buzzing noise . I also started a new project and tried  again to use ASIO and VST3 and it crashed when I inserted a midi clip from Ample guitar. I tried again, this time I only changed back to VST3 and left the driver to ASIO and it also crashed.  I changed the driver back to WASAPI and opened an existing project with VST2 instruments and the sound is crackly on playback and soon after I got a “audio engine dropout (9)”. I created a new project with WASAPI and VST2 plugins and it was ok.

Share this post


Link to post
Share on other sites

I've been experiencing some trouble with melodyne, everytime I create a FX region, the software displays the melodyne window but with no information. I need to close it and open it again so I can see the notes.

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

Just a general “thank you” to the Bakers not just for this update and hot fix but for keeping my favorite DAW well alive and kickin’.

 

I’ve been onboard since Pro Audio (I think version 9 ?) in 2001 or so.

 

Thanks guys !

  • Thanks 1

Share this post


Link to post
Share on other sites

 

 

Even installing the fix version, when I try to save a project created by the previous version program crashes. Same situation when trying to record VST. Projects created in previous versions are saved normally without application crash.

Edited by Milton Sica

Share this post


Link to post
Share on other sites
On 11/29/2019 at 4:21 AM, Apeirofobia said:

I've been experiencing some trouble with melodyne, everytime I create a FX region, the software displays the melodyne window but with no information. I need to close it and open it again so I can see the notes.

same issue here. I have to use my old sonar platinum untill this is resloved :(

Share this post


Link to post
Share on other sites

Thank you for this hotfix and posting on the Facebook pages. I installed the last build and straight away had problems in playback - terrible noise, no matter the latency.

This update fixed all that (whew) - no I can get back to making music.

  • Thanks 1

Share this post


Link to post
Share on other sites

I installed the hotfix today and it corrected the audio engine freaking out (disconnecting constantly) but I get the attached error when I close a file. It's otherwise working great.

 

Probably unrelated. LOL.

_11302019_205645.dmp

Edited by Terry Kelley

Share this post


Link to post
Share on other sites

I've been running the hotfix since Friday and haven't noticed any problems. That said, my audio interface runs great until it doesn't, so perhaps this is premature, but add the data point anyway.

Share this post


Link to post
Share on other sites

Hi,

Thanks for the hotfix (it seems to work), adding my data point:

Got the issue specifically with the last Cakewalk update (I was working on a project, it was fine; installed the update, resumed work, it was no longer fine; in the meantime no Windows updates, I'm running 7 so I can be fairly sure, no other updates I would know of), reinstalled everything, removed all my plugins, still had the issue.

The most relevant info pre-hotfix: driver mode WASAPI Shared (because I'm cheap and only have on-board audio), Mixing Latency settings fixed and cannot be changed.

Post hotfix: still WASAPI Shared, Mixing Latency settings actually still fixed and cannot be changed but the noise and dropouts are no longer there.

See also screenshots (sorry for half of them being JPGs, I didn't notice they were being saved like that).

Looking forward to seeing it permanently and officially fixed but good job nonetheless.

before1.JPG

before2.JPG

before3.JPG

after1.PNG

after2.PNG

after3.PNG

Share this post


Link to post
Share on other sites

Hi @Krecikdwamiljony thanks for the report. in wasapi shared mode unless you have a win10 driver that supports lower latency the latency is fixed at 10 msec. Since you are running win 7 that would be the expected result here. I think there is a ui issue with the slider being grayed out which we'll look at. Thanks!

Share this post


Link to post
Share on other sites

I thought I understood the issue but apparently I don't 😊 I thought that before the update I had been able to set a higher latency by increasing buffer size and/or number of buffers (so audio always had time to be processed) but after the update both have been set to a very low value (and not all samples were computed on time, causing all the buzz) without the option to increase either.

Glad it works again, though.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...