Jump to content
Sign in to follow this  
Colin Nicholls

Possible bug - Input Echo (audio track) stops working

Recommended Posts

There is definitely something strange going on in 2019.09 with Input Echo on an audio track suddenly not working.

The use case is this: I'm working in my project, rehearsing a guitar or external synth part, and suddenly I realize that I can't hear the instrument. So far it's always been an audio track on which I've got Input Echo manually enabled. (Either to hear the FX bin, or just because.)

Using the mouse, I toggle the blue Input Echo button back and forth with no success. I have to Run/Stop the audio engine (in the Transport module) before Input Echo is restored.

I will try to work on steps to reproduce, but in the meantime, if other folks have observed this, or have advice, please add to the thread. Thanks.

Share this post


Link to post
Share on other sites

Does this happen in every single session, just one particular session, or here and there in any random session? I've have this and other weird stuff like this happen on its own and sometimes closing out of the session and opening it back up will fix it. Other times the problem will still be there when opening back up and in those cases I port things over to a new session and that will usually fix it. You can try that. You can do it by saving all the tracks and buses as a template and loading that into a new session and then while having two sessions open simultaneously, copy the tracks from one session to the other. It's not perfect, as not every setting is properly saved in the template, such as aux input settings, phase button settings and bus colors that I've observed won't save.  It may be a pita but if you get tired of stopping/restarting the audio engine then maybe a clean session will solve it for now. 

Edited by Christian Jones
x

Share this post


Link to post
Share on other sites

Well it's happened to me at at least once in each of the last three sessions... and it always develops some time after starting a new session, i.e. I've never had it not work once during a session. I've always been able to correct it mid-session by Run/Stop the audio engine.

Share this post


Link to post
Share on other sites

Everything looks normal - the engine is running; all recorded stuff is playing back (audio, vst, midi); I just can't hear my guitar as I play along. The blue Input Echo light on the track lies to me...

Share this post


Link to post
Share on other sites

Do you have plugins in that track? If the rest of the project is playing ok toggling the engine shouldn't have any affect on input echo.

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

Do you have plugins in that track?

I've experienced it both with plugins and without.

If the rest of the project is playing ok toggling the engine shouldn't have any affect on input echo.

I don't know what to tell you other than what I've experienced, as described above. Toggling the engine restores input echo on the misbehaving track.

Share this post


Link to post
Share on other sites
20 hours ago, Colin Nicholls said:

I don't know what to tell you other than what I've experienced, as described above. Toggling the engine restores input echo on the misbehaving track.

If their are FX in the track, you can't know that it's echo that's failing. If the FX aren't passing audio, there's nothing to be echoed out. You implied earlier that is can happen with no FX in the bin. Are you sure about that?

Edited by David Baay

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

If their are FX in the track, you can't know that it's echo that's failing. If the FX aren't passing audio, there's nothing to be echoed out. You implied earlier that is can happen with no FX in the bin. Are you sure about that?

Yes, absolutely. It was that experience that prompted me to write up a post about it.

I haven't experienced it again in the last 24 hours, for what it's worth, but I'm sensitized to it and paying attention in case it happens again.

Share this post


Link to post
Share on other sites
28 minutes ago, Colin Nicholls said:

ECHO Layla 3G PCI         Focusrite Scarlett 6i6 2nd Gen

Are you using WDM driver mode to have both interfaces available, or only using the Layla PCI in ASIO mode currently? If so, I'd recommend trying ASIO mode with just the Focusrite interface, and see if ithe problem persists. Years ago I had an issue with input-monitored tracks going silent on rewinding after recording a take with my EMU 1820m PCI. In that case, toggling the audio engine or just restarting the tranport would bring them back to life, and stopping the recording with R instead os Spacebar before rewinding would avoid the problem entirely. Something seemed to be causing the audio driver to close the ports on rewind from stop. Have not seen the issue since the 1820m died, and I started using a MOTU PCie interface. 

 

Share this post


Link to post
Share on other sites

Hi @David Baay, thanks for the great suggestions.

I pretty much exclusively use the Layla3G in ASIO mode. I while back I completely switched to the Focusrite 6i6 for some trials but returned to using the Layla. I've never used anything but ASIO mode since it became an option back in... whenever.

In my last post, I spoke too soon: I indeed did experience the non-echoing Input Echo behavior earlier this evening. It might well have been immediately after recording a take - I will be trying to reproduce that.

Also, very good idea about trying the Focusrite interface to see if the same thing happens. Intend to do that also, but was waiting until I had a clear set of reproducable steps.

It's funny you should mention alternatives to Spacebar for starting and stopping playback and recording. I've noticed that Spacebar seems prone to mis-starts or bursts of static instead of normal playback, whereas using the mouse to click the transport button is less prone. I haven't tracked that down in any detail, yet, but it seems strange.

(All this makes it sound like I'm having multiple issues but the truth is, my system is behavior pretty well and I'm happy making a lot of progress on my projects. )

Share this post


Link to post
Share on other sites
5 hours ago, Colin Nicholls said:

It's funny you should mention alternatives to Spacebar for starting and stopping playback and recording. I've noticed that Spacebar seems prone to mis-starts or bursts of static instead of normal playback, whereas using the mouse to click the transport button is less prone. I haven't tracked that down in any detail, yet, but it seems strange.

I saw somewhere in the forum others talking about the same issue using a Focusrite interface (driver update issues).  I myself have experienced this "static" effect on playback.

This has since stopped since I have updated my driver to the "next" to latest version and have not had this happen for a few months.  Perhaps it is your driver?

[additional info]  After the coffee kicked in I seem to recall that updating the Focusrite drive did not go well the first time and I re-installed the driver and rebooted my laptop and then things worked better . . .   Don't know if it applies, but thought I'd add it anyways.

Syphus

Edited by Syphus
More is better

Share this post


Link to post
Share on other sites

It happened again this morning. Yes, I'd been tracking some guitar but each time I stopped transport, I'd playback and also check that Input Echo was working. It was. Then suddenly, after a short period, it wasn't. I have no reason to think it was consequential to recording the take.

Instead of Run/Stop audio engine, I tried a few other things:

  • toggle input echo on the current track (no change; could not hear guitar)
  • select a different track (same IO input) and toggle input echo (no change)
  • scroll up to a completely different track with no FX in bin, but same IO input; toggle Input Echo (still no sound)
  • Turned on my Roland Keyboard (VK8) and temporarily changed the IO input from "In 7+8" to "In 5+6"; enabled input echo and played a few notes: SUCCESS
  • Restored the input to "In 7+8", COULD HEAR INPUT
  • OK, go back to the guitar track and enable input echo: I CAN HEAR GUITAR

So, in summary, I think that forcing Input Echo to operate on a different set of inputs may have restored normal Input Echo operation.

(Let me stress that all these tests are with the ECHO Layla3G control panel muting the direct monitoring. I'm only listening through the DAW outputs.)

So that was interesting. I'll keep working and see if I can isolate the exact steps to make it happen.

Share this post


Link to post
Share on other sites

When input monitoring is failing, do you get either or both input or output meter activity on that track? Really sounds like an interoperability issue with the driver.

Share this post


Link to post
Share on other sites

@David Baay, I don't think I see meter activity but I wouldn't swear to it. I'll double-check that next time it happens. When it does, I'm going to do the following:

  • Check the Layla Control Panel for meter activity (prediction: I'll see positive signal level)
  • Check the Cakewalk Track Meter (prediction: no activity)
  • Switch input channels on the specific track (prediction: input echo restored)

In the meantime, it's good that I've got a lot of guitars to record/track 🙂

Share this post


Link to post
Share on other sites

If there's no meter activity when armed to record, that would suggest the driver isn't opening the input port. If that's the case, I could see how switching to a different input and back would re-open the port. You might experiment with the Always Open All Devices setting in Audio > Playback and Recording.

Share this post


Link to post
Share on other sites

Yeah, @Noel Borthwick, I know, I know....

FYI, it just happened again and everything happened according to my prediction: Layla control panel indicated signal (and I could hear it when unmuted the direct RT monitoring, of course); no activity in the DAW meter until I toggled the input channels on the track, at which point normal operation returned.

When it happens, it happens immediately after stopping playback. (not recording). So far, this morning it's always been upon reviewing the latest take (playback only) that I realize the input echo isn't working.

Seems to be quite prevalent this morning. The thing to do now would be to switch to the Focusrite 6i6 for a bit and see if I ever get it happening there...

Also just FYI, the option in Preferences > Audio > Playback and Recording is unchecked:

           [  ] Disable Input Monitoring during playback

 

Summary:

OK, given that this totally can't be debugged by BandLab without reproducing it against a modern audio interface+driver, I may stop posting updates here unless I can do that. 

As Noel gently hints, this wouldn't the first quirk I've dealt with using the ECHO Layla 3G but, damn, even so, I love that interface.

 

 

Edited by Colin Nicholls

Share this post


Link to post
Share on other sites

Its not impossible that its a bug in the state of the input monitor channel in CbB. Do you have "Allow arm changes during playback/record" enabled?
If also see it with another interface please let us know. Its strange that you see input on the layla panel. However its possible that its not passing the input to the DAW via ASIO. 

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

Do you have "Allow arm changes during playback/record" enabled?
If also see it with another interface please let us know.

Will do. No, that option is not enabled.

However, today I learned that the "Project" section in Preferences only displays if you have a project open. Are they Project-specific settings? I guess they are. Huh.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...