Jump to content
  • 0
Syphus

[SOLVED] No Sound from Instrument after Imported MIDI

Question

Hi All,

I have encountered this problem . . .   I would like some thoughts . . .

Here is the Process:

1) Create/edit a bass guitar part using Guitar Pro 7 (GP7) and export the midi

2) open a CW session (project) and using the "Synth Rack" create a instance of SI bass with/source midi track.

At this point I can click on the bass string or run the MIDI program snippets on the left side or use the virtual controller keyboard and get sound from the instrument.

3) import or drag & drop (D&D) the midi from GP7

4) When I hit play, the midi track shows activity (VU), but now no sound is produced.

5) Stop play & go back to the instrument GUI (interface) . . . Clicking on bass or running the programs on the left do not produce any sound.

Interesting enough, if I do not import or D&D the midi everything is working as described (I kill the project before hand by closing CW).

Notes:

Sometimes when I try to open CW again,  it will not open and is hanging (still active process).  Killing process allows me to open CW again.  I don't know if it will

kill it's self at this point (process) but something is obviously running in the background of CW.

If I manually enter midi data using the PRV (on the instrument's source track), all is good and I can play the midi notes with sound.

I tried to use the event viewer to see if there was anything weird going on with the imported midi,  but saw nothing.

Tried using another VST (MODO Bass) and reacted the same as described above

 

I'm assuming the the midi data from GP7 is the problem as this point.  I'm going to go and generate some other midi data with another program and import

it to see if it has any problems . . .

Has anyone out there experienced this? 

 

Thanks,

Syphus

Edited by Syphus
Solved

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
13 minutes ago, Promidi said:

After you have performed the import of the MIDI data into the SI bass MIDI track, open the event list view.  Are there any events in there other than notes?

This would be my guess. Chances are Guitar Pro 7 is adding setup information to the exported files. This should be dealt with by modifying the program's export options.

Cakewalk sfz engine synths shut down when encountering unexpected data. Once the data is sent to the synth, it will make no sound until the project is shutdown and restarted. There are two ways to deal with the unexpected data in MIDI clips -

  1. Open the clips in the Event List View and remove the offending data. Often the data is at the beginning of the clip. Deleting everything up to the first note may be enough or
  2. Enable "Don Not Intercept NRPNs" in the VST plug-in properties page for the synth

3Oa2ztH.png

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

OK - I'm back . . .

Problem is solved due to several things:

1 - I created some midi (for bass track) using another program that I know the results of.

  • had to adjust notes to bring them into VST range - this worked importing the file

2 - Grabbed the midi file from Guitar Pro and imported (using drag & drop method):

  • Stripped out the extra data from midi using "Event Viewer"
  • Set the VST to ignore NRPN data (per Scook)
  • Had to adjust note register (how low can you go - not that low - LOL).  So most of the data was out of range of the VST (my bad @mettelus thanks)
  • Hit play and all is good

Thanks everyone for your help/suggestions - Have a great day!

Syphus

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

After you have performed the import of the MIDI data into the SI bass MIDI track, open the event list view.  Are there any events in there other than notes?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, Syphus said:

[snip]

4) When I hit play, the midi track shows activity (VU), but now no sound is produced.

[snip]

Do you have an audio track that corresponds to the midi track and if so, does the audio volume show there?

This might not be your issue, but in many cases I find it helpful to have both the midi and audio track sliders showing. 

Edited by MusicMan11712 (aka Dr. Steve)

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Syphus said:

2) open a CW session (project) and using the "Synth Rack" create a instance of SI bass with/source midi track.

Another comment to add to the above. The SI bass is also off by an octave IIRC, requiring you to to manually offset it. Unless you also have notes in the higher octaves, it will appear to be playing, but no sound.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I will try to answer all here:

3 hours ago, Promidi said:

After you have performed the import of the MIDI data into the SI bass MIDI track, open the event list view.  Are there any events in there other than notes?

yes tried to look and edit the midi via "event viewer"  there was a "NRPN" at the beginning of the file - I deleted it but the condition persisted.

 

3 hours ago, MusicMan11712 (aka Dr. Steve) said:

Do you have an audio track that corresponds to the midi track and if so, does the audio volume show there?

This might not be your issue, but in many cases I find it helpful to have both the midi and audio track sliders showing. 

I do not believe it is my issue - the instrument worked until I imported the midi . . .

 

3 hours ago, scook said:

This would be my guess. Chances are Guitar Pro 7 is adding setup information to the exported files. This should be dealt with by modifying the program's export options.

I thought the same  . . .  unfortunately I  do not see any export parameters with Guitar Pro

3 hours ago, scook said:

Cakewalk sfz engine synths shut down when encountering unexpected data. Once the data is sent to the synth, it will make no sound until the project is shutdown and restarted. There are two ways to deal with the unexpected data in MIDI clips -

  1. Open the clips in the Event List View and remove the offending data. Often the data is at the beginning of the clip. Deleting everything up to the first note may be enough or
  2. Enable "Don Not Intercept NRPNs" in the VST plug-in properties page for the synth

I will look at this  . . .  and enable "Don Not Intercept NRPNs" and see what happens.  I will also edit the midi first (before clicking  play ) to remove the NRPNs to see what happens there.

3 hours ago, mettelus said:

Another comment to add to the above. The SI bass is also off by an octave IIRC, requiring you to to manually offset it. Unless you also have notes in the higher octaves, it will appear to be playing, but no sound.

not likely in this case as I am using two different VSTs  and both are acting badly with this data

 

Thanks all for your suggestions . . .   I will working on it later and report back . . .

 

Syphus

 

Edited by Syphus
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...