Jump to content
GreenLight

Help! Super-weird bug with audio preview in browser 😟 (reproducible!)

Recommended Posts

Hi all!

I have been having an intermittent problem with Cakewalk (and maybe Sonar?) for a long time, but unfortunately I can't really reproduce it reliably.

I preview a lot of wav files using the browser, and sometimes certain files "bypass" the preview bus and somehow play back anyway, often REALLY LOUDLY, making me jump in my chair. No meter in Cakewalk moves, but I can see the sound card mixer software reacting. It doesn't happen very often, but when it does it seems to affect a specific file: that file always has the same problem every time I play it during that session. I just had the issue with a wav loop, but after restarting Cakewalk, the same file played back normally through the preview bus. 😕

So I'm wondering if anyone else has experienced this? I just had the problem on Cakewalk 2019.09 build 70.

I don't know how to troubleshoot or to properly report it... :(

Edited by GreenLight
Changed topic name

Share this post


Link to post
Share on other sites

This is happening to me again! 🤔

Sometimes, when previewing samples in the Browser, the selected preview bus is bypassed and sound is sent directly to the hardware output.  What could make this happen?

It's very unpleasant, as it is so LOUD! But I still can't find a consistent way to reproduce it though...

Share this post


Link to post
Share on other sites

My super-weird audio preview bug is back again! 😣

Check the screen capture below:

  • I show you my selected Audio Preview bus
  • I click on 4 consecutive WAV loops and for the first 3 you can see the Preview Bus meter moving
  • But playback of the fourth loop somehow bypasses the preview bus, sending audio at full volume to my hardware outputs instead!

Am I the only one to ever run into this weirdness?

1424720500_previewbusweirdness.gif.daa0965d23726692d76c69dd59bb5b77.gif

Share this post


Link to post
Share on other sites
On 10/18/2019 at 5:17 PM, GreenLight said:

Hi all!

So I'm wondering if anyone else has experienced this? I just had the problem on Cakewalk 2019.09 build 70.

I don't know how to troubleshoot or to properly report it... :(

Having had an issue with Preview on certain files,  and currently working with support on another issue with the Media Browser, I feel your pain!

I haven't had the same issue that you have, but had an issue that involved certain WAV files not previewing correctly as well.  Please consider the following if you haven't tried already:

1) When the issue happens with the same file, you said you can replicate it until you restart Cakewalk.  So, does it still happen if you mute the Preview Bus?  Also, what happens if you mute ALL busses? Then mute the Master bus only? Is there still output on the Hardware interface meters? This might help track down where the errant audio is coming in from, and which bus.

2) One of my issues with Media Browser came from the fact that some of the WAV files had a wav file header that caused a playback problem.  It looks like you're using a sample pack from a company.  Is the issue always caused by the same company's files?  Do you have an issue with other samples, from other companies?  If you have any REX (.rx2) files, see if you run into the issue with REX file playback as well.  

3) When you get this issue, what happens if you do a reset of the audio engine, does it still happen?  Also, if you have another audio interface (like an on-board Soundblaster or RealTek sound chip) when the issue happens again, switch to one of these sources and see if you can replicate the issue.  Also, if you have other audio driver types besides ASIO, try switching to those like WDM or WASAPI if you have those as choices, and see if you can replicate the issue there.

3) My issue was fixed in 2021.01, 2019.09 is a bit far back.  Is there a reason why you don't go to 2021.01?  What version of OS are you running?   How old are the Hammerfall drivers? 

All of these suggestions are designed to try to pinpoint if some kind of issue is happening on certain files, and if the issue lies with Cakewalk, or the audio driver.  Hope this helps!

Share this post


Link to post
Share on other sites

@forkol Thanks for your reply, I will investigate and report back soon!

34 minutes ago, Noel Borthwick said:

Your first step should be to upgrade to the latest build and try and reproduce it there. 2019.09 is an ancient build.

Thanks @Noel Borthwick. Today it happened with 2020.11 but I will upgrade to the latest build and report back. The problem is it's so intermittent... but I am patient! :)

Share this post


Link to post
Share on other sites
3 hours ago, FJ Lamela said:

In the last update it also happens sporadically, it has happened to me.

Thanks. Good to know I'm not alone – at least it confirms I'm not (that) crazy... 😛

Share this post


Link to post
Share on other sites
Posted (edited)

@forkol @FJ Lamela Thanks for your previous input! I can now reproduce this with the latest Cakewalk version 2020.01 Build 098.

This is a breakthrough for me (it's the small things in the world, right...? 🙃) I hope someone else can verify if it's a real bug or just my system that's weird.

Long story short, my problem has two connected parts:

  1. Sometimes when opening projects, my previously selected Audio Preview Bus (in the Browser) has changed for an unknown reason

    And the real problem:
  2. During the session: files that I have once played via bus A, will always be played through bus A, even with bus B (or bus X) subsequently selected

Steps to reproduce:

  1. Create an empty project
  2. Create two buses, for example MASTER and PREVIEW
  3. In the Browser, set the Audio Preview Bus to MASTER (auto, tempo and loop settings seem not to matter)
  4. Play,  say, three .wav files and remember which ones you played
  5. Change the Audio Preview Bus  to PREVIEW
  6. Listen to the same files you just played. They should still play through MASTER. Other files will correctly play through PREVIEW.

It is consistent, but it seems that sometimes additional files will refuse to play through the new bus as well.

I'm going crazy. 🤪 Thanks for any help!

Edited by GreenLight
Color optimization :)

Share this post


Link to post
Share on other sites

@GreenLight

I can confirm the bug whitout your steps even.it happens even when you have more buses

i hope the team will can fix it in the next update.

  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, FJ Lamela said:

@GreenLight

I can confirm the bug whitout your steps even.it happens even when you have more buses

i hope the team will can fix it in the next update.

Thank you so much @FJ Lamela! Finally I figured it out, and it's reproducible - victory! ✌️ I have been annoyed by this bug for 4-5 years or more... my first post in this thread is from 2019.

There are basically two things I would like to forward to @msmcleod or someone from the Cake team:

  1. To report the bug when changing buses for Audio Preview Bus as described above
  2. Investigate why the selected Audio Preview Bus would suddenly change when opening projects. It doesn't happen a lot, but from time to time.

Thanks for a great product!

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, GreenLight said:

Thank you so much @FJ Lamela! Finally I figured it out, and it's reproducible - victory! ✌️ I have been annoyed by this bug for 4-5 years or more... my first post in this thread is from 2019.

There are basically two things I would like to forward to @msmcleod or someone from the Cake team:

  1. To report the bug when changing buses for Audio Preview Bus as described above
  2. Investigate why the selected Audio Preview Bus would suddenly change when opening projects. It doesn't happen a lot, but from time to time.

Thanks for a great product!

I agree,cakewalk is a great daw and have feautures before than any other daw.

The bug as you told is intermittent,sometimes it happens a lot, sometimes sporadically.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...