Jump to content
iZiKKO

Akai MPK mini II latency problem

Recommended Posts

Hi guys! I have just set up my brand new Akai MPK mini II Midi keyboard in Cakewalk, but it seems to have some latency when I hit the keyboard keys. I'm assuming my set up did not go well! (I have included my current settings below)

Would anyone know how I should set this up properly?

I have connected the controller to a USB port on my Dell Inspiron 5758 laptop. No other devices are connected, except mouse. My laptop is running Windows 10, has 8GB RAM and Realtek  audio (see first image). It seems that Realtek is not supporting ASIO drivers?

Note: When I'm playing the MPK through Akai's MPC Essentials there is no latency or other issues.

Please help me set this thing up so I can start rocking.

compsetup.jpg

CaBsetup4.jpg

setup.gif

setup2.gif

setups3.gif

setups4.gif

setups5.gif

setups6.gif

setups7.gif

setups8.gif

setups9.gif

setups10.gif

Share this post


Link to post
Share on other sites

Latency is caused by the buffer settings for the audio interface and Plug-in Delay Compensation. In this case, the "Mixing Latency" buffer slider appears to be at the minimum setting and is just a little less than one would expect using an ASIO driver at 512 samples. IOW too high for real time use. The maximum setting needs to be no more the 256. Even then some find the latency a problem. Good values for most start around 128 or about 1/3 of the minimum setting achieved using your current hardware.

 

  • Like 1

Share this post


Link to post
Share on other sites

For low latency audio one needs a good audio device with drivers that can give you low latency. The built in audio on most computers i.e. Realtek  were never meant to do low latency audio.  Though later Realtek chips and drivers do include ASIO. I have not bothered to see how well they preform. 

An inexpensive audio device  with the right specs can be had for around $100 or less.  I do not recommend  ASIO4all but some have reported usable results with it. 

  • Like 1

Share this post


Link to post
Share on other sites

@scook Thank you for your advice, mate! I tried to move the Mixing Latency slider 1/3 to the right but once I click Apply it goes right back all the way to the left (Fast). Very odd?

Share this post


Link to post
Share on other sites

@John I know Realtek is not a very high end audio device but it still does the job in when I'm using the MPC Essentials. As I mentioned, there is no latency with MPC, it just comes up with Cakewalk. That's why I think I must have wrong settings in Cakewalk.

Share this post


Link to post
Share on other sites

Moving the "Mixing Latency" buffer size slider to the right is the wrong direction. The slider is already at its minimum which it several times more than an acceptable value for real time monitoring. Possibly one of the other Audio driver mode settings will provide a better minimum value for the "Mixing Latency" buffer size slider. Once the best driver mode/latency setting is achieved, the only other consideration WRT latency is Plug-in Delay Compensation.

  • Like 1

Share this post


Link to post
Share on other sites

I installed ASIO4ALL  on my laptop for use with my Realtek audio chip.   It gives me acceptable latency with virtual instruments using any DAW I wish to use.

https://www.sweetwater.com/sweetcare/articles/installing-and-using-asio4all-for-windows/

My laptop is a low end unit not intended for serious audio use, but I find it a handy to have scratchpad for playing virtual instruments when I am traveling.  Note: using the Realtek audio chip gives acceptable audio playback over headphones or external speakers, but I would never intend to record external instruments with this.  I would say that use would definitely require an external audio interface.

Edited by abacab
  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys for all your advice! I managed to clear the latency somehow! I was tweaking the settings a lot, so can't be sure, but I think finally it was changing the File System Playback and Record I/O buffer values from 256 to 128. Now my Akai is quite responsive with Cakewalk.

Peace and rock on!

Edited by Kris Olin

Share this post


Link to post
Share on other sites

In your original screenshots, you set the interface to "WASAPI Shared".  That gives worse latency possible, even on lower settings.

Some interfaces have good latency in "WASAPI Exclusive" and/or "WDM/KS". The only problem is that you can not get Windows audio (Youtube, etc.) when the DAW is running.

Many interfaces have best latency in ASIO mode. For example latest Realtek chips (I do not know if your notebook has such). Note that I had to install Realtek original driver first and DELL specific on top of it to make my XPS work correctly while showing Realtek ASIO panel (somehow DELL has forgotten to include required module). These chips in ASIO mode beat in latency many low end interfaces. I have not measured reported 6ms RTL, but the latency is definitively lower then with VS-20.

Note that ASIO not always gives lowest latency. F.e. latest Behringer interfaces do better with WDM/KS. My old M-Audio Firewire has approximately the same latency with both, but "WASAPI Exclusive" is worse.  At the same time a cheap tablet rocks with "WASAPI", can not work with "WDM/KS" and hardly usable with ASIO4ALL. So the best mode is particular interface dependent.

Periodically I get huge MIDI (!) latency from different devices (e-drums, DP). Interesting that I had no such problem with MPK Mini. Rebooting the system was helping. The reason is still unknown (that problem is rarely reported, but people hit it from time to time).

PS. What can not influence the latency is the File System buffer size. Under some condition it can produce cracks/pops, but it is technically completely unrelated to the latency.

  • Like 1

Share this post


Link to post
Share on other sites

If MME works for you, that is great. It is better to spend time making music than tuning latency and MIDI tolerates higher latency then let say guitar (voice is the worse).

Just do not hesitate to try other modes if you start to feel you want a bit faster response.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...