Jump to content
Sign in to follow this  
Sonarman

Zoom in makes it extremely difficult to place the clips precisely on the grid

Recommended Posts

So I just zoom in to check whether the loop is placed perfectly on the grid and this opens up several issues. I'm not sure whether this is a
display issue or a bigger issue. I Zoom in (really microscopic to the extent the smart grid turns to 1 sample) and a few weired things start
to happen. 
1)Firstly the grid line disappears. 
2)I am not able to movie the clips or place the now time precisely at the place where CbB ruler says the the 2nd bar is(Or any other bar I
try, but i didnt came across the same issue when I tried this in bar 4 & 7 so I guess this is specific to some measures.)
3)Prior to zooming in the now time stays at the precise 2nd bar but if I move it after zooming in it wont get placed in the same place again. 
4)The waveform in side the clips appears displaced from its original location. 

363645527_CbBissue.png.b62b13e769e715328d4a96b52b2ff7ea.png

Its really messy this ain't the first time I noticed this, have came across this soo many times but today it was really annoying coz it was
hindering my workflow. I always thought its a display issue in the gui but today while trying to loop some bars it created fade out to the
nearby clips although the loops are exactly 1measure long with the same tempo. So I zoomed in to see what the issue is and its a real mess.
One of these issues seems to disappear(displaced waveform Issue no 4.) if I turn the Looping on in Grove clip properties

Not able to recreate this issue when the tempo is kept at 120. Happens in various projects though. My current project is 138bpm.

It might be a little hard to write what I am facing.
May I just ask you to open an empty project and change the bpm to 138. Now import a audio loop or something and try to keep it somewhere, lets
say bar 2. now keep the now time at bar 2 and zoom in really hard to check whether the loop is kept precisely at bar 2 you will come across
all sorts of complications I am going through. Hope its a known bug or there is some explanation why this happens.  

Another display issue I have seen a many times in Sonar is the Waveform in clips show as if there is data at the end of clips when kept at a
particular horizontal zoom in/out level. Clips look fine when kept at other zoom levels.

640255727_CbBWaveformerror.png.69764146fa7313976412da3bb388c380.png

Share this post


Link to post
Share on other sites

All I can say is that I had most of the issues above in 32-bit Sonar for years, so just to confirm.

Share this post


Link to post
Share on other sites
3 minutes ago, chris.r said:

All I can say is that I had most of the issues above in 32-bit Sonar for years, so just to confirm.

I see. I'm running 64bit, the issue is consistent in both my PC's one running W7 and another running W10

Share this post


Link to post
Share on other sites

How are you zooming in?

I just tried what you asked, I zoomed in to the sample level, and my clip stayed exactly at Bar 2.

I can not reproduce your issue.

 

When you zoom in so far, the grid lines disappear depending on your snap settings. I had it set to 128th note and the grid did disappear after I zoomed in beyond that level of note resolution.

Edited by Grem

Share this post


Link to post
Share on other sites
28 minutes ago, Grem said:

I just tried what you asked, I zoomed in to the sample level, and my clip stayed exactly at Bar 2.

With zoomed max try to click at bar 2 to place the now time there, or drag the clip a few samples around and try to place back at bar 2.

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, Grem said:

How are you zooming in?

I just tried what you asked, I zoomed in to the sample level, and my clip stayed exactly at Bar 2.

I can not reproduce your issue.

 

When you zoom in so far, the grid lines disappear depending on your snap settings. I had it set to 128th note and the grid did disappear after I zoomed in beyond that level of note resolution.


Yea, thanks for checking. Couple of things to make sure, 1) have you changed the tempo? While kept at 120 there seems to be no issue. I also tried changing the tempo to various rates and at some tempos (40, 80, 120, 100, 200,etc) this issue doesn't show up. It does show up in tempos like 70, 98, 138, 139, 170, 101,...

2) Like @chris.r suggested you will have to zoom it to the maximum. Even after reaching sample level keep zooming in untill it max out. Now try to move the clip or now time a little and try to place it back at bar 2. 

I have kept display vertical lines in front of the clip in track view settings, so even after zooming to sample level i could see a grid line in exactly 2:01:000 but this line disappears when I zoom in further maximum. This may or may not be a normal behavior when someone zooms in max, but I am zooming in to make sure if the clip is aligned on the grid and the grid line disappearing dont help. This aint a big issue still if the other issues doesn't show up. The clip in itself looks misaligned and not sure of its position. like this...

251848328_CbBissue.png.082164afb8dbcc16fb1899eff5a04cb1.png

So now when you try to drag the clip or now time new issues show up.  You cant click or drag the now time or clip precisely near  2:01:000, and the clip wont move to its previous location what ever you might try. Its as if something is messed up in the grid's algorithm that sonar itself is unsure where exactly the clips should be placed.

Edited by Sonarman

Share this post


Link to post
Share on other sites

It seems that you can only move to whole sample positions (which makes sense). Depending on sample rate and tempo, those positions may not align precisely with musical time. So it's inevitable that there might be a small offset between sample and bar/beat. You can check that by adding a sample ruler.

That said, grid lines shouldn't disappear of course.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, dreamkeeper said:

It seems that you can only move to whole sample positions (which makes sense). Depending on sample rate and tempo, those positions may not align precisely with musical time. So it's inevitable that there might be a small offset between sample and bar/beat. You can check that by adding a sample ruler.

That said, grid lines shouldn't disappear of course.

I did anticipate something of this kind as an explanation for this.. Could be true. However the way CbB handles this is still eccentric. It is expected that the clip might not be able to align precisely to the musical time if what you say is true.  yet after zooming in the now time wont precisely align to the beats as well, how could that be the case?

Share this post


Link to post
Share on other sites

@Sonarman I did what you described/ asked. So yes I changed the tempo. I also zoomed in as far as it will go, sample level.  And yes, I did as you asked, when zoomed in max I was able to move the clip, get it back exactly to bar 2, and I was able to get the now marker on bar 2 also.

If you want a clip to fall exactly on the beginning of a bar, you can use snap settings of a musical time. IOW measure, half, quarter, eighth, act. 

There is also a setting (not at my computer) that puts edits at the zero crossing, eliminating the need to zoom in and check.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Grem said:

@Sonarman I did what you described/ asked. So yes I changed the tempo. I also zoomed in as far as it will go, sample level.  And yes, I did as you asked, when zoomed in max I was able to move the clip, get it back exactly to bar 2, and I was able to get the now marker on bar 2 also.

If you want a clip to fall exactly on the beginning of a bar, you can use snap settings of a musical time. IOW measure, half, quarter, eighth, act. 

There is also a setting (not at my computer) that puts edits at the zero crossing, eliminating the need to zoom in and check.

Thanks Grem. Now this means something else has to be looked at. And perhaps I did use snap settings indeed, it all looks nice and snappy but when i zoom in all these discrepancies show up. 

Update: Yes once I zoom in I am able to move and snap back the clip to bar 2 by changing the snap setting to musical time. The problem was smart grid changing its settings to 1 samp. thus preventing me from snap the clip back to bar 2. The now time also follows the snap settings.

So now going back to my first post

Quote

1)Firstly the grid line disappears. 
2)I am not able to movie the clips or place the now time precisely at the place where CbB ruler says the the 2nd bar is(Or any other bar I
try, but i didnt came across the same issue when I tried this in bar 4 & 7 so I guess this is specific to some measures.)
3)Prior to zooming in the now time stays at the precise 2nd bar but if I move it after zooming in it wont get placed in the same place again. 
4)The waveform in side the clips appears displaced from its original location. 

1) This does happen but ain't a big issue maybe.
2)@Grem and @dreamkeeperhelped with this, I'm able to move back the file to the precise location by changing the snap settings from 1 samp. to musical value.
3)Same as point 2 this is also possible by changing snap settings.
4)This does happen.  And since @Grem could not reproduce this in his setup this further complicates things. Hope few more guys try reproducing this.  I will try to post a video demonstrating this.

Edited by Sonarman

Share this post


Link to post
Share on other sites

@Sonarman look here to make zero crossing settings: https://www.cakewalk.com/Documentation?product=SONAR X3&language=3&help=Dialogs2.076.html

 

I can get the clip right back on bar 2, but it takes a little drag/drop/drag/drop to get it just right without snap settings. With snap settings it just snaps to the bar 2 mark. Is this what your referring too?

56 minutes ago, Sonarman said:

when i zoom in all these discrepancies show up. 

How does it sound? Does it sound like a click at the beginning of the clip? Is it out of timing?

  • Thanks 1

Share this post


Link to post
Share on other sites
8 hours ago, dreamkeeper said:

That said, grid lines shouldn't disappear of course.

I agree with this. And this was the only thing I forgot to look at when I did your test.

And @Sonarman you are correct, at the last seven to eight steps from zoom being maxed out (or would that be maxed in!) the grid lines disappear. I think you may have found a bug. : )

You can report it by submitting steps to reproduce the issue to @Noel Borthwick, @Jon Sasor, or @Jesse Jost any one will get you to the place to make the report.

Edited by Grem
  • Great Idea 1

Share this post


Link to post
Share on other sites
1 hour ago, Sonarman said:

Yes once I zoom in I am able to move and snap back the clip to bar 2 by changing the snap setting to musical time. The problem was smart grid changing its settings to 1 samp. thus preventing me from snap the clip back to bar 2.

Yet another mysterious ghost inside cakewalk revealed :D.

  • Haha 1

Share this post


Link to post
Share on other sites

 

19 minutes ago, Grem said:

@Sonarman look here to make zero crossing settings: https://www.cakewalk.com/Documentation?product=SONAR X3&language=3&help=Dialogs2.076.html

 

I can get the clip right back on bar 2, but it takes a little drag/drop/drag/drop to get it just right without snap settings. With snap settings it just snaps to the bar 2 mark. Is this what your referring too?

How does it sound? Does it sound like a click at the beginning of the clip? Is it out of timing?

Yes its possible with the snap turned off as well, requires a little more effort dragging. But since I kept my smart grid turned on and smart gird was trying to snap to 1. sample I was not able to place the clips precisely at 2.01:000. 

When I zoom in the clip looks like this with the blue line extending till the previous sample ruler although the clip is aligned at bar 2.
 1574251295_CbBissue.png.6f6dcedc469f69ab48ab66b2fabe8651.png

No there is no problem with the sound it sounds fine, but when I try to loop the clip by copy pasting to the next following measures some of the clips create fade in and outs randomly which is what in the first place made me to zoom in and check for errors.


Btw snap to zero crossing is turned of in my preferences and I dont think it has any effect on this.

Edited by Sonarman
Added Quote

Share this post


Link to post
Share on other sites

Ohhhh!! Now I get it!! : )

 

I changed the tempo BEFORE I did anything else. Let me try it now that I know what you mean and see what I get.

  • Thanks 1

Share this post


Link to post
Share on other sites

Nope. I still get the expected results. I don't see the extended zero waveform lines that you see. Even when I do it like you do in the video.

 

 

On another note, I never use the Smart Grid. It does things that I don't expect and I am left wondering 'Why is this happening?' So I made myself a project template that I use for new projects. So I essentially never see Smart Grid in action.

 

Let me ask you this, has that clip your dragging been edited at the start/beginning of the clip? That might have something to do with this. IOW, CbB is saving the info that's been edited in case you want to revert back to the original clip.

 

And look what happened with me!

 

1375920450_Clip1.PNG.1e367c58ac3fdfa97aa246a85f04ed20.PNG

 

This was after I edited the clip, then bounced it to clip.

  • Like 1

Share this post


Link to post
Share on other sites

I am working with 24/44 on my Surface Pro. And I see your at 48/32 which may be why we see a difference. But based on what I am seeing, I think what your issue is has to do with CbB saving extra data/info for the clip so that it can revert back or undo. And that is compounded by you switching the tempo after the project was started.

Others have reported strange behavior that was due to info that is 'traveling' with the clip for reasons of reverting and undo. So I am not sure if this is a bug or expected behavior.

 

Now I could be way off on the reasons why this is happening, but I think I am in the3 ballpark! : )

Maybe someone else will chime in and give us a different reason.

  • Great Idea 1

Share this post


Link to post
Share on other sites

Wicked. I am actually importing a Vengeance factory loop directly into the grid.  However I tried different files including final mixdown's I made from CbB. This shows up with everything. And yes since you are using 24/44 in your DAW you might not experience this in the same bar as mine, try switching the clip to bar 3 bar 5 etc.  And different tempos.

Edited by Sonarman

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...