Jump to content
  • 0
Angramme

DAW audio output modified

Question

I don't know if I'm accurate with my prediction but I think the audio from Cakewalk is being modified before being fed to the speakers. What do I base this theory on? Well when I export my audio it sounds different when played back in VLC or similar software (more on that here: 

)

But once I load it back inside the DAW and play it, it sounds like the original project! at first I thought that the problem lies in the export but now my theory is: ( I will use the term "weird compression" to signify the potential DAW internal audio "routing" bug ) [my routing is correct, all buses going to master, and master to audio interface]

- my original project audio played inside the DAW is going through some weird compression or something thus it sounds different than in reality.

- when I export it, the DAW exports it without  the weird compression so I hear the real audio when I play back the exported version.

- once I import back the exported audio inside the DAW it once again applies the weird compression thus audio sounds the same as the original project but it's not the real audio

That's just my speculation, meaby the problem is somewhere else. If you know what it might be please tell me :)  but if I'm somehow right, how do I fix it?

EDIT:

Use sort by date if you want to understand the whole conversation

Edited by Angramme

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Glad you found it. The "Enhancements" tab was 5th tab I couldn't remember... it is not present on my Win10 machine, and I do not miss it.

  • Haha 1

Share this post


Link to post
Share on other sites
  • 1

Let me see if I can help.

  1. Open your project in Cakewalk and start it playing . While playback is in progress mute the master bus. Is it then silent? If you don't have silence there is a routing problem. If it is silent then...

  2.  Adjust the master fader so that the volume never peaks above  -1  (at this point most people don't go above  -3).

  3. Instead of exporting the mix, bounce it to a new track (Select all, then click the Tracks tab in the Track View header and then click the Bounce to Tracks option - the Bounce menu will open - in the source category  choose buses and then highlight only the Master bus then click OK).

  4. When the bounce is complete, solo the resulting track and route it's output directly to the hardware output. Play it back. It should sound exactly the same as the mix (if it does not come back here and let us help you figure out why).  If it sounds right trim any unwanted time from the beginning and the end, add fade in and fade out, then bounce the clip to itself (If you want it to play back a little louder you can Normalize it to -1).

  5. Select your finished clip (rename it now from the right click menu if you wish) and export it (don't use the Export button- instead use File/Export/Audio - in the Source Category choose Clips - set your desired sample rate, bit depth, and dither). When exporting clips there is no need to enter a file name. The clip name will be the name of the resulting file.

 

I hope this helps. FWIW I never export mixes. The above method may seem complicated but once you have done it a couple of times you will see the logic behind it...

 

Or not.

 

  • Like 2

Share this post


Link to post
Share on other sites
  • 1

Does the daw and vlc use the same sounddevice and the same speakers?

If not that's something that can affect the sound experience.

Share this post


Link to post
Share on other sites
  • 1

I read your first post. The description of how it sounded made me think of an equalizer or filter that removed low frequencies.

Share this post


Link to post
Share on other sites
  • 1

Check your Realtek quick... "Sound" in Control Panel... then select the Realtek and "Properties." In that pop-up, go to the "Spatial Sound" tab at the top and make sure that it is set to off. Windows has internal FX chains (basically) that are accessible to programs that will color the sound coming out of the system. Some programs also have these internally (I believe VLC does), so you can also check them there... mixers, ambient environment, speaker fill, and other DSP effects. You want to check that those are all either zeroed out, or off.

Bear in mind, that someone listening to your music is doing so in their own environment; so even though you may have them off, they may have them on.

Share this post


Link to post
Share on other sites
  • 1

Hello Angramme,  don't get too depressed.  When you finally solve this issue it will likely turn out to be something very simple. Let's go down what you've done so far.

2 hours ago, Angramme said:

 I don't know how to bounce the track to itself.

Right click the clip. Bounce to clip is in the right click menu. This renders any edits and processing.

 

2 hours ago, Angramme said:

 By "normalize the volume" do you mean compression? 

Normalize is in Process/Apply Effect. It allows you to raise or lower the overall volume of a clip so that it peaks at a specific value.

 

2 hours ago, Angramme said:

I routed it's output to my "Speakers (Realtek High Definition Audio)

I am going to avoid suggesting a different interface. These things are usually fine for playback. Record latency and fidelity are a different matter.

 

2 hours ago, Angramme said:

I played it and it still sounds different than my original mix, why?

Let's try a different approach.

  1.Drag the clip (Output) into the Cakewalk browser. Then open a new blank project and drag the clip (Output) into it.

  2. Open Preferences/File/Audio Data and change the render bit depth to 16.

  3. Right click the clip and Bounce to clip. This will render it as a 16 bit clip.

Now drag the file onto the Windows desktop and play it with Windows media Player.

 

Try this. I will check back shortly.

Also Mettelus  is probably on to something with "Spatial Sound"

 

Share this post


Link to post
Share on other sites
  • 1
13 minutes ago, Angramme said:

Also just to check my sanity, when you export your music it sounds exactly the same as in the DAW when played in vlc or windows media player right?

Therein lies the issue. Windows Media Player has a truckload of sound enhancements internal to the program. All media players have some sort of mixer to my knowledge, so in addition to Windows itself, each program would need to be checked.

The export from Cakewalk will reflect the options of the export dialog, so if a media player sounds differently, check the settings for any mixers or sound enhancements. Based on your issue, it seems they are engaged in your media player.

Share this post


Link to post
Share on other sites
  • 1

The Cakewalk  Browser is toggled on or off by hitting the "B" key. It has 3 tabs at the top for Media, PlugIns, and Notes. The media tab can navigate to practically any folder in your computer. It is a tremendously flexible way to move audio files or samples into or out of projects.

As for your last question, yes. For me exported files sound exactly like they are supposed to in other players. I believe that what @mettelus has written about is the real problem. The Media Player/ VIC or the Realtek mixer software (or both?) is likely adding some sort of processing.

Also check that Windows itself is not the culprit. Right click the audio icon in the Windows Taskbar. Open playback device/ properties - there is an enhancements tab there as well.

Also try copying the file to your phone or tablet.

At some point you will find the problem. It will very likely be one of those slap the forehead moments (DOH!).

Anyway, best of luck.  I know these sorts of things can be creativity killers. All you want to do is make music and instead you are (expletive deleted) around with computer settings. I've been there. You will get it to work.

Share this post


Link to post
Share on other sites
  • 1

Yes that is weird.

Another experiment...

Create a new blank project and import a file from a commercial CD. Then export that file without any other processing. If this also exports noise you may need to contact CbB support.

I have to go for now and fry some other fish, but I will check back late tonight or in the morning to see how you are getting along. If I think of anything else I will post from my phone.

 

 

Share this post


Link to post
Share on other sites
  • 1
On ‎5‎/‎1‎/‎2019 at 3:13 PM, Angramme said:

I've downloaded it on my phone and it's just noise, that's weird because I exported it in standard settings 16 bit depth, 44100 sample rate, no dithering. Why is it? It at least plays in VLC and others on my computer.

Your phone might not have a codec to play the wav file. Thus it just sounds white noise over your phone speaker. IDK.

I do know WMP and VLC are not great for dissecting mixes, only for a basic listen.

Share this post


Link to post
Share on other sites
  • 1

Nah, you are good. There is always someone lurking around. There are three things to check to find your issue, but if Windows Media Player and VLC sound the same, it is probably in #1 or #2 below:

  1. Windows level - Type in "Sound" in search bar and open "Sound (Control Panel)." Select the Realtek (or whatever the default device is on the Playback tab) and "Properties." In that pop-up, go to the "Spatial Sound" tab at the top and make sure that it is set to off. Also, on the "Advanced" tab, set the default format to something reasonable (I use 24-bit, 44100 Hz (Studio Quality)), and check that both "Exclusive Mode" options at the bottom are unchecked. I seem to remember Win7 had a 5th tab at the top, and think it was for Dolby FX, which you would also want off if it is there. Basically, check all of the tabs in that pop up for any audio effects.
  2. Realtek - There is a version of Realtek HD Audio Manager (or some such) that I *think* could also be accessed via the "Configure" button on the Sound (Control Panel) -> Playback tab after selecting the Realtek. If you have that installed, it should come up typing "Realtek" into the Windows search box. This is not on my Win10 machine, but if you can access that (have it installed), I know there were also things like "Speaker fill" (essentially fake surround sound), and the Dolby FX there (playback environments like "Bathroom" and such). Disable those if you can access.
  3. VLC (this is most likely not your issue, since you get the same results on VLC and WMP) - For VLC specifically, the mixer stuff is in the "Tools->Effects and Filters" if you open the application (I opened it without launching a media file). Go through each tab of the "Audio Effects" and make sure that none are enabled.

Check those first and see if that helps, and can go from there. #1 and #2 above are the ones that will affect you at a system level.

 

Edited by mettelus

Share this post


Link to post
Share on other sites
  • 1

Please pick one reply as an answer regardless of how many posts it took to solve the problem.

Also there are two sort orders for each thread just below the OP. The default sorts by vote  but there is a sort by date option as well.

thanks

Share this post


Link to post
Share on other sites
  • 0

Hi Base 57! Thank you for your reply, I will go through what I've done:

1. Yes it's silent when I mute master.

2. I adjusted it so it never goes above -3

3. I've done it, I now got a new track.

4. I soloed it so no sounds come from other tracks, and I routed it's output to my "Speakers (Realtek High Definition Audio)" directly, It sounds exactly the same :) I skipped the fading out and in, the volume adjustement and bouncing it back to itself.  I don't know how to bounce the track to itself. By "normalize the volume" do you mean compression? 

5. I've selected it renamed the track to "Output", then did exactly what you said ( I tried without enetering a filaname then I tried enterng it too ) And nothing happened and the file wasn't exported. I tried restarting cakewalk. Still nothing. However going inside the audio directory of my project I found "Master (Bounced, 9)" (the same as the clip name) I played it and it still sounds different than my original mix, why?

I've noticed that it sounds different only outside the DAW, when you import it as audio it sounds the same as original. Once the export happens and you get the file it for some reason always sounds different than original and always in a same way. I'm getting kinda depressed to be honest...

Edited by Angramme

Share this post


Link to post
Share on other sites
  • 0

Thanks for your response Kurre, I don't know what sound device does vlc use but I have only one that is *real* anyways in my laptop (meaby windows emulates one), but they certainly both use my headphones.

EDIT:

I think they both use "Speakers (Realtek high definition audio)"

Edited by Angramme

Share this post


Link to post
Share on other sites
  • 0

Yeah it sounds kinda like this but also with reverb. but why would vlc and groobe music and audacity apply an equalizer or filter to the music? or is it applied when exporting? Also my kick that is much lower doesn't get changed a lot.

Edited by Angramme

Share this post


Link to post
Share on other sites
  • 0

Thanks for your replies. I checked the spatial sound and it's turned off but you said that some programs can turn it on internally?Also instead of turning these default DSP effects off (because everyone has them on), how would I apply these to cakewalk so I can hear what I'll export? 

Secondly Base 57 thanks for your encouragement :)

1. by cakewalk browser do you mean the bandlab sample browser? 

2. I believe I did it already (I don't have access to my computer right now, I'm writing on my phone)

Also just to check my sanity, when you export your music it sounds exactly the same as in the DAW when played in vlc or windows media player right?

 

Edited by Angramme

Share this post


Link to post
Share on other sites
  • 0

I've downloaded it on my phone and it's just noise, that's weird because I exported it in standard settings 16 bit depth, 44100 sample rate, no dithering. Why is it? It at least plays in VLC and others on my computer.

Share this post


Link to post
Share on other sites
  • 0

Just to inform you, I'll go silent for about 2 days because I have an exam at school. I'll get back to this during the weekend

Share this post


Link to post
Share on other sites
  • 0
On 5/1/2019 at 9:48 PM, Base 57 said:

Create a new blank project and import a file from a commercial CD. Then export that file without any other processing. If this also exports noise you may need to contact CbB support.

So I've downloaded an mp3 from here: http://download.publicradio.org/podcast/minnesota/classical/programs/free-downloads/2016/08/19/daily_download_20160819_128.mp3 imported it into Cakewalk and exported to wav in 16 bit 44100 sample rate no dither, and it sounds the same, I even turned up the volume to listen closer but it seems to work fine ( meaby is not so pronounced with classical music but I think there is simply something wrong with my project )

I will try the rest of you rsuggestions now...

Share this post


Link to post
Share on other sites
  • 0
On 5/1/2019 at 6:17 PM, Base 57 said:

Let's try a different approach.

  1.Drag the clip (Output) into the Cakewalk browser. Then open a new blank project and drag the clip (Output) into it.

  2. Open Preferences/File/Audio Data and change the render bit depth to 16.

  3. Right click the clip and Bounce to clip. This will render it as a 16 bit clip.

Now drag the file onto the Windows desktop and play it with Windows media Player.

I did it, and it sounds exactly the same as before, that is the error persists :( .

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...