Jump to content
Grey Allen

Able to create drum map presets - Unable view presets in Drum Map Manager [SOLVED]

Recommended Posts

I'm able to create drum map presets and save them, the file shows up in the designated folder after I've named and saved it. 

1.png.c8a4b8ca9a0a9131c3d8b5bec46aca55.png

3.png.e1a56342df7272ba42806c876e0b9cf4.png\

 

 

 

The problem comes in when I attempt to view/select it in the 'Presets' tab of the Drum Map Manager. None of the drum map files that were saved (nor the ones that come with Cakewalk by default) show up in the dropdown as selectable/clickable options, despite being in the designated folder and the manager being able to save presets without any problem to that folder. What could be the cause of this? 

2.thumb.png.d7c6012bba4db537d41cbc738a2979ec.png

Edited by Grey Allen

Share this post


Link to post
Share on other sites
Posted (edited)

Double-check the entry under Preferences > File > Folder Locations > Drum Maps, just to be sure

Edited by Colin Nicholls

Share this post


Link to post
Share on other sites

Yes the correct entry is specified, I even tested it with a new folder in my documents and it's also able to write the file there. It's able to create the files to the assigned directory they simply don't show up in the preset dropdown

18 minutes ago, Colin Nicholls said:

Double-check the entry under Preferences > File > Folder Locations > Drum Maps, just to be sure

 

Share this post


Link to post
Share on other sites

I attempted to reproduce the problem and couldn't. Even though I didn't save the New Project in which I'd just created and saved the Drum Map preset, when I exited Cakewalk and then re-opened it, created a new project, added a MIDI track and directed it to a new drum map - the preset I'd just created previously was there, along with all the others.

Now, I expected this, of course, but I wanted to make sure.

You're not switching users or anything? Can you run Cakewalk "as Administrator" just to see if it makes a difference?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
39 minutes ago, Colin Nicholls said:

I attempted to reproduce the problem and couldn't. Even though I didn't save the New Project in which I'd just created and saved the Drum Map preset, when I exited Cakewalk and then re-opened it, created a new project, added a MIDI track and directed it to a new drum map - the preset I'd just created previously was there, along with all the others.

Now, I expected this, of course, but I wanted to make sure.

You're not switching users or anything? Can you run Cakewalk "as Administrator" just to see if it makes a difference?

it seems to be very unique problem unfortunately, I've seen other question around asking about the same problem but no solution.  Running as admin doesn't make a difference either But thank you for your help 

Edited by Grey Allen

Share this post


Link to post
Share on other sites

Damn, I hope someone else has some insight on this. It's about now that @scook shows up and lays down some solid knowledge, but he's probably raving out at a Zoom Party right now.

Share this post


Link to post
Share on other sites

Can you check there aren't any filenames with non-ASCII characters in the filenames within your Drum Map directory?

Share this post


Link to post
Share on other sites
4 hours ago, msmcleod said:

Can you check there aren't any filenames with non-ASCII characters in the filenames within your Drum Map directory?

After reading your comment I tried removing all drum maps and only leaving a few  that have ASCII characters in the folder and they still do not show up in the background. 

9 hours ago, Colin Nicholls said:

Damn, I hope someone else has some insight on this. It's about now that @scook shows up and lays down some solid knowledge, but he's probably raving out at a Zoom Party right now.

I didn't even think about that when posting this, completely slipped my mind that the new year starts today haha. Happy New Year fellas!

Share this post


Link to post
Share on other sites
1 hour ago, Grey Allen said:
5 hours ago, msmcleod said:

Can you check there aren't any filenames with non-ASCII characters in the filenames within your Drum Map directory?

After reading your comment I tried removing all drum maps and only leaving a few  that have ASCII characters in the folder and they still do not show up in the background. 

This goes for the path to the drum maps as well. 

Also make sure the folder is not compressed.

Maybe the install and or the drum map path are not in the default locations. If so, it may help to know more about the install.

Share this post


Link to post
Share on other sites
1 hour ago, scook said:

This goes for the path to the drum maps as well. 

Also make sure the folder is not compressed.

Maybe the install and or the drum map path are not in the default locations. If so, it may help to know more about the install.

AAAHHHAAA. COMPRESSION. 

I was wondering what these blue arrows were when I first booted up the new pc. I had no idea it could affect the programs I use. All I had to do to get everything running properly was to disable the compression windows had done automatically. I did this for all Cakewalk related files to be safe, but the Drum Maps were already visible after I disabled compression for only that folder. 

fr1.png.4c4acd6b56f58c66f4c3fdc6a6339957.png

 

Disabling Compression for the Cakewalk files

  1. Hold WINDOWS Key + R to open windows 'run'
  2. type in %appdata% and click ok
  3. Locate your Cakewalk file in the Roaming folder. (C:\Users\<USER>\AppData\Roaming\Cakewalk)
  4. On your Cakewalk folder, Right click -> Properties ->Advanced 
  5. Uncheck 'Compress contents to save disk space'fr2.thumb.png.9c26cc567780ac5238c6a50ef4329289.png

I did this for all relevant Cakewalk folders.

  • C:\Users\<USER>\AppData\Roaming\Cakewalk
  • C:\Program Files\Cakewalk
  • C:\Program Files(x86)\Cakewalk
  • C:\Cakewalk Content

note: you don't need to disable compression for the parent folders your Cakewalk folders. eg, you don't nee to turn off compression for your 'Roaming' folder as well.

 

Thanks for the help @scook @msmcleod @Colon Nicholls 

  • Thanks 1

Share this post


Link to post
Share on other sites

Please edit the OP and add [Solved] to the subject line

 

Compressed folders do not play well with the DAW.

Don't see it very often and it is the source of a lot of confusion when encountered.

 

Glad you got it sorted.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...