Jump to content
Sign in to follow this  
Michael McBroom

Unable to open audio playback device SOLVED

Recommended Posts

I've just run into this puzzler for the first time. When I try to play a file that I had previously been working on, I get the above message. It suggests that the device might be open in another tune -- which it isn't -- and instructs me to contact Support, but I thought I'd check in here first. You know how Cakewalk defaults to stacking up pieces you've previously worked on -- in a queue of sorts, I suppose? Well, I cleared out all the earlier pieces I'd been working on, wondering if that might make a difference.

There's nothing unusual about this piece of music. In fact I had been successfully working on it when I saved it about a month ago. The file contains both MIDI and audio data. For MIDI output I'm using TTS-1. I tried playing a couple of autosaves that were still lingering around and I got the same message with them when I tried playing then. I double checked that something hadn't suddenly gone wrong with Cakewalk, and so I successfully opened and played a file I'd just been working on. To be clear, the file in question opens fine and I can navigate around in it. It just won't playback when I hit the "Play" button.

I checked in Preferences to make sure nothing had changed in my audio preferences. Nothing had changed. The only oddity I've found is the tune shows it to have been developed at 48/16, although I have Cakewalk set to 44.1/16. So I went in to Preferences and changed the sampling rate to 48k. Didn't make a difference.

I don't know even where to begin with this one, so I thought I'd toss it out to the forumind and see what y'all think. Any ideas? If I hit some parameter that I shouldn't have,  it would have had to have been sometime during that last edit, I suppose. Well, except the autosaves, which have different save times/dates also won't playback. I dunno. I'm really stumped on this one.

 

Edited by Michael McBroom

Share this post


Link to post
Share on other sites

The key might be the sample rate. Did you also check you audio interface control panel. You can also look in windows sound settings 

but it’s odd because usually the song still plays but out of pitch and in your case slow 

Edited by John Vere

Share this post


Link to post
Share on other sites

About the sample rate, as I mentioned, changing it had no effect. So I don't think that's it.

I didn't check the audio interface control panel because nothing has changed with it. As I mentioned, I can play back other files, just not that particular one -- or group, including autosaves, as it turns out.

Again, nothing's changed with respect to the system's audio device. If it had, this would have shown up as problems with other CW files, and they don't.

You wrote, "in your case slow" No, it isn't slow -- it isn't playing at all. I get a pop-up with the subject message and advice to check that other songs aren't using the device and to contact CW support.

 

Share this post


Link to post
Share on other sites

So your using ASIO mode. 
when you look at windows sounds it shows your audio interface as the default device 

In cakewalks preferences the audio interface is  checked for all settings under the audio tab there’s no other audio devices 

you don’t have asio4all or magix drivers hanging out 

That other song note is not normally seen but did you shut down and re boot? 

 

 

 

Share this post


Link to post
Share on other sites

Yes to all of the above, but no to ASIO4All or magix. They are not installed on this system. I even rebooted my computer just to have a clean slate when I called up the file in question. Still that same popup. I even went so far as renaming the file and saving it to a new location, just in case something might have been wonky with the last location, which caused CW to build a new folder for it. Same popup.

It's worth noting that, since the last time I successfully worked on this file -- in Cakewalk -- a month ago, I have also worked on literally dozens of other music files and have had zero problems with playback. It's just this one file -- or group, including the autosaves -- that won't play back.

 

Edited by Michael McBroom

Share this post


Link to post
Share on other sites

We’ve all had projects that get corrupted for whatever reason. 
steps you can take

remove all iffy plug ins.Bypassing might work too.
Open in safe mode. 

next is rebuilding a new project 

because you use midi and the Tts1, this is easier that normal. 
just save as midi file and OPEN  it. 
most of you project should be ok. 
now save this as a CWP and make sure to rename 


now back in the dead project save track template for each audio track 

in the new project insert these this should preserve all effects and routing 

now using the browser find the audio folder for the dead project and carefully one by one drag the audio to the respective tracks.  Test playback as you go  

cakewalk converts the audio to the project settings so this will rule out sample miss match 

 

just an extra step would be to save your tts1 settings as a preset I always do this with all my vst’s  

 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

I've already thought of this -- I'm just trying to avoid it. In fact, I have old Cakewalk archives of this tune from years ago that I can resurrect. Again, I was just trying to avoid this. But if worse turns into worst, this will be the path I will take.

 

 

Share this post


Link to post
Share on other sites

Well, I found out what the offender was. It was an audio track that apparently had been recorded at 48k, and since I had CW set to 44.1k, this was a problem. Now, I don't understand why it didn't resolve things when I switched CW over to 48k, but oh well. Anyway, to get the tune to play, I had to delete the audio track. It was an audio recording of a MIDI track that I'd created with my Roland guitar synth, and the reason why I made it was because the Roland's MIDI track would only work when the Roland synth was on, and I wanted portability. But I was able to copy the Roland's track to another MIDI track using TTS-1 as the output device, and problem solved. I think I still liked the Roland's patch sound a bit better, but the differences are small, so I can live with TTS-1's patch.

 

Share this post


Link to post
Share on other sites

Glad you figured it out. But it's a question of how in the heck did a 48hz audio file get into a 44.1hz project? As I said Cakewalk converts all audio to the chosen settings like 44.1/24 And if you recorded it directly into Cakewalk it would follow the settings as well. 

You can easily re record it again, Just send the midi back to the Roland and record the audio in stereo. 

Share this post


Link to post
Share on other sites

Yeah, I know, but it's complicated and I didn't want to weigh this thread down with all the quirky details. Like the fact that the original recording was done in Pro Audio 9 19  years ago. Back then I saved it as a bundle (.bun), which preserved everything, supposedly. I loaded this .bun file into CWbBL and then I recorded the Roland synth track as audio for sake of portability. I did this a few months back, but honestly I don't recall changing the sample setting to 48k. Getting old, I guess. To complicate things even more, I've been working on this tune on my laptop, using an audio interface that has MIDI ports. This current machine, my desktop, has a sound card and no MIDI ports. And I've had mixed luck using USB to MIDI converters, so I just decided not to mess with hooking the Roland up to this machine.

I'm not using my laptop at the moment because it's down for the count in need of some repairs. As it was beginning to fail, I managed to back up all my CW files to a USB flash drive, which is how I got them into my desktop. So it might be a mismatch between the two systems that caused this, even though they're both running the same version of CW. But I haven't had a problem with any other files I copied over, many if not most of which also have audio data. So it's just kinda weird.

I did finally get the audio track reset to 44.1k, but it was a mess. It had dropped over a semitone in pitch and it was slower. So I just deleted it.

Edited by Michael McBroom

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...