Jump to content
Craig Reeves

Cut and paste bug: Cut ignores space designated in selection

Recommended Posts

On 12/21/2020 at 11:18 AM, lapasoa said:

Why don't you use Ripple Edit for that?

There are workarounds, sure, such as just copying and deleting, but the point is that it's a bug.

Edited by Craig Reeves
  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Craig Reeves said:

There are workarounds, sure,

Ripple Edit is not a workaround. It is the solution to the problem you are having. Just be sure to turn it back off after the edit.

  • Like 1

Share this post


Link to post
Share on other sites

Craig, when you did it by Copy + Paste ,you didn't select a track before pasting

When you used cut, you selected track 8 - why? What happens when you don't select a track?

Share this post


Link to post
Share on other sites

This also happens to me occasionally. I work in staff view, and it will paste the notes several measures away, or sometimes not paste at all, though the Edit History shows a paste did occur. I have to shut down and restart when this happens. It is a serious detriment to my workflow. I will try Ripple Editing next time. I never use it otherwise, due to the nature of my workflow, but if it solves the problem it's an acceptable workaround, certainly better than restarting.

Share this post


Link to post
Share on other sites

You'll notice that the "Cut" operation changed the selected area in the tracks after the clips were transferred to the clipboard (ha). Sort of "shrank" the selected area to include just the clips, not the beginning space.

I'm actually surprised that Copy+Paste worked the way it did. It would be nice if "Copy" and "Cut" were consistent.

Is it a bug? Debatable.

An inconsistency? Arguable.

Is Ripple Edit the solution? Not in my opinion. It is, however, another tool in the toolbox that could be used to perform the operation you're trying to do.

Edited by Colin Nicholls
  • Like 1

Share this post


Link to post
Share on other sites

Sometimes I can unselect the extra space that gets selected erroneously, while holding the control key, and then it will paste normally. doesn't always work though. sometimes, after the computer has been running awhile, Cakewalk just seems to get tired or confused. Like me, but not as often.

Share this post


Link to post
Share on other sites
11 hours ago, Bristol_Jonesey said:

Craig, when you did it by Copy + Paste ,you didn't select a track before pasting

When you used cut, you selected track 8 - why? What happens when you don't select a track?

The same thing occurs whether the track is first selected or not.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...