Jump to content
jono grant

Cakewalk hangs after close

Recommended Posts

Does anyone have the problem: Cakewalk sticks around in Task Manager after closing? 

Any reason this would happen? (quite often)

Thanks

JG

Share this post


Link to post
Share on other sites

On my set up the piano icon hangs around for a few seconds after Cakewalk is closed. Always has done.

if is more than that, maybe a dodgy plugin ? Why is it a problem ?

Jerry

Share this post


Link to post
Share on other sites
6 hours ago, jono grant said:

Any reason this would happen?

sometimes it has failed to drop the audio driver; you can force this to happen by power-cycling an external audio device, or for internal to can disable/re-enable it in device manager

/hth

Share this post


Link to post
Share on other sites
On 12/15/2020 at 12:57 AM, jono grant said:

Does anyone have the problem: Cakewalk sticks around in Task Manager after closing? 

Any reason this would happen? (quite often)

Thanks

JG

I can't tell you where it is at, but in the settings there use to be a setting that would allow cakewalk to send data back to "cakewalk servers" for development purposes.

You need to be sure that that is not checked to be active - the result would be that the closing process will try to report back to the "old Gibson server" which of course does not exist!   This will hang due to no IP resolution and cause Cakewalk to hang in the "task manager" (unless you kill the process).

I found this to be quite the pain if you don't know that it is selected (report back to server) since it takes quite a long time to release (disappear in Task Manager ).

I would check that - of course this could have been fixed and no longer a problem, but I believe I have had this happen with in the last year.

Syphus

Share this post


Link to post
Share on other sites

Are you on the latest version? This used to happen to me as well but has gone away. I can close Cakewalk and the piano midi icon is gone instantly now. I found that impressive. It used to always stick around for at least 30 seconds and longer for as long as I can remember. I just noticed this the other day because I closed Cakewalk and then I opened it almost within 10 seconds because I forgot to do something. I was surprised it opened so fast. 

And this for me is on 2 completely different computers/ interfaces so it can't be a system issue. 

Share this post


Link to post
Share on other sites

This can happen if you've got a large amount of plugins, or several plugins with a large amount of parameters (e.g. TH3 / THU / Scheps Omni Channel ).

This has been addressed for the next release.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Syphus said:

I can't tell you where it is at, but in the settings there use to be a setting that would allow cakewalk to send data back to "cakewalk servers" for development purposes.

You need to be sure that that is not checked to be active - the result would be that the closing process will try to report back to the "old Gibson server" which of course does not exist!   This will hang due to no IP resolution and cause Cakewalk to hang in the "task manager" (unless you kill the process).

I found this to be quite the pain if you don't know that it is selected (report back to server) since it takes quite a long time to release (disappear in Task Manager ).

I would check that - of course this could have been fixed and no longer a problem, but I believe I have had this happen with in the last year.

Syphus

This is no longer an issue.

Share this post


Link to post
Share on other sites
3 hours ago, msmcleod said:

This is no longer an issue.

I was not in the position to check at the time  - thanks for the update @msmcleod.    Sorry for the useless info . . .

 

Syphus

Share this post


Link to post
Share on other sites
On 12/18/2020 at 9:55 AM, jono grant said:

Thanks for all this info everyone! I see a new update sitting there, I'll try it out.

Cheers

J

Curious to know if this solved it?

Share this post


Link to post
Share on other sites

This happens 100% of the time on my crashes, which are about once a day?  
I always assumed it was a problem letting go of my MIDIMAN MIDISPORT 8x8 Drivers, and the only solution is to reboot. 

Share this post


Link to post
Share on other sites
2 hours ago, shane said:

This happens 100% of the time on my crashes, which are about once a day?  
I always assumed it was a problem letting go of my MIDIMAN MIDISPORT 8x8 Drivers, and the only solution is to reboot. 

I use the MidiSport 8x8 (the old blue & yellow one), and I don't have issues with it causing CbB to crash not close properly. 

Share this post


Link to post
Share on other sites
On 12/22/2020 at 9:41 AM, Billy86 said:

Curious to know if this solved it?

Since the update I haven't noticed it hang. I haven't had too many projects open yet but so far so good!

J

Share this post


Link to post
Share on other sites
On 12/15/2020 at 12:57 AM, jono grant said:

Does anyone have the problem: Cakewalk sticks around in Task Manager after closing? 

Any reason this would happen? (quite often)

Thanks

JG

This occasionally happens to me as well. Although not as often as it used to.

Share this post


Link to post
Share on other sites

@Noel Borthwick If i remember correctly, this often happened if project contained D-Pro LE for me. (Audio device: UA-101) I'm not using D-Pro LE now so I don't know if it will cause the same problem now.

Edited by HIBI

Share this post


Link to post
Share on other sites

I know I'm late here, but I can make it happen if I open a project with lots of samples that are loading and close the project before they are all loaded. Bang, it will hang. 

Or if the project has a poorly written VST/i that doesn't give up easily!

Share this post


Link to post
Share on other sites

A hang on close can be ccaused by multiple reasons. Capture a dump file and it will reveal the culprit.

For example plugins with thousands of parameters like Waves Omnichannel could previously cause this. Its been addressed in the January release.

Share this post


Link to post
Share on other sites

After closing a project it hangs for some 2 or 3 secondss. It''s normal and depends of VSTs and effects you used in the project.

Edited by lapasoa

Share this post


Link to post
Share on other sites
On 12/26/2020 at 2:36 PM, Noel Borthwick said:

Some drivers don’t terminate and hold the app captive. I’ve not seen this in many years but the some of the old Roland Drivers did this.

Ahh, this might explain why this happens to me after a crash (FA-66 interface). Can't even end it in Task Manager. Sometimes opening another audio prog such as Audacity will clear it, but other times I have to log off in windows and then that clears it.

On a related note, is there anyway to stop CW dumping GB's of files into system error memory dump every time it crashes ? A while back, investigating why my OS HD kept filling up when nothing new had been changed/added for a long time led me to 35GB worth of CW related files in this location, which I guess came from crashes? Apologies if I haven't used quite the right terminology on the location it is dumped to, but it is something like that. Using disk clean-up I can get rid of it, but it would be nice to not have to keep doing it.

Edited by paulo

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...