Jump to content
Tony p

Troubleshooting Midi Controller

Recommended Posts

Hi. For some reason I cannot get my midi controllers to work. I open up any synth, can get sound out of them if i click on the virtual keys with the mouse, but I dont hear any sound when I press the physical keys on my Casio Priva or Behringer midi controller. However they both work with the Addictive Keys standalone program so I know they are being recognized by the PC and are functional. I have the devices checked off in the MIDI Input section in the preferences, I even had them as outputs although that's not what I'm trying to do. 

Dont know if this matters, but I had this sonar on another PC before and they worked then. All authorization should be good as I can use every other feature I've tried and cakewalk command center is installed . What am I missing? 

Thank you!

Share this post


Link to post
Share on other sites

Things to check:

1. Have you got input echo enabled on your midi/audio tracks or instrument track if that's what your using?

2. Check you've not got any surface controllers defined in Preferences that are assigned to these devices

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, msmcleod said:

Things to check:

1. Have you got input echo enabled on your midi/audio tracks or instrument track if that's what your using?

2. Check you've not got any surface controllers defined in Preferences that are assigned to these devices

 

Mark- The echo option was it! I went to playback and recording in preferences and selected "always echo current MIDI track". Do I know what that means? No. But, I'm back in business baby!  Amazing, Thank You.

Share this post


Link to post
Share on other sites

Enabling "always echo current MIDI track" means every  time the track has focus input echo will be enabled. While convenient a better solution is disable "always echo current MIDI track" and manually control input echo. An input echo button is on all track strip headers in the track view, track inspectors and console strips.

Share this post


Link to post
Share on other sites
38 minutes ago, scook said:

Enabling "always echo current MIDI track" means every  time the track has focus input echo will be enabled. While convenient a better solution is disable "always echo current MIDI track" and manually control input echo. An input echo button is on all track strip headers in the track view, track inspectors and console strips.

Scook- Thanks for the information. Why would I bring up a synth and not play it?

Share this post


Link to post
Share on other sites

If you've got complex routing in your project, it can be a pain when a track automatically has it's MIDI echo on.

For example, cases where one synth is controlling another (Jamstix & AD2 spring to mind).

Having the track being echoed can have undesirable results when you want to select the track to adjust something else.

I normally have this option enabled during tracking, but quite often switch it off for more complex mixes.

Share this post


Link to post
Share on other sites
36 minutes ago, Tony p said:

Scook- Thanks for the information. Why would I bring up a synth and not play it?

Generally input echo is used when recording soft synth and monitoring audio through the DAW. Input echo is usually turned off when playing back audio and MIDI clips.

Automatically enabling input echo can have unwanted side effects like MIDI data from one track playing the "wrong" synth. This is because an instrument/MIDI track automatically changes input to Omni if it is set to None when input echo is enabled.

Share this post


Link to post
Share on other sites
On 3/12/2019 at 8:03 PM, scook said:

Generally input echo is used when recording soft synth and monitoring audio through the DAW. Input echo is usually turned off when playing back audio and MIDI clips.

Automatically enabling input echo can have unwanted side effects like MIDI data from one track playing the "wrong" synth. This is because an instrument/MIDI track automatically changes input to Omni if it is set to None when input echo is enabled.

Makes sense. Thank you!

Share this post


Link to post
Share on other sites
On 3/12/2019 at 7:35 PM, msmcleod said:

If you've got complex routing in your project, it can be a pain when a track automatically has it's MIDI echo on.

For example, cases where one synth is controlling another (Jamstix & AD2 spring to mind).

Having the track being echoed can have undesirable results when you want to select the track to adjust something else.

I normally have this option enabled during tracking, but quite often switch it off for more complex mixes.

Right now I'm just using it for soft synths. Nothing that complex yet. But it's good to know, thank you.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×