Jump to content
Sign in to follow this  
sjoens

To Snap or Not To Snap? PRV

Recommended Posts

Lately Snap-To isn't snapping to, in PRV. Shaky hands make it hard to get it right. 

1. Set Snap to 1/4 in both Control Bar and PRV window

2. Slide a note to the nearest 1/4 measure

3. Note slips either side of the measure line (1:01:119 or 1:02:004, etc.)

I'm having to Quantize regularly.

Same with Smart Grid or no Smart Grid.

Intensity is medium to high.

No other options are checked in Preferences.

 

Share this post


Link to post
Share on other sites

Make sure you are set to Snap To, not Snap By. Easy to miss in the PRV because it only shows when you have the resolution pick list open.

Share this post


Link to post
Share on other sites

Definitely Snap-To as I almost never use Snap-By. Easy to miss but 1st thing I usually check when things aren't working as expected.

If no one else is seeing this, I may have a setting altered somewhere. Just don't know what it could be.

Share this post


Link to post
Share on other sites

To have snap always land exactly on the measure set intensity to extreme.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks scook. This may be project specific. I created a new project and it worked properly.

As I understand it, Intensity is how strong it will snap.  Duration (whole, 1/2, 1/4, etc.) tells Snap where to put the note being dragged regardless of Intensity. In this project, Duration and Intensity both seem to have no affect on where the note lands when snapped. In fact, I was getting all kinds of erroneous Snap-To locations dragging different notes around in PRV.

Edited by sjoens

Share this post


Link to post
Share on other sites

Just to be sure - since they're independent, Snap To is set in both the Control Bar Snap module and in PRV itself?   If so, I'd change both to Snap By, then change them back to Snap To, then Save.   

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: Re-read the OP that it can be off the grid either way, so it's not Snap Offset

Another possibility: Snap to Landmarks enabled, and aligning with other MIDI notes/clips...?

Edited by David Baay

Share this post


Link to post
Share on other sites

@SteveC Thanks. I tried it but no change.  The Snap function is completely unchangeable in this project.  BTW, I never use Snap-By unless I'm trouble shooting things like this.

@David Baay  No. I keep things simple and use Snap pretty much default.

 

I think I've narrowed it to just this one project acting goofy as the new project I made worked properly w/o changing any settings.

Come to think of it, Dimension Pro caused the project to crash hard once closing CbB, which may have corrupted the file somehow.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, sjoens said:

I think I've narrowed it to just this one project acting goofy as the new project I made worked properly w/o changing any settings.

Come to think of it, Dimension Pro caused the project to crash hard once closing CbB, which may have corrupted the file somehow.

What if you copy the clips to a new MIDI track?

 

Share this post


Link to post
Share on other sites
Posted (edited)

Neither drag-copying the clips to form a new track nor creating a new track and copy/pasting the clips there improve the situation.

On another note, I still have to minimize or close any open web browsers before opening Sonar/CbB or they simply won't open. Very annoying.

Edited by sjoens

Share this post


Link to post
Share on other sites
On 5/9/2020 at 2:33 AM, sjoens said:

On another note, I still have to minimize or close any open web browsers before opening Sonar/CbB or they simply won't open. Very annoying.

What's the connection between Cakewalk and web browsers?

Share this post


Link to post
Share on other sites

Never figured that one out Steve. Just learned to live with it.

Share this post


Link to post
Share on other sites

Hi, I'd like to say I've had a similar problem to OP! It happens when I record midi notes with midi controller or Virtual Controller, then snap won't work on PRV.
If i want to work with regular notes I'll have to quantize midi content. 

I thought this was a known issue but after reading this thread it seems it could be a bug!

Best regards, 
 

EDIT: It seems the issue only occurs on some projects for me either!

On 5/8/2020 at 12:43 AM, sjoens said:

I think I've narrowed it to just this one project acting goofy as the new project I made worked properly w/o changing any settings.

 

 

Edited by mgustavo

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...