Jump to content
RICHARD HUTCHINS

Tracks playing back through speakers not headphones

Recommended Posts

Hi

Finally got Cakewalk onto my new PC. Hooray!

However....I am using a focusrite scarlet 214 as output. I can record through this fine but when I play back the track it comes through the PC speakers not my headphones which are as usual plugged in to the Focusrite socket. This was how I always did it and had no problems using the headphones, but of course, moving everything to a new PC means starting again with settings. Clues or hints anyone?

Share this post


Link to post
Share on other sites

You should plug your speakers into the new interface as well. You have a great-sounding audio interface and no need to use that onboard chip.

In Cakewalk's Preferences, switch your driver to use the Focusrite ASIO driver.

In Windows settings, select the Focusrite as your audio output.

At this point everything will be output to the Focusrite, you'll get better playback sound all around, and you'll be able to listen through headphones and/or speakers on the Focusrite. The sonic improvement through the speakers might impress you.

  • Like 1

Share this post


Link to post
Share on other sites

I would advise the opposite. Windows sound can and will change the settings set on the Scarlet. For Cakewalk or any DAW use only the Scarlet. Let Windows have your internal sound for its use and leave the Scarlet alone. This means two separate sound systems. Ideally they should not know the other exists.  

Share this post


Link to post
Share on other sites

Sorry chaps, I simply Don't understand

 

All I want is to go back to getting my headphones to work....and then, one day in the future maybe actually write some music! I honestly dont know much about this, except every time I do ANYTHING different I have to start again and ask foe help.

So... how do I get the track to play back through headphones like I used to do in the old days i.e. last week??

Share this post


Link to post
Share on other sites
3 hours ago, RICHARD HUTCHINS said:

Sorry chaps, I simply Don't understand

 

All I want is to go back to getting my headphones to work....and then, one day in the future maybe actually write some music! I honestly dont know much about this, except every time I do ANYTHING different I have to start again and ask foe help.

So... how do I get the track to play back through headphones like I used to do in the old days i.e. last week??

Its actually simple.  Use your Scarlet when using Cakewalk.  Plug in the headphones  to the phone jack of the Scarlet. And there you have it. 

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Starship Krupa said:

In Cakewalk's Preferences, switch your driver to use the Focusrite ASIO driver.

I suspect this is your solution. In preferences, if you select ASIO as your driver mode, CbB can only see the Scarlett at that point (which is highly preferred). If you are getting playback through the onboard chip, you must have a different driver mode running. This is setup via CbB preferences... On a cell here, so can detail later if you cannot find that, but is in preferences, near the top left under the audio section.

  • Thanks 1

Share this post


Link to post
Share on other sites
19 hours ago, RICHARD HUTCHINS said:

. . . when I play back the track it comes through the PC speakers not my headphones which are as usual plugged in to the Focusrite socket.  [snip]  Clues or hints anyone?

Not sure if you tried disabling all but your preferred/default Sound > Playback device.  Not sure, but maybe that will help?

Playback Device Properties.png

Share this post


Link to post
Share on other sites

Hi Guys

Thanks for taking the trouble to reply. I tried these suggestions one by one and also downloaded the latest drivers. Now it works as before; trouble is I'm not sure what I did right, probably a few things!! Each time I do one of these things I learn a bit more so its all good stuff for a newbie like me.

This is the level of competence I command! But anyhow the end result is what counts so thanks again.  

 

Rich

  • Like 1

Share this post


Link to post
Share on other sites

I had the same problem after I loaded the latest driver from Focusrite . . .

 

I fixed it by reinstalling the the driver.  Here is what I suspect happened (this for future reference for those that may have this problem):

The first time i installed the driver, I launched Youtube too soon (more in a minute),  and all my sound for the PC came thru the PC and anything using the ASIO driver was coming out of the Focusrite headphone jack . . .   I did restart the PC - to no avail.

I reinstalled the Driver and let windows do its thing and the driver install seemed to take a bit longer that it did the first time.  I also got more messages as to what was happening from the install (than I did the first go round).

I think I just killed the process some how by launching the Youtube video while it was still "installing"  and perhaps the install did not finish properly.

 

Syphus

Share this post


Link to post
Share on other sites
10 hours ago, John said:

I would advise the opposite. Windows sound can and will change the settings set on the Scarlet. For Cakewalk or any DAW use only the Scarlet. Let Windows have your internal sound for its use and leave the Scarlet alone. This means two separate sound systems. Ideally they should not know the other exists.  

It can, but when Cakewalk loads the ASIO driver, it should take over and load whatever settings you specify. Also, if you go into Windows' sound settings via Control Panel you can set sample rate and bit depth to match what you are using in Cakewalk so that the interface doesn't have to switch.

I like using my Firepod/FP-10 for general Windows playback because it just sounds so good. Also, I don't use "computer speakers," I use one of my pairs of studio monitors.

But whatever works best, and there are many ways to a successful solution.

Share this post


Link to post
Share on other sites

Ok first thanksall  for the help. Now... people often ask me why Cakewalk drives me mad..here's why;

 

All was well last night, after the forum kindly showed me how to put things right.

new focusrite drivers installed,preferences all showed up the drivers, everything worked.Hooray.

 

Today however its a different matter...fired up the PC, ( at first it crashed not sure why which was annoying as it is brand new but we'll leave that for the moment.)

Reboot; Up comes a message saying that there are no outputs... look in preferences and everything has gone, no mention of focusrite no drivers no sound NO NOTHING!! 

 

Am I missing something, what on earth has gone wrong..((honest guv I didn't touch anything...))help please? Meanwhile I am off for a cup of tea and then counting to 10 slowly.

Share this post


Link to post
Share on other sites

I have not checked,  but the version that I have installed (4.63.23.563)  are known to have a bit of a problem.  The newest are 4.63.23.564.  See

The last comment talks about the BSOD....

 

If you are using 463 . . .  see my previous comment in this thread.   Sorry if not totally helpful . . . 

Syphus

 

Share this post


Link to post
Share on other sites

Some of the issues may lie in your Windows Sound Control Panel settings. As mentioned above, setting Windows to use the Realtek as the default device, will make it leave the Scarlett alone. The issue is that for ASIO, only one program can control it, and if it is at a different sample rate than another program wants to use, then it will not play back. On boot, *if* the Scarlett is the default device, Win10 will take control of it, and may assign it (lock it) to some internal playback, which can effectively can "lock it out" on you. The Realtek/Windows combo works well to playback just about everything, you just cannot record decent audio with it.

This is an old post talking about how to set up the Realtek as the Windows default with another Audio Interface available (Saffire and Scarlett can be interchanged). *IF* you have the 1903 version of Win10, you need an extra step to drill into the sound control panel (Sound Settings->Sound Control Panel (in the upper right)). Prior to that "Sound Settings" alone opened the control panel right off.

Share this post


Link to post
Share on other sites
11 hours ago, RICHARD HUTCHINS said:

Reboot; Up comes a message saying that there are no outputs... look in preferences and everything has gone, no mention of focusrite no drivers no sound NO NOTHING!!

Going forward, please be more specific about certain things.

You rebooted and "up comes a message." Is from Windows, Cakewalk, or what? You didn't mention starting Cakewalk.

Previous to this, you said you had everything working, which was great, but at that point you did't tell us what you had selected in Cakewalk's Preferences or Windows Settings or any of that, so I have no way of knowing what configuration worked for you. All I know is what I suggested, but I think you went with something more like @John suggested, which is fine.

After you've nailed a problem it's a good idea to post in the forum thread what your solution was. This has two purposes. First, some other poor sod who has the problem in the future can read it and do what you did and make it work. Second, the poor sod may be you!😄

So, first item of business, can you remember how you had it set up when it was working?

Next, tell us how your audio system is configured now. Start with where everything is plugged in. What kind of speakers do you have and where  are they plugged in? Where are your cans plugged in?

When you go into Windows Settings/System/Sound/Output, what devices are listed in the pulldown?

When you go into Cakewalk Preferences Playback and Recording/Driver Mode, what is that set to? What about Devices?

Back in Windows, Hit  Win-R then type Control Panel into the box and hit Enter. From Control Panel, select Sound. What do you see listed in the Playback tab?

The forum will help you get this to work, mate. It's not a tall order.

 

Share this post


Link to post
Share on other sites

Okay, mea culpa. Basically computers drive me nuts, all I want to do is write songs. But, as you rightly point out, I cant have it both ways, to use a powerful program like Cakewalk I need to take my time and get it sorted instead of going off on a rant every time something goes awry.

Also its not fair to ask help from  forum users who take time out to reply, and then lazily expect to avoid giving the full config info.

In my defence I assumed it would stay fixed once it was sorted but obviously its not that simple. So...deep breath, apologies again for my sloppy attitude, and I am now going to get another cup of tea and slowly read through the replies, and then give a proper breakdown of the problem. Hopefully.

 

Guess you cant have your Cake(walk) and eat it...😉

  • Like 1

Share this post


Link to post
Share on other sites

OK, tea has arrived biscuits eaten. Here we go;

 

I cant remember the error message when the system crashed, I tried looking at the error logs ( screenshot attached) but its way over my head and means nothing. Next time I will write it down instead of cursing.

The screenshot shows the first error message saying no audio in Cakewalk. Preferences show no drivers so the focusrite drivers which I downloaded have simply disappeared. No input drivers, output says 2470W Intel R display audio.

No playback timing master anymore.

Playback and recording shows WASAPI shared.. means nothing to me.

 

In control panel under sounds/playback it shows "speakers realtek not plugged in" See screenshots.

 

Headphones are connected to the Focusrite box. I have no external speakers I used headphones.

 

My next step is to try to reinstall the focusrite drivers again and see what happens. If they go missing once more I will post better details.

 

 

No audio devices and system crash screenshots.PNG

silent buses detected.PNG

sound.PNG

Share this post


Link to post
Share on other sites
16 minutes ago, RICHARD HUTCHINS said:

Playback and recording shows WASAPI shared

Go to preferences/Playback and recording. Switch this to ASIO. Your not taking advantage of your devices driver by running it in anything other than ASIO.

This will then give you access to the ASIO settings in preferences/Device settings.

  • Like 2

Share this post


Link to post
Share on other sites

OK did that. However the problem is that each time I reboot, Cakewalk loses the focusrite drivers, and I have to reinstall them and then they appear again. How do I get Cakewalk to remember the drivers each time it opens?

Share this post


Link to post
Share on other sites
42 minutes ago, RICHARD HUTCHINS said:

OK did that. However the problem is that each time I reboot . . . .

. . . I have to reinstall them . . .

Addendum: . . . Cakewalk loses the focusrite drivers . . .

reboot the computer? or reboot Cakewalk?

 reinstall on the system/PC level? or enable them in Cakewalk?

Addendum: (1) What audio i/o device does Cakewalk see when you reboot [whichever reboot you mean]? (2) Are you using/Do you routinely use that device? (3) If not, have you tried disabling it?

(I ask because I see some device I/Os under Recording that say "Not Plugged In and am wondering if you have another audio device under Playback that it might be defaulting to if not disabled. Just guessing as to possible causes based on my experiences with two resident E-Mu PCI cards and a mobo card/chip. ) 

Edited by MusicMan11712 (aka Dr. Steve)
to add additional diagnostic Qs based on prior device settings screen shots

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...