Jump to content
jim137

Start Lag-a small dialog box about generic ASIO driver then stop SOLVED

Recommended Posts

Posted (edited)

A small dialog box flashes on the screen just since the recent update (2019.07 B79 and the first 2019.07) when I push the space bar to start playback.

it never appeared before.1633154124_CakewalkLowlentencytroublebox.png.8d9f8ad1dab75336f91cfde9ef149c08.png

I have had trouble capturing it; it comes and goes so quickly.

I have to wait until it is done; then push the space bar again.

I bounce around between SoundForge 13.0 B100 and Adobe Audition 2019 constantly get this box:

1134655637_Onetroublemessagebox.png.91d1e9cea7544eb1b0204564367d5872.png

Even though in preferences, I have 'Suspend Audio Engine When Cakewalk is Not in Focus' checked.

I have tried it both checked and unchecked and perceive no difference.

 I am using a RME Multideck II with lastest drivers on Windows 10 1903.

Any suggestions or advice had to correct this?

Anyone else experiencing this?

It is really is stopping the flow of working.

Edited by jim137

Share this post


Link to post
Share on other sites

Some DAWs install a Generic Low Latency Driver. CbB is not one of them.

The Generic Low Latency Driver supplied by Cubase has been know to cause problems,

The Generic Low Latency Driver supplied by Samplitude is a rebadged ASIO4All.

These generic drivers interfere with manufacturer supplied ASIO drivers.

The best solution is remove or rename the generic driver and use the RME driver.

 

Please do not cross post the same thread in multiple areas.

Share this post


Link to post
Share on other sites

Please uninstall the generic ASIO driver. It is a steinberg driver that gets installed by some apps and if you have an older version it crashes many applications.

Here is a thread talking about issues with the same driver.
If there isn't an uninstaller for it try and find the name of the driver DLL then rename the file to something like genericasiodriver.bak
That will stop it loading.

Share this post


Link to post
Share on other sites
Posted (edited)

I have not installed a generic ASIO Driver.

This is the RME Driver.

In preferences when I poke the ASIO Panel the RME ASIO Dialog comes up.

 

The RME is listed in the drivers area

.mmc_2019-08-06_10-51-15.png.f69c9e2fd05f86358cfad3e08f18a8cc.png

Edited by jim137
clarity

Share this post


Link to post
Share on other sites

There have been a few threads reporting the same issue over years. In this past the user reported Cubase was installed on the machine The first message in the OP looks like the Cubase Generic Driver message. It seems strange that this machine only has CbB, SoundForge 13.0 B100 and Adobe Audition 2019 installed. I suppose Magix could have added their Generic Driver to SoundForge (although I do not recall it throwing the Generic Driver dialog) or Audio Audition may have added one to their newer software.

Share this post


Link to post
Share on other sites

I doubt this is the answer.

Both Audition and Soundforge have been in place for months or years time. 

The appearance of the generic dialog box just appeared with 2019.07 the first one and now 2019.07 B79

These are two different problems.

Cakewalk Low lentency trouble box.png

Share this post


Link to post
Share on other sites

So Cubase has never been installed on this machine? CbB does not install any audio drivers.

Share this post


Link to post
Share on other sites

Cubase 10.20 is on the machine.

Cubase was on the machine before the install of 2019.7 and this dialog box never came up.

I have searched the computer and there is no generic ASIO driver listed.

Share this post


Link to post
Share on other sites

May want to check the entries under

HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

and

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ASIO

My guess is the Cubase Generic Low Latency Driver is listed there along with the RME driver. If so, this driver is the problem.

 

Share this post


Link to post
Share on other sites

The Registry information was useful I think.

I went through the procedure of removing the Steinberg\ASIO folder suggested by Noel.

I had to close down 5 programs and reboot and am testing it now.

So far that solves the first problem. Strange that it appeared only after this new build.

This other problem is still there and has been for some time; but I can live with it.

I also get the audio Dropout teal dialog.

1900412853_Onetroublemessagebox.png.c27b2bbaaa957f9f02ffa20ae1ae6da7.png2019-08-06_11-27-01.png.cc751af10ca3e4a92a64482d30c644ca.png

 

Share this post


Link to post
Share on other sites

Use a different driver in SoundForge and Audition.

Share this post


Link to post
Share on other sites
Posted (edited)

Scook work-around appears to be working for problem No. 2.

I wish the preferences dialog worked. 

Suspend Audio.....

Cakewalk_2019-08-06_09-58-53.png.0b05afaa6005f6c89f951fd7ee13ec25.png

Edited by jim137

Share this post


Link to post
Share on other sites

Maybe your AUD.INI is still filled up with all the settings from the Generic ASIO driver.

Try deleting AUD.INI ( from %APPDATA%\Cakewalk\Cakewalk Core\) and startup Cakewalk again, which will re-create it. You'll need to set your sample rate etc again, but it'll refresh all its settings for your RME driver.

If this still doesn't work, you could try re-installing your RME driver, then deleting AUD.INI again.

Share this post


Link to post
Share on other sites

@jim137 you may be confusing two independent issues. The generic driver one has nothing to do with the disconnected device message. There is no way that could be an effect of the 2019.07 release because its environmental.

The latter message is because the RME driver sends device disconnected messages to windows at unexpected times when nothing has actually been disconnected. It happens when simply switching device focus between different programs - likely when the program inits its instance of the RME ASIO driver. I have an RME device and encounter the same issue.

Fortunately in the 2019.07 release we have a way to supress the disconnected device message:
Please look at this help topic. You can now turn off device change notifications and this will suppress that annoying message.

PS: we forgot to include that in the release notes. It will be added soon.

Share this post


Link to post
Share on other sites
2 hours ago, jim137 said:

The Registry information was useful I think.

I went through the procedure of removing the Steinberg\ASIO folder suggested by Noel.

I had to close down 5 programs and reboot and am testing it now.

So far that solves the first problem. Strange that it appeared only after this new build.

This other problem is still there and has been for some time; but I can live with it.

I also get the audio Dropout teal dialog.

1900412853_Onetroublemessagebox.png.c27b2bbaaa957f9f02ffa20ae1ae6da7.png2019-08-06_11-27-01.png.cc751af10ca3e4a92a64482d30c644ca.png

 

BTW I don't recommend deleting that folder personally. Just find the generic asio driver and remove that one. Or contact Steinberg and ask them for instructions. 
Its definitely not something supplied by RME since I don't have that on my system. The generic ASIO driver crashes many programs besides Cakewalk. 

Share this post


Link to post
Share on other sites

I didn't delete; just renamed it \xASIO.

 

Thanks everybody for all the solutions and responses. 

I appreciate all the quick responses and suggestions.

Both problems are solved.

  • Like 1

Share this post


Link to post
Share on other sites

Renaming the entire folder might cause Cubase to malfunction. Its better to rename just the ASIO dll.

And regarding the dropout dialog, that is because the driver requests the host to disconnect. We're simply following instructions :)
RME drivers seem to send out these messages simply by using another app while the host has the ASIO driver open. I get those just by tabbing to a youtube window from Cakewalk. The process of chrome requesting audio focus leads to that.
If you don't want that to happen you can choose not to let the RME device be your default Windows device to force it to be exclusive to the DAW.

Or you can talk to RME and see if they can improve their driver interop :)

Share this post


Link to post
Share on other sites

Unfortunately, Steinberg installs the Generic Low Latency ASIO driver (by default).

This driver can bump your desired ASIO driver out of position.

IOW, If the proper RME ASIO driver was selected in CbB, it may now be "bumped" out of place (leaving the Generic ASIO driver as the selected driver).

 

In the locations scook mentioned above, delete the Generic ASIO driver entry:

  • HKEY_LOCAL_MACHINE\SOFTWARE\ASIO
  • HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ASIO

Once deleted, no application can see/select the Generic ASIO driver.

This works for ANY ASIO driver you don't want to use.

ie:  Many hardware guitar processors, drum modules, and synths now function as an ASIO audio interface.

If you know you never want to use your Helix, AxeFX, GT-1000, TD-50, Montage, etc... as an audio interface, this is a quick/easy solution.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks again to everybody for your help.

Label these two problems solved!

I was flying fast for the rest of the day yesterday; not having to wait and dismiss strange dialog boxes.

I resisted for so long to post my problem and look at how fast it was solved and the amount of input I gained.

Share this post


Link to post
Share on other sites

Please edit the OP and add [Solved] to the subject line.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...