Jump to content
Jesse Jost

[CLOSED] Cakewalk 2019.07 Early Access 1

Recommended Posts

IMPORTANT - PLEASE READ
An Early Access build of Cakewalk by BandLab is now available, and we'd love for you to try it out! As an Early Access build, this is not an official Cakewalk release. If you have not already done so, please be sure to read about the Early Access Program before participating.

Download the Cakewalk 2019.07 Early Access installer  

Please note that an official release will be announced once the Early Access period has ended. 

Thanks in advance for your participation!
The Bakers
 


 

2019.07 brings major usability enhancements, including Comping and Take lane enhancements, Smart Tool customization, Control Bar module alignment and over 100 bug fixes.


Highlights
 

Smart Tool customization
The Smart Tool can be customized in order to disable specific functions and simplify the Smart Tool behavior. The Smart Tool is powerful, but may produce unintended results in certain situations, such as inadvertently isolating clips in Take lanes when clicking the bottom half of clips. If you are not strictly using Take lanes for comping, you may want to disable the comping behavior.

Center Control Bar modules
Control Bar modules can be left-aligned, justified, or centered.
 

Comping and Take lane enhancements
Comping and take management has undergone a massive overhaul for this release with many workflow improvements, optimizations and bug fixes. A few highlights:

  • Freely assemble clips in track lanes either by recording or dragging and dropping from different sources
  • Configure the Smart Tool to optionally turn off comping features while editing audio on lanes and re-enable it when you are ready to start building a comp track


Copy/paste and drag drop enhancements
There have been numerous improvements and bug fixes with selection and copy paste:

  • Inter project drag and drop and copy paste support for take lanes and automation lanes
  • Improved drag drop preview to visually represent the final data
  • Full support for drag and drop of take lanes between tracks. 
  • New lanes are auto appended to tracks when dropping / pasting clips from multiple lanes
  • Lane order is retained when dropping / pasting clips from multiple lanes
  • Improved support for pasting track and clip envelopes in lanes
     

Help Module content for clips
The Help module is a window that dynamically shows contextual help for various UI elements in Cakewalk. Simply point to a UI element for a brief moment, and the Help module displays a short description of the UI element. In addition to a brief description of the clip type, the Help Module also lists common Smart Tool gestures that are supported by each unique clip type.
 

Selection markers in time ruler
The time ruler now shows draggable markers at either end of the time selection range. You can modify the start or end of the selection by dragging these markers or move the entire time selection by dragging the selection range bar.
 

Loop and Punch marker enhancements
The time ruler now uses more intuitive mouse cursors for selection, loop, punch and marker drag bars and handles. The mouse cursor shows a letter to indicate which marker will be modified before you actually click the marker: S (Selection), L (Loop), P (Punch), and M (Marker). 

 

Fixes & Enhancements
 

Stability

  • Crash when pasting automation
  • Crash on opening project after closing another
  • Improved notification handling
  • Crash copying and pasting bus automation
  • Projects using elastique audio crash when playing if audio is missing


Optimizations

  • Screensets in projects with high track counts load faster
  • Multi threaded UI updates for notifications
  • Undo redo of take Lanes is faster


UI

  • Bounced Track fails to appear with user created Lens
  • Changing Lens and reopening CbB changes "None" unexpectedly
  • Full Screen Mode only expands across multiple monitors
  • Changing screensets slow with large number of tracks


Selection/Tools

  • CTRL Selecting clip doesn't work if the clip is partially selected as a result of a time selection
  • CTRL clicking a clip during playback creates a clip envelope instead of selecting the clip
  • Select Tool cannot select Comp Clip


Control Bar

  • Ability to center Control Bar modules
  • Control Bar Export Module can lose gripper
  • Export CB module is cropped when CB is locked and justified
  • Resetting the Control Bar doesn't unlock module order
  • Draw issue with Control Bar when floating after justify


Take Lanes/Comping

  • Copy paste in take lanes can delete source data
  • Editing clips in lanes can lead to un-editable clip envelopes
  • Copying and pasting clips from multiple take lanes is not possible
  • Loop recording in Comp mode with lanes closed causes unexpected cropping of clips
  • Some projects could prevent clip envelopes from being edited
  • Now Time jumps in playback when isolating clips in Take lanes during playback
  • Copy/Paste does not work as expected in Take Lanes
  • CTRL Selecting neighboring clip does no't work immediately after isolating a clip region in a take lane
  • Copying data from non-adjacent lanes pastes to adjacent lanes
  • Dragging MIDI clips from Browser goes to lane 1
  • Pasting multiple clips in lanes to a track with single lane does not refresh UI
  • Drag drop of multiple audio files from browser to take lanes not supported
  • Pasting Multiple clips in lanes to bottom lanes cause clips to collapse to single lane
  • Double clicking take lane in clips view does not select lane
  • Clips in lanes cannot drag from one track to different lanes in another track
  • Dragging takes to a new track skips over populated lanes
  • Drag drop between lanes doesn't work properly when hidden tracks present
  • Clips can be moved from their original take lane on CTRL drag and drop
  • Copying clips in Lanes with envelopes gives unexpected results.
  • Clip can no longer be selected after undo of drag
  • Pasting clips in lanes to new project does not refresh UI correctly.
  • Undo of paste of multiple lanes in new project does not behave as expected
  • Comp Clip Draws unexpectedly after crop
  • Dragging clips on MIDI take lanes to create overlaps does not crop data
  • Dragging group of clips to new track deletes existing clip on destination track
  • Pasting multiple layers to last lane in a track creates extra lanes
  • Comp clip remains visible after dragging outside of the Clips View
  • "Delete Muted Takes" renamed "Delete Muted Clips"
  • Lane order changes pasting to new project
  • Lanes order of order when dragging to create a new track
  • When creating clip/automation lanes, Take lane initially appears grayed out
  • Shift click does not work on comp clip when take lanes open
  • Bouncing to clip causes clip to change lanes unexpectedly
  • Duplicated tracks with lanes inverts order
  • Redoing a loop recording in comp record mode fails to restore recorded clips state


Automation

  • Clip envelope in lanes cannot be edited after save/reopen of project
  • Reassigning Automation Envelopes closes lanes unexpectedly
  • Automation from multiple lanes pastes to a single lane
  • Pasting Multiple Automation envelopes to track with fewer lanes has unexpected result
  • Dragging clips from Browser to Lanes removes automation data
  • Drag Copy to new project does not copy automation
  • Automation lanes not created after recording track automation
  • Automation lanes are copied out of order, and not all copied if automation lanes are expanded in destination project
  • Some projects are saved with clip envelopes assigned to incorrect lanes
  • Setting Edit filter to clip automation on a lane doesn't work properly when multiple clips present 
  • Clip envelopes on lanes don't respect edit filter state when loading projects
  • Clip envelopes lose visibility on take lanes when toggling show take lanes
  • Duplicate Track does not persist Automation lane state
  • When pasting automation then showing lanes, Edit Filter is not set correctly with FX automation
  • Redo not populating automation lanes correctly.
  • Edit Filter in automation lanes not behaving as expected after paste
  • Edit Filter not behaving as expected with auto track zoom
  • Pasting take and automation lanes simultaneously has unexpected results.


Track View

  • Clips now have details in Help Module
  • Aim Assist remains visible after dragging outside of Clips View
  • Show Snap Assist when dragging clips to a different project
  • Clip name moves up a pixel when right-edge crop reaches it
  • Muted clips cause crossfades when overlapping non-muted clips
  • Dragging Punch range in time ruler before measure 1 shrinks range unexpectedly


Staff View

  • Mouse cursor jumps to different monitor when clicking in Staff View time ruler
  • Notes may not appear in Staff View in some projects


General fixes

  • V-Vocal Clips do not drag copy as expected
  • Missing Help Module text for several views/contexts
  • Help Module Support for ProChannel EQ Fly Out
  • Notifications only appear on primary monitor
  • Several "importing" messages displayed when closing project after previewing MP3 files in browser
  • Some projects can fail to cut/copy on track
  • Delete Track can delete unintended tracks
  • Browser drag preview image now aligned to bottom right of cursor
  • Track View key bindings are not listed in Preferences dialog when using Basic lens
  • Dragging clips between projects can fail to create a new track in destination project
  • Keyboard shortcut for Show/Hide Clip Properties does not hide
  • Mouse cursor flickers between arrow and ibeam when moving mouse over automation lanes
  • External Insert can be dragged from Browser to clip
  • Dragging Punch range in time ruler doesn't update time rulers in other views


Note about localization
Please be aware that any new strings introduced in this build have not yet been localized. 

  • Like 12
  • Thanks 6

Share this post


Link to post
Share on other sites

Looks awesome!

What does "Please be aware that any new strings introduced in this build have not yet been localized. " mean?

Looking forward to putting this update through the paces.

  • Thanks 1

Share this post


Link to post
Share on other sites
25 minutes ago, Resonant Serpent said:

What does "Please be aware that any new strings introduced in this build have not yet been localized. " mean?

It means new text in the program will appear in US English regardless of the language setting.

For info about Localization see https://en.wikipedia.org/wiki/Language_localisation

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

This takes my breath away!!! Wow, I am just overwhelmed!

This is really the best "Sonar" (CbB) ever! Thanks a lot, Bakers!

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

I'd love to participate but I don't quite understand the procedure and what it will involve.

 

I really don't want to have to re-install CbB to do this. How is this going to coincide with "normal" updates via BA? Am I to be forced to re-install to get back an authorized update?

 

I could use and would really appreciate a better understanding.

 

Thanks!

 

Share this post


Link to post
Share on other sites
9 minutes ago, Keni said:

I'd love to participate but I don't quite understand the procedure and what it will involve.

 

I really don't want to have to re-install CbB to do this. How is this going to coincide with "normal" updates via BA? Am I to be forced to re-install to get back an authorized update?

 

I could use and would really appreciate a better understanding.

 

Thanks!

 

To participate, all you need to do is grab the link in the first post, and download/install. It requires the most recent (2019.05) update to be currently installed first. If you need to roll back to 2019.05, you then run the uninstaller for Cakewalk, then reinstall from BandLab Assistant. 

  • Thanks 1

Share this post


Link to post
Share on other sites
5 minutes ago, Jon Sasor said:

To participate, all you need to do is grab the link in the first post, and download/install.

 

@Jon Sasor

After I have installed this version of CbB, this Early Release version, when the final public release version comes out, will I have to uninstall the Early Release to be able to install the public release? Or will I be able to just install as is?

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
1 minute ago, Grem said:

 

@Jon Sasor

After I have installed this version of CbB, this Early Release version, when the final public release version comes out, will I have to uninstall the Early Release to be able to install the public release? Or will I be able to just install as is?

If a newer build than the Early Access one is released, you'll see the "an update is available!" Notification in CbB and you can download and install from BandLab Assistant without having to uninstall Early Access.

  • Thanks 1
  • Great Idea 2

Share this post


Link to post
Share on other sites

Here is a reminder of how BA works

  • If you are running the most recent PRODUCTION release, BA downloads and runs the small update only installer
  • If you are running any other release and there is an update available, BA downloads and runs the full CbB installer (just like it did the first time CbB was installed on your machine).

So, if you are running the Early Access Program release and a never version goes production, BA will download the full production release. If the EAP release goes production, there is nothing for EAP users to do.

Share this post


Link to post
Share on other sites

This is described in the abot the early access program topic:

Cakewalk will present an "Update Available" notification when the final release version becomes available, if Notifications are enabled

  • Like 1

Share this post


Link to post
Share on other sites

Unfortunately, the buzz, or motorboat situation with the play transport is still happening.

I am using a Focusrite 18i8 2nd gen with a i7 8700, 16 gig, all drivers updated. Buzz has been with me for about 6 months now, I think.

Share this post


Link to post
Share on other sites
41 minutes ago, parboo12 said:

Unfortunately, the buzz, or motorboat situation with the play transport is still happening.

I am using a Focusrite 18i8 2nd gen with a i7 8700, 16 gig, all drivers updated. Buzz has been with me for about 6 months now, I think.

I have not encountered this personally. Do you have any more specifics to reproduce the problem @parboo12?

Share this post


Link to post
Share on other sites
1 hour ago, parboo12 said:

Unfortunately, the buzz, or motorboat situation with the play transport is still happening.

I am using a Focusrite 18i8 2nd gen with a i7 8700, 16 gig, all drivers updated. Buzz has been with me for about 6 months now, I think.

 

24 minutes ago, Noel Borthwick said:

I have not encountered this personally. Do you have any more specifics to reproduce the problem @parboo12?

FWIW, I get this on my 6i6 and my 18i20 - both are 1st gen, although it doesn't happen often enough to cause me an issue. More often than not stopping & starting the transport fixes it, and if that doesn't work restarting the audio engine always fixes it.

A couple of things I've noticed:

  1. It happens more often on lower ASIO buffer settings
  2. I've never seen it happen when the 6i6 / 18i20 ASIO drivers are wrapped up with ASIOLink, and CbB is using the ASIOLink drivers.

This leads me to believe that it's either a timing issue and/or something to do with the order of the calls to the ASIO driver.

 

Share this post


Link to post
Share on other sites

There's been several threads in the forum about this.  I have nothing that would reproduce this, but if I'm using Cakewalk for an hour or two I consider myself lucky if it hasn't happened. It happens when you hit Play or Record. It just stops and buzzes until you hit Play again or Reset. It can be very annoying. Especially if the volume is up. Thanks for the info about the wrapper, Mark. I am hoping Cakewalk will fix it before I have to resort to other things!

Sometimes its bad enough and so frequent that I have to restart Cakewalk. I haven't seen it happen with anything else, but to be fair, I use Cakewalk most of the time. Hope you guys can figure it out!

Thanks.

Share this post


Link to post
Share on other sites
Posted (edited)
38 minutes ago, parboo12 said:

There's been several threads in the forum about this.  I have nothing that would reproduce this, but if I'm using Cakewalk for an hour or two I consider myself lucky if it hasn't happened. It happens when you hit Play or Record. It just stops and buzzes until you hit Play again or Reset. It can be very annoying. Especially if the volume is up. Thanks for the info about the wrapper, Mark. I am hoping Cakewalk will fix it before I have to resort to other things!

Sometimes its bad enough and so frequent that I have to restart Cakewalk. I haven't seen it happen with anything else, but to be fair, I use Cakewalk most of the time. Hope you guys can figure it out!

Thanks.

I've just spent the last hour messing around with various settings.

One post on the Avid forum suggested it was Intel Turbo Boost causing it, but disabling it in the BIOS makes no difference for me.

I can usually make this happen reliably by quickly stopping/starting the transport repeatedly. It'll happen around 1 out of 5 times doing this when my usual ASIO buffer setting of 64. When it's set to 32, I get it 2 out of 3 times. Obviously in normal use, it's a lot less frequent than this - I quite often use a buffer setting of 32 for recording piano, and I can go several hours with it happening only once or twice in normal use.

However, I failed to get the motor-boating with a buffer of 128 or higher.

So I think the answer is to use a larger ASIO buffer, and if necessary use the PDC button when tracking. If you really need to use a lower buffer, then just accept the buzz might come along now and again.

[Edit] - It's worth mentioning I've only ever heard of this happening with the Scarlett interfaces. I certainly don't get this with any of my other interfaces.

Edited by msmcleod

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Jon Sasor said:

To participate, all you need to do is grab the link in the first post, and download/install. It requires the most recent (2019.05) update to be currently installed first. If you need to roll back to 2019.05, you then run the uninstaller for Cakewalk, then reinstall from BandLab Assistant. 

Thanks Jon...

 

Is it a must to roll back? This is where I stopped earlier. If I must re-install to roll back so that it updates the version correctly, it's more than I want to do...

Edit:

I see another post after this I responded to.... It will either stay as is until a newer update is available, or if the release is the same as the early release, it will be fine until the next NEW update at which time it will have to download the full package as opposed to the smaller update-only package...

I think I'm gonna wait this one out for a while as it seems a little "clunky" to me at this point and in need of some changes to how this works. It was easy to do using CCC in the old days, but this sounds difficult.

 

If I install this early release my program will not show the correct info for versioning and then if I continue to do so it will never have this info corrected?

 

I guess I'll practice one of my weak points and remain patient?

 

Edited by Keni

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×