Jump to content

Control Surface Qcon G2 (2nd Extender)

Recommended Posts

Greetings ALL,

I've been using this unit plus an EXT (extender) for about a year now and they work great. I just picked up the 2nd Ext G2 and for some reason it won't connect to Sonar. It shows up in Control Surfaces as "Mackie Control XT-2" but in midi devices there are 3 inputs for the controllers and only 2 for the output and I'm assuming this is why it's not working like the other two.

Any ideas of how to get around this? (and I did have the 3rd one checked during setup before I took the pic)


Edited by dahjah

Share this post

Link to post
Share on other sites

@dahjah -  The first thing to do is make sure you're running MIDI in MME mode in Cakewalk.  

1.  Start Cakewalk with no project loaded.
2.  Go to Preferences, and look at the the driver mode within MIDI -> Playback and Recording.  
3.  If it's set to UWP, is set to MME, restart Cakewalk and set up your MIDI devices/control surfaces again.

If this doesn't work, the issue here is either with Windows or the ICON QCON Ext drivers.

Using multiple USB based MIDI devices of the same type can confuse Windows. Cakewalk will only show the second ICON QCON Ext MIDI device if it's available in Windows, so if Windows isn't registering it as a separate device, this could be the issue.

If the issue persists, you probably want to start with a clean slate, both with Windows and Cakewalk.

1. Unplug all of your ICON QCON G2 devices.
2. Uninstall any ICON QCON G2 drivers.
3. Go to Device Manager (press windows key + X, then press M), and make sure "Show hidden devices" is checked under the View menu.
4. Open the "Sound, video and game controllers" section and delete any ICON QCON G2 drivers.
5. Reboot your PC.
6. Open up Device Manager and confirm there are no ICON QCON G2 drivers present.
7. Shut down your PC.
8. Decide which USB ports you'll be using for your ICON QCON devices. You want to use the same ports every time for each device to avoid this situation in the future.
9. Plug in your ICON QCON devices, and switch on your PC.
10. Go through any steps needed to install any drivers.

1.  Within Windows Explorer, go to %APPDATA%\Cakewalk\Cakewalk Core, and rename:
              - TTSSeq.ini to TTSSeq.old
              - ctrlsurface.dat to ctrlsurface.old
2.  Start Cakewalk with no project loaded.
3.  Go to Preferences, and ensure the driver mode is set to "MME" within MIDI -> Playback and Recording.
4.  Close preferences, and start a new a blank project.
5.  Go to Preferences, add your MIDI devices, and set up your control surfaces again.

Moving forward:
1.  Always use the same USB ports for your ICON QCON devices.
2.  Ensure the ICON QCON devices are plugged in before you start your PC.  This will help to ensure that they are given the same MIDI device index every time.

If this doesn't help,  Icon support is probably your first port of call.  Explain to them that your second G2 EXT MIDI output isn't being seen by Windows. Hopefully they'll be able to offer a solution.

Another solution might be to connect the second ICON QCON G2 Ext to your PC using a USB hub... this might make it look different enough to Windows to allow it to appear.

  • Like 1

Share this post

Link to post
Share on other sites

Excellent, thank you very much got them all working now. It was set to MME, once switched to UWP the 3rd one showed up. I think that's reverse of your instruction but either way it's working 💖

  • Like 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...