Jump to content
  • 0
DSL

setting a default write midi channel

Question

Hi Friends,

I'm currently editing a midi track in CbB. The track happens to be set to channel 6, to match the external synth, but every time I add a note it is writing the new note as channel 1 and I have to keep changing the note's data using the edit tool. I can't see how to change the default write setting to match the track channel. Please can someone tell me how to do this?

Thanks

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Posted (edited)

Hi John,

I did that but it still insists on assigning  each new note I write to channel 1, so I have to keep correcting it. Do you think it's maybe a bug then?

Dave

midi issue.PNG

Edited by DSL

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

@DSL

It looks like you changed the arpeggiator settings.

The track settings is in the left window. Under FX you have those three settings, Channel, Bank, Program, that currently is set to none. Change C-none to channel 6.

I think...i haven't touched the daw for quite a while now. Makes me unsure of things.

Edited by Kurre
correction

Share this post


Link to post
Share on other sites
  • 0
35 minutes ago, Kurre said:

It looks like you changed the arpeggiator settings.

Interesting.  I gave up using the arpeggiator because it seems to do non-documented things with MIDI under-the-hood in a way that conflicts with some of my other workflows. 

The arpeggiator in the image doesn't seem to be in use.  @DSL if you are trying to use the Inspector-based Arpeggiator to drive external synth, please write more about what you are doing. 

Note to self: Possibly add this to the list of reasons to have more documentation for under-the-hood [hidden] MIDI data flow.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Kurre said:

@DSL

It looks like you changed the arpeggiator settings.

The track settings is in the left window. Under FX you have those three settings, Channel, Bank, Program, that currently is set to none. Change C-none to channel 6.

I think...i haven't touched the daw for quite a while now. Makes me unsure of things.

@Kurre

I tried that, made no difference. Oh well, I'm only writing one note at a time, I need to edit anyway so...

Share this post


Link to post
Share on other sites
  • 0

Since tracks can hold all 16 channels, adding notes by hand always defaults to 1.

The actual channel used may be forced by setting the channel drop down. When set to a value other than None, all the notes in the track play on the designated channel. 

The channel drop down also sets the channel property for all the notes in the track when saved as a MIDI file.

If the actual channel property in the notes matters in the project, after editing, select the track (or the notes to set) and use the Event Inspector to change all the notes at one time.

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, scook said:

Since tracks can hold all 16 channels, adding notes by hand always defaults to 1.

The actual channel used may be forced by setting the channel drop down. When set to a value other than None, all the notes in the track play on the designated channel. 

The channel drop down also sets the channel property for all the notes in the track when saved as a MIDI file.

If the actual channel property in the notes matters in the project, after editing, select the track (or the notes to set) and use the Event Inspector to change all the notes at one time.

I never thought of that; it probably wouldn't have occurred to me since I always designate each midi track a unique channel. Thanks for reassuring me that the track will save to only one channel as a midi file, since I regularly swap files with other users. Thanks for your help 👍

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

What I see is you have the track inspector channel dialogue set to none. I'm not sure what setting a channel in the avanced midi settings does because you can select more than one channel there. But definatly the track inspector sets the channel for the midi events which will be reflected in the event list and when your save the midi file to share.  

630552889_midiissue.thumb.PNG.a647f74c3ccb17b52593a5f05ff1509a.thumb.png.be1c24855f29de49514d470b2bf1e362.png

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 0

What I do is in Cakewalk.ini file, I set RechannelMIDI=1.

This can be done in Preferences(Advanced) | Initialisation File.   (Option: RechannelMIDI, Value: 1)

Now, whenever I bounce MIDI clips, The MIDI Channels of all events in the resultant clips change to match the channel you have given the MIDI track the MIDI clips are in.

In my MIDI projects,  I have 16 MIDI tracks each with their MIDI channels set accordingly.  When I do Select all then bounce to clips, all MIDI channels in all MIDI tracks change to match the MIDI channel of their respective tracks.

To make this easier, I have bound “A” to select all and “B” to Bounce to Clips.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...