Jump to content
  • 0
Onegin

Audio drops out during recording!

Question

Posted (edited)

Hey everyone, so I'm just transitioning from a dawless setup so please bare with my ignorance. My audio is dropping out during recording, the audio will record fine for the first 10-15 minutes or so, then it drops out and I'm left with this high pitched noise and nothing else, even though I can still hear the clean audio coming through my headphones that are connect to my audio interface.

Here are the details;

I'm using the latest version of Cakewalk (though I'm having this same issue in Ableton)

My audio interface is a Focusrite Scarlett 18i20

The audio is coming from my eurorack modular system which is connected to my Yamaha Mixer MG10XU, the mixer output is fed into channels 1 & 2 on the Focusrite.

I have the latest Focusrite control installed, and my settings in Cakewalk (and Ableton) are set as Focusrite USB ASIO Input as I read it was best to use ASIO as opposed to the other options.

Sampling rate is set at 44100

Buffer size 256 samples

ASIO Reported Latencies: (including buffer and hardware)

Input: 12.4 msec. 546 samples

Output: 12.4 msec. 546 samples

Total Roundtrip 24.8 msec. 1092 samples

I can't imagine it is my PC because it has 64gb ram, 8gb video card, intel Core i9 processor etc etc. I have tried everything I can think of or find to fix the issue and I just can't seem to resolve it. I make ambient soundscapes mostly and mostly those are quite long recordings, I absolutely need to be able to do full recordings and with the audio dropping out after 10-15 minutes it puts me in a bad situation.

Any insight or suggestions would be greatly appreciated. Being that it is happening in both Cakewalk and Ableton I'm guessing it is likely an issue with either the audio interface, or with the settings somewhere, but really have no idea. I just don't understand why the sound is coming through the headphones attached to the audio interface crystal clear even after the sound drops out in the recording. Anyway, thank you for your time & consideration.

Edited by Onegin

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Hi Onegin and welcome to the Cakewalk forums.

Have you tried raising your buffer setting to 512?

Kind regards,

tecknot

Share this post


Link to post
Share on other sites
  • 0

One thing you might want to try is to download the beta drivers for the scarlet range.

The release notes speciality mentions Cakewalk by Bandlab

http://beta.focusrite.com

I have a PC configured as per signature and I do not experience dropouts while recording.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

This sounds like a power management issue more than anything else to me. Go into your Power Profile settings and make sure selectively suspend USB is disabled and it's all set up for high performance.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Have you tried recording the tracks clean to be mixed afterwards and render when done? 

The dropouts could be due to CPU overload from effects that are being used when recording 15mins of non-stop recording - especially once that consume a lot of memory. 

Share this post


Link to post
Share on other sites
  • 0

 I think @Promidi has nialed it. There seems to be some issues with that interface reported in other threads here due to the drivers. 

That set up is more than capable of handling large projects. 256 buffer is all I've ever used for years now. 

Share this post


Link to post
Share on other sites
  • 0

FWIW I use the 18i20 and have no issues with it at all.  I normally record at a buffer size of 64.

+1 to both @Promidi & @Lord Tim 's suggestions.  

The beta drivers have been much more reliable for me (  I was getting occasional BSOD's when changing buffer size in the official ones ). 

Turning off the USB power suspend / ensuring you're running in High Performance mode is a must. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
17 hours ago, Onegin said:

Buffer size 256 samples

ASIO Reported Latencies: (including buffer and hardware)

Input: 12.4 msec. 546 samples

Output: 12.4 msec. 546 samples

Total Roundtrip 24.8 msec. 1092 samples

That's indicating a ridiculous amount of reported hardware latency - almost certainly the driver is misreporting. I'm not sure how it would have  bearing on the issue since it shouldn't come into play until recording stops, but I'd be curious to know if other Scarlett users are seeing the same, and what the actual round-trip latency is as measured by a tool like CEntrance ASIO Latency Checker or by checking the position of re-recorded audio with record compensation disabled.

EDIT: Seems the original Latency Checker page has been removed, but you can still download the utility via this link:

https://centrance.com/driverfolder/CE_LTU_37.zip

Edited by David Baay
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

647575222_Screenshot2022-03-16034851.png.0044902b88678d5822153e6a105d17ba.png

This is what I'm seeing, so it seems fairly consistent.

I'm using the release drivers for my 18i20 and they've been rock solid for me, but you guys have got me curious about the beta drivers now...!

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, Lord Tim said:

This is what I'm seeing, so it seems fairly consistent.

I linked the CEntrance utility to my post in case you want to check the actual RTL - you just need to patch an Out to an In to create a loopback path for it to measure.

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, David Baay said:

I linked the CEntrance utility to my post in case you want to check the actual RTL - you just need to patch an Out to an In to create a loopback path for it to measure.

I meant consistent with what @Onegin was seeing, but I'm curious to see what the true RTL is now you mention it - I'll grab that when I get a breather.  :)

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
12 minutes ago, Lord Tim said:

I meant consistent with what @Onegin was seeing.

Yeah, i understood that. it's just weird. I guess you have a big negative Manual Offset entered in Record Latency Adjustment to get accurate record compensation...? Or possibly you've never noticed it's over-compensating?

If not, you'll want to set the Manual Offset = CEntrance Measured - CbB Reported RTL

The delta should be consistent at all buffer sizes; if not, that would be further evidence of a driver issue. 

Edited by David Baay

Share this post


Link to post
Share on other sites
  • 0

I'm honestly not really noticing anything off performance-wise with this interface at all. I'll go down to 64, like Mark uses, if I want to make sure things feel snappy in real-time with amp sims or if I'm playing in fast drums or something with a fairly tight attack, but even 256 is fine for general "get the ideas into the machine" settings, and it gives me a bit of CPU headroom for mixing, so I tend to leave it there most of the time. Considering the speed of some of the ridiculous stuff I do, I'd certainly notice if the latency was weird! :/ 

Share this post


Link to post
Share on other sites
  • 0

I'm sure that reported number is wrong. So you won't hear/feel more than is typical when input monitoring, but CbB will use the reported input latency to compensate the audio position when recording stops, and will end up over-compensating so playback will be early. Also this can potentially cut off the attack of the first note if you start recording from time zero or use punch-in. As much recording as you do, I would think this would have become evident at some point unless you already have your Manual Offset dialed in and just forgot about it. .

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...