Jump to content
tleaustin

Can't get virtual instruments to record

Recommended Posts

Total newbie here. I'm just trying to get the virtual instruments packaged with the new Cakewalk to record, such as Drum Kit 1. I open a new project, select Basic. I select "Insert" then "Soft Synth" and Drums, and SI-Drum Kit. This adds  a track and assigns a default midi port. I can bring up the kit, select a sample pattern and loop it. I hear it in my headphones, and I see sound bars in the drum and master mix channels. I arm the drum track to record, then hit the main record button (set to overwrite).  There is an active sound bar in the drum track and I hear the drums, but I do not see any sound patterns on the track itself, and there is nothing after I hit the stop button and attempt the play button.

Is there some setting I'm missing? I've looked at the midi port settings, tried some variations with the other soft synths such as strings. The default is the Virtual Controller assigned to Midi Omni. I've tried setting this specifically to the SI-Drum Kit 1,  Midi Omni, but still nothing is recorded.

I'm running on an HP laptop, 16 GB RAM, Windows 8.1, new Cakewalk installation a few days ago. Thanks for any ideas to get me out of the ditch!

Share this post


Link to post
Share on other sites

There are a variety of ways to enter MIDI data. Many use a real MIDI keyboard but CbB has a virtual controller which uses the PC keyboard or touch screen. Most virtual instruments work the same and Studio Instruments are no exception.

  • Add the instrument to a project
  • Set the input to your controller, enabled the record and input echo buttons on the track
  • Play a few notes on the controller to confirm the synth makes sound (some load a default preset, some require the user to load a preset).  Try different presets.
  • Start record in the transport.
  • Cakewalk will start recording the MIDI data from the controller.
  • Stop the transport and turn of the record and input echo buttons.

Without a real controller, it may be easier to enter MIDI data using a different method. Either by step recording or one of the other views: the step sequencer, piano roll view and staff view. Or use existing MIDI loops.

The Studio instruments include MIDI loops. Instead of loading the MIDI loops in the pattern grid pads, drag them to the track.

It is possible to play the MIDI loops in the pattern grid using controller to send MIDI notes 7 through 11.  This is in the documentation for the plug-in in the "Using the MIDI Patterns" section. To open the help, hit the F1 key when the plug-in UI has focus.

May want to check out the videos in the tutorial section of this forum too.

Share this post


Link to post
Share on other sites

Dragging the sample MIDI drum loops directly to the drum kit track works, that is, without recording them. I don't see how to make them loop, but I can copy a bunch of iterations and that works for now. I'll use the virtual kit like a metronome and add some synth string samples to practice changes on real instruments before I start composing.  I kinda have tutorial fatigue, at some point you have to jump in and run into some problems. 

I'll look into Using MIDI Patterns, it will make more sense now. Thanks for the post, very helpful.

Share this post


Link to post
Share on other sites
2 minutes ago, tleaustin said:

I don't see how to make them loop, but I can copy a bunch of iterations and that works for now

If the clips have rounded edges like the clips in SI-Drums, click-drag the edge of the clip to roll out copies of the loop. To make loops out of regular MIDI clips, select the clip and type CTRL+L

Here is more info on groove clips.

Share this post


Link to post
Share on other sites
Posted (edited)

Doesn't look like anybody answered the initial question? I can't get my virtual instruments to record either? I can hear the drum, but when I record, it does not record?

I've got it set up just like the "Creative Sauce" you tube channel says to do and I can't get it to record at all...?

 

Edited by TimAmyJo
  • Like 1

Share this post


Link to post
Share on other sites

TimAmyJo. The question was answered. Virtual instruments don't record. You must supply MIDI data in the track associated with the instrument. See scook's reply.

 

Share this post


Link to post
Share on other sites
7 hours ago, TimAmyJo said:

Doesn't look like anybody answered the initial question? I can't get my virtual instruments to record either? I can hear the drum, but when I record, it does not record?

I've got it set up just like the "Creative Sauce" you tube channel says to do and I can't get it to record at all...?

 

Is this a permutation of this thread?

 

Share this post


Link to post
Share on other sites

If there are no other tracks try selecting all midi for input. On a singular midi track you should be able to record midi but you won't hear it. You will see the recorded representations of it. 

You should see midi in the instrument track when you record it. Do you see midi?  I suspect you are hearing the loop preview and not recording midi or hearing it through the virtual instrument. When dragging a loop from a drum program it's easy to think it is playing in the track because the drum program is also locked to the tempo and might be playing at the same time.

I would bet you aren't getting the midi to the track for whatever reason. I've never used the QWERTY method so I can't comment there. Do you have another way to connect something that might give you midi? Most keyboards no matter how cheap had a midi out or usb.

Share this post


Link to post
Share on other sites

Starise, I think TinyAmyJo is doing the same as the OP.  Open up the drum GUI, hit record, then mouse-click on the drums in the kit in the GUI and expect it to record the activity as MIDI events in the track.

  • Like 1

Share this post


Link to post
Share on other sites

I Have the same problem. If I try to add a track an pick out the SI Drums they aren't listed, just cakewalk TTS1 and Mt Power drumkit...none of the virtual instruments.

If I drag the SI Drums into the newly created miditrack, I can open the kit and play them and hear them, but I can't record them and I can't access them on the keyboard by using Alt and 0. It's driving me mad. I can use the MT power kit ..but no effects etc AND..I cant use the TT1 kit....BUT...no fx etc.

Share this post


Link to post
Share on other sites

If Studio Instruments are listed with the FX plug-ins, this is a scanning error.

Often this is corrected by running a Reset from the VST Setting in preferences.

I am not sure from the description if the tracks are getting setup properly. Try using the Add menu (see the "To create instrument tracks" section) until you are comfortable with how Cakewalk routes data.

 

Share this post


Link to post
Share on other sites

Robert Stevens send a screenshot. Include the track(s) with the SI Drum kit, and the track inspector. (Press I to toggle it visible/invisible.) then only can we begin to see what is wrong.

 

Share this post


Link to post
Share on other sites

@Luis Pedro CarreroHow are you "playing" the drums?

1) Do you have an interface and are using a keyboard or some other MIDI controller. Or your PC keyboard?

2) Or do you open the GUI and click on the drums with your mouse?

 

Share this post


Link to post
Share on other sites
22 hours ago, Nigel Mackay said:

@Luis Pedro CarreroHow are you "playing" the drums?

1) Do you have an interface and are using a keyboard or some other MIDI controller. Or your PC keyboard?

2) Or do you open the GUI and click on the drums with your mouse?

 

The 2nd. What can I do step by step to fix this?

Share this post


Link to post
Share on other sites

What @scook said.

To get started:

Have a MIDI track routed to the drums.

And then one of these:

1) Open the Piano Roll View  in the MIDI track, start recording, click on the correct note for each drum.

2) Select the MIDI track, open the PC keyboard as a MIDI input (Alt-0), start recording, press the correct keys on the keyboard for each drum.

3) In the MIDI track's PRV, write all the correct notes at the correct times to get the beat track you want.

Do one drum at a time - kick, snare, hihat, ... - which makes it easier to remember which note to use.

If you are going to record a few times to get all the drumbeats in, remember to set record mode to Sound on Sound.

Most types of music need drums, and unfortunately, doing a drum track is not a quick fix.

Also, go to the Tutorial section, do a search for beginner and watch all those YouTube videos. The great thing is you can run Cakewalk at the same time, pause the video, and do what you have just been shown. Just remember, it doesn't have to be the exact same instrument as the video, it is mostly concepts and techniques which are being taught.

Share this post


Link to post
Share on other sites

And also, please read the whole topic from top to bottom before adding your question. You are the 3rd person to ask the same question on this page. You are the 3rd person getting exactly the same answers. The very first answer on this page by @scook is the answer.

Share this post


Link to post
Share on other sites
15 hours ago, Nigel Mackay said:

And also, please read the whole topic from top to bottom before adding your question. You are the 3rd person to ask the same question on this page. You are the 3rd person getting exactly the same answers. The very first answer on this page by @scook is the answer.

Funny when people take for granted that there is something "to fix" when they don´t get the results they expect. 🙄

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...