Jump to content

Commit arrangement loses first midi note


Recommended Posts

I haven't used the Arranger Track for a few months but I don't remember seeing this issue before.

I find I can easily reproduce it with these steps in a new project:
- insert midi track
- add a few notes, make sure the first on starts at 1:01:000
- create an arranger section for the first few measures
- add the section to an arrangement
- Commit Arrangement to Project
- the first note seems to disappear every time -- if it starts right on the first beat, if I shove it over a bit, it's fine

Can anyone please verify that this is not something in my configuration?

UPDATE: taking a closer look at this I see that when the arrangement gets committed, every midi event gets moved one tick earlier. So I guess events at 1:01:000 have nowhere to go,


Edited by musekamp
more info
Link to comment
Share on other sites

1 hour ago, bdickens said:

If you give yourself one or two measures of count in, that won't happen.

Thanks for the suggestion! I made a section of the count in and kept it as the first part of my arrangement and nothing got lost.

Yes, then I nudged everything one tick later. I know 1 tick isn't much but I feel better with all the events back where they were originally :)

Link to comment
Share on other sites

  • 3 weeks later...

Thanks for looking into this. Here's the before and after project files. Using the current version of Cakewalk.

(Sorry I PMed you the files before I realized I could just attach them here.)

Here's what the event list looks like before and after:

CommitArrangement-after.cwp CommitArrangement-before.cwp

Edited by musekamp
add version
Link to comment
Share on other sites

@msmcleod It looks like this might be pilot error after all.

After a tip from @Heinz Hupfer in the question thread I see that this seems to be related to my overlap threshold setting.

Not sure how I should have it set but I'll have to read up on the Arranger enhancements that I ignored the first time around!


Edited by musekamp
Link to comment
Share on other sites

Ok, tracked down the issue - if "Select Events with Sections" is turned off in the select module,  commit arrangement doesn't work properly - this is the cause of everything being off by 1 tick.

I'll fix the commit arrangement command for the next release to ensure this is switched on for the duration of the commit command, but in the meantime, please ensure this is switched on before committing an arrangement:


  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...