Jump to content
Ryan Hodel

Sudden Slow Down In Performance

Recommended Posts

I've been using Cakewalk for about two months now. I've got a Focusrite 6i6 interface and my computer has an i7 with 24G of RAM with a solid state hard drive. Things were going ok (I mean, I was having a fair amount of crashes, but for a free DAW; it made me diligent about saving) until today. I was recording a guitar part, stepped away, and when I came back everything was SLOW. This is NOT a latency issue. For stability reasons I have my buffer set to 512 and just monitor directly through the interface. No, now what happens is when I hit the space bar to stop play, for example, it takes a full 4 or 5 seconds for the cursor to reset to the start spot. During this time the DAW is frozen. Then is goes back to playing like usual. The whole program just seems to have gone into slow motion. I tried reinstalling, to no avail. I am at the verge of tears. If anyone has any suggestions I am all ears. Also, if I didn't provide enough details, please ask. I'm so frustrated right now I'm probably not being very eloquent.
thanks,

Ryan 

  • Like 1

Share this post


Link to post
Share on other sites

Have had similar issues before with some projects but haven't had the problem since changing a number of things. There are 2 things which worked for me depending on the projects complexity. One was to make sure I had the right USB driver for the 6i6. It turned out I had two drivers. One was the original Focusrite one and the other one was a Microsoft released one (called Microsoft Focusrite USB driver) or something like that which came in with a Win 10 update. Look in device manager and see what you have. Once the Microsoft one was deleted and I restarted the PC then all was fine with the offending projects. So Cbb may have been using the wrong driver for the 6i6 or getting confused? I am unsure what was happening but all I know is that it sorted a load of issues for me, including that slowing down.  Also make sure you have the correct driver for the 6i6. They were made as a 1st generation and a 2nd generation sound card and it is best to have the correct driver installed for the generation you have. Have a look at the Focusrite site to determine which generation sound card you have then check top make sure you have the correct USB driver for that generation.

The second thing which worked when audio behaves oddly with the 6i6 was to have a look at the ASIO control panel for the soundcard. I have my buffers set in CBb to 512 all the time, same as you. In CBb go to Edit>Preferences>Audio>Driver settings and click on the ASIO panel button. This will open your Focusrite Control panel. If it doesn't then there is your problem (wrong driver!). If the Focusrite panel opens then go to settings and change the buffers there. Try a few different settings. 5ms works most of the time for me but sometimes I have to change it to 7ms or even 10ms on very complex projects. See which works best for you or if it makes a difference at all. You may have to close the project and reopen it to notice any beneficial effects of doing this. See if any of these things help and let us know.

 

 

ASIO Panel.jpg

  • Like 1

Share this post


Link to post
Share on other sites

FWIW I've got the 1st gen 6i6. 

It works fine for me with a buffer size of 64 (1.5ms), and for very light projects I can go to a buffer size of 32. This is on an old 3rd gen i5 at 3.4Ghz with 16Gb of RAM.

I've not experienced any slowdown or crashes for several years, with the exception of the old Melodyne crashing issue (which had a workaround to avoid it).

On an i7 with 24Gb of RAM, you should easily be able to run at an ASIO buffer of at least 128, or 256 if you've got hundreds of plugins.

Are you using any "lookahead" plugins in your project (e.g. linear phase plugins) ? These sorts of plugins are designed for mixing only, not for recording. Using them will introduce a fair amount of latency (especially with a large buffer size) as they have to read in "x" number of buffers ahead of time to process. This may explain the slowdown.

Another possible cause could be bad video drivers, which could explain both the slowdown and the crashes.

Another possibility could be bad memory sticks, which I've personally experienced - and it's a nightmare to diagnose. Even mismatched memory sticks can cause crashes (e.g. different makes or different speeds).

 

  • Like 2

Share this post


Link to post
Share on other sites
10 hours ago, Ryan Hodel said:

I was recording a guitar part, stepped away, and when I came back everything was SLOW

Could indicate Windows went into sleep mode.

My experience has been (with any software) is if im not using for more than 5 minutes, shut it down.

  • Like 3

Share this post


Link to post
Share on other sites

Thank you for the responses. I appreciate you guys taking the time.

sealesb, 

I checked in my Device Manager and under Sound, Video and Game Controllers were two Focusrite drivers, one named Focusrite USB Audio and the other Focusrite USB Midi. Both listed Driver Provider as Focusrite. Under Audio Inputs and Outputs, there were two entries labels, identically, Focusrite USB (Focusrite USB Audio). Those listed their driver provider as Microsoft; my heart leapt! Could this be the answer? I disabled both of those drivers and restarted. No dice. Were these the right things to check? Is there another place to look? When that issue popped up for you, you said it was a result of a Windows update. Did it occur right after the update? That is one of the things I'm so frustrated by, I hadn't updated anything or changed any settings prior to this issue. (By the way, Chuck E Baby, in an effort to make my system as stable as possible, I have my computer set to never go to sleep, I even went so far as to turn off all of Window's system noises (dings, beeps, et al.)) I've also messed around with different ASIO settings, so I'm getting the right dialog box but those changes don't seem to have any effect.

msmcleod, 

I went through to make sure there weren't any mixing plugins active and didn't find any. I did have several instances of Melodyne running, but in my initial attempts to solve the problem, I archived all of those tracks.

I'm going to continue struggling with this today, so if any of you can recommend another place to look for the driver issue, I'm all ears. Or if you have any other ideas at all. Thank you again for taking the time to respond, it was very kind of all of you.

Thanks, 

Ryan

  • Like 1

Share this post


Link to post
Share on other sites

Well having a Focusrite USB driver and a Microsoft certainly didn't help at our end. You are looking in the right place. Getting rid of the Microsoft one (permanently) had an immediate effect. Make sure it doesn't reload when you reboot. Disabling it might not work as it may not remove the registry entries, deleting it completely might. As far as I can recall it did not happen right after the Microsoft update. It just crept in over time and was traced back to that extra Microsoft USB driver after a lot of investigating on our behalf. The Focusrite midi driver is fine so you can leave that alone. If you go to this website, the guy does a great piece of free software for permanently removing USB devices from a PC. I used that to remove the Microsoft Focusrite USB driver permanently. It might not be your problem but at least you can rule it out as an issue. https://www.uwe-sieber.de/

Note that we have had to reinstall the complete Focusrite setup a few times over the years. So uninstall the Focusrite control panel, that should remove the USB driver also but check it is gone. Then reboot and reinstall the lot again. Open CBb and set up ASIO.

Another thing worth trying, and I see someone (msmcleod) has mentioned read  ahead plugins above also, is to open the project, do not hit the play button but hit the big FX button in the control bar to switch off global FX. Then save the project (or make a copy by "saving as" using a different name), close down CBb, reboot and reopen it. I say reboot because it is the best way to make sure all the plugins are no longer using RAM. Open the copy of the project and play it. That way no FX will be used from the start until you re-enable them. If the song does not slow down then the issue lies with a plugin somewhere. Melodyne does weird things with us and always has. If you use it then render the clip immediately so the plugin is no longer running. Do that for all the instances of Melodyne which are running. We found this beneficial also in that it stopped certain projects becoming corrupted on a regular basis. So use Melodyne, bounce to clip and then move on is the way we work these days. There are loads of other things which may cause weird audio issues. I just remembered we had a problem with the audio drivers for our Nvidia graphics cards also. Disabling them sorted it. I have no idea why these should interfere with CBb but they did, especially after updating the OS. So we keep them off our systems now. We have had Nvidia graphics drivers cause issues also. Trying a different one usually sorted the problem.

What storage capacity has your solid state hard drive got by the way?

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Chuck E Baby said:

Could indicate Windows went into sleep mode.

My experience has been (with any software) is if im not using for more than 5 minutes, shut it down.

Windows is notorious for not coming out of hibernation/sleep properly. The quickest way to check this is save your work and reboot the machine. *If* that resolves it, start digging into the power options you have set. Be aware there is more than just "never sleep"... in the "advanced settings" section (via change advanced power settings) there are things like "USB selective suspend," etc. Be sure to walk through each of those if a reboot fixes the issue.

  • Like 3

Share this post


Link to post
Share on other sites

Some studios disable bluetooth and wi-fi also when working with a DAW. I can't find the article now but it convinced me to get in the habit of switching them off when using CBb. Known as Airplane mode on Win 10. I have no idea if it is helping in any way but it is so easy to switch on and off as needed.

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, mettelus said:

Windows is notorious for not coming out of hibernation/sleep properly. The quickest way to check this is save your work and reboot the machine. *If* that resolves it, start digging into the power options you have set. Be aware there is more than just "never sleep"... in the "advanced settings" section (via change advanced power settings) there are things like "USB selective suspend," etc. Be sure to walk through each of those if a reboot fixes the issue.

I always disable hibernation on my PC's, which also disables hybrid sleep too:

pic_disp.php?id=39257&width=350

For those who don't know the difference:

  • Sleep -  Put's everything into a kind of standby mode, using a trickle of power to keep the machine on and the memory contents alive. If you're on battery though, it'll eventually die.
  • Hibernate - Dumps your current memory state to disk, and powers off the machine. When you restart, the memory state is restored from disk and you're back to where you were before hibernating. On Windows 10 machines, the default for powering off is actually to hibernate - not turn off. Restart actually does a full reboot. 
  • Hybrid Sleep - does both. It dumps your current memory state to disk AND keeps your hardware in a standby mode. It's much quicker to power back onfrom this mode, and if you get a power outage, it acts as if you've done a standard hibernate.

Some USB hardware goes through a kind of restart when it "recovers" from sleep or hibernate (bear in mind that the USB hardware has its own internal memory, which Window's can't save when you hibernate). On wake up, the devices state is then different from what the Windows driver thinks it should be, and is the likely cause of issues with coming out of hibernation/sleep.

Hibernate isn't all bad though. I'll quite often re-enable it on my laptop if I'm going to be using on battery for extended periods. Laptops will automatically hibernate when the batter is low, so at least if the battery dies I've not lost my work.

  • Like 1

Share this post


Link to post
Share on other sites

OK, there's a lot here to go over and, again, thanks for your responses.

Real quick:

sealesb, I'm a little wary about permanently removing devices that I don't completely understand. Is there a way to test what the impact will be? That's why I started with simply disabling them. And, I'll be trying the FX thing, I hadn't thought of that.

mettelus, I actually did go through the advanced menu for the USB Suspend, etc. You're completely right, those changes are important and actually solved an issue I was having when I initially installed Cakewalk.

msmcleod, I didn't realize you could do that through command line. Is that a faster way to do it or is it more thorough?


Ryan 

Share this post


Link to post
Share on other sites

sealesb,  

One other quick question: you can just bounce to clip a track with Melodyne in it and then delete the Melodyne plugin from that track? That sounds ideal, I just didn't know you could do that. I basically never mess with the Melodyne once I have it set the way I want. Is it that simple, or do I need to freeze the track as well. Sorry, I know this is a basic question but I only started using Melodyne with Cakewalk so I really don't know much about it.

Ryan

 

Share this post


Link to post
Share on other sites

When using Melodyne as a Region FX, the clip should be rendered using the "Render FX Region" option under Melodyne in the Region FX menu either from the track view or clip context menu.

  • Like 1

Share this post


Link to post
Share on other sites

Melodyne is a clip effect of you are using it via region effects so there is nothing to delete if you bounce to clip. Freezing the entire track will also disable the plugin but it is a non destructive option unlike bounce to clip.

With the latest update and I'd you are running the latest version of Melodyne your should see greater stability do it may not be necessary to freeze. I doubt your issue is related to Melodyne fwiw.

Are you seeing this issue even after restarting and is it only on one of your projects? If so can you send us a link to download it?

  • Like 1

Share this post


Link to post
Share on other sites

Re Melodyne, scook is right. You can do it that way or if Melodyne is just sitting on a clip as FX then you can right click that clip and select "bounce to clip". That means you get a clip with Melodyne rendered into it and the little FX button in the top right hand corner of the clip will no longer be there.

Your other question about removing devices. I do not know a way offhand of determining in advance what effect removing a device will have. All I know is that if you plug the device some time later and are connected to the internet at the time, then Windows will go off and find the drivers for it.

  • Like 1

Share this post


Link to post
Share on other sites

scook and sealesb,
 

Thank you for the tip on Melodyne. That's going to be useful going forward regardless. 

Noel Borthwick, 

I agree with you that Melodyne is probably not the cause of my woes. The issue remains persistent  after numerous restarts, setting changes and even a reinstallation. Unfortunately, this is literally the first project I've created using Cakewalk. I've been working on it for about a month and a half. I'd be happy to share anything I can with you, provided you don't tell me I'm a shit songwriter; I know. ;)  
Just tell me what I need to do.

Ryan

Share this post


Link to post
Share on other sites

One other small detail, I've no idea if it's relevant. I mentioned that while the song is playing if I hit the space bar, to stop playback, it takes nearly 5 full seconds to reset (playback stops immediately). If, on the other hand, I simply use the cursor and select a previous spot in the song and click on it while the song is playing, it jumps back to whatever spot I've selected and begins playing back seamlessly. Like I said, not sure if that matters. 

I really am very grateful for all of the support I've received. You guys are great. 

Ryan

Share this post


Link to post
Share on other sites

Just in case anyone is still checking this thread:

An odd thing happened. As the software was still semi-functional, I decided to export the stems for use in another DAW. I was about half way through this slow process and suddenly Cakewalk came back to life. It was being the slow DAW I had gotten used to over the last couple of days and POW! I was literally in the middle of exporting WAV files and it just started working normally again. Needless to say I am both grateful and wary about trusting it going forward, but for now...

Noel, if you are still interested in following up on this, please let me know. I am very happy it's working now, but like I said, I'm not exactly confident in it's performance going forward.

Thanks to all who responded previously, I do appreciate it.

Ryan 

Share this post


Link to post
Share on other sites
1 hour ago, Ryan Hodel said:

It was being the slow DAW I had gotten used to over the last couple of days and POW! I was literally in the middle of exporting WAV files and it just started working normally again.

Sounds like something is chewing up resources while Cakewalk is being used. I would look at my Anti Virus first. Make an exception for Cakewalk and it relative files (I do the whole Cakewalk Core folder).

On ‎5‎/‎19‎/‎2019 at 4:32 PM, Ryan Hodel said:

One other quick question: you can just bounce to clip a track with Melodyne in it and then delete the Melodyne plugin from that track?

THIS is the way I use Region FX.

Good luck.

  • Like 1

Share this post


Link to post
Share on other sites

Do you have a lot of tracks with automation write enable set in the project?
Also if you go back to a prev version of the project does the issue come back?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...