Jump to content
fret_man

Wave V13 is now available

Recommended Posts

18 minutes ago, Pollux said:

It's cheaper to upgrade to Diamond than to get the WUP for the remaining ones

16 minutes ago, simon said:

^^^ yes definitely check for upgrade prices before/if you decide to WUP.  It's often much much cheaper.

This is great advice! Never thought of doing this. Thanks!

Share this post


Link to post
Share on other sites

I still hope that one day they (Waves) dispose of their cumbersome shell (seems not in v13)! As long as they keep their plugins shellized I will stay Waves free (the handfull plugins that I have are almost never used)!

Share this post


Link to post
Share on other sites

@Pollux @simon so if I have the SSL bundle v12 and were to upgrade to Studio Classics (which includes the stuff in the SSL bundle), I would have v13 licenses for all of the products (including the v12 ones I had originally), right?

Does this make sense? I'm not fully awake yet lol

Share this post


Link to post
Share on other sites
2 hours ago, abacab said:

Should. But Windows 11 compatible?

I think it is marketing speak, unless Windows 11 broke the VST3 standard (which we would all be in deep trouble) it isn't like WAVES plugins are highly dependent on a specific version of the OS.   It is more like scare tatics to make us question if we need to upgrade for fear of incompatibilty.  

This isn't like MAC where "native" M1 upgrades are related to coding changes.

Share this post


Link to post
Share on other sites
2 hours ago, aidan o driscoll said:

I assume all our v12, v11 waves plugs keep working forever

...and v10 and v9.    🤞

Share this post


Link to post
Share on other sites
32 minutes ago, Luc said:

@Pollux @simon so if I have the SSL bundle v12 and were to upgrade to Studio Classics (which includes the stuff in the SSL bundle), I would have v13 licenses for all of the products (including the v12 ones I had originally), right?

Does this make sense? I'm not fully awake yet lol

yes - of course your 'old SSL bundle' would be surrendered as part of the upgrade but as you say Studio Classics would give you them all back again as V13 with a years WUP thrown in.

Also make sure you get a price from everyplugin.com for anything Waves related.  Don't buy direct :)

There is an option to generate a 'code' to give  to the 'local dealer'

choose 'customize upgrade' and click the 'buying from your local dealer'  link

 

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
1 minute ago, simon said:

yes - of course your 'old SSL bundle' would be surrendered as part of the upgrade but as you say Studio Classics would give you them all back again as V13 with a years WUP thrown in.

Also make sure you get a price from everyplugin.com for anything Waves related.  Don't buy direct :)

There is an option to generate a 'code' to give  to the 'local dealer'

choose 'customize upgrade' and click the 'buying from your local dealer'  link

Awesome! Thanks! 😀

Share this post


Link to post
Share on other sites
47 minutes ago, marled said:

I still hope that one day they (Waves) dispose of their cumbersome shell (seems not in v13)! As long as they keep their plugins shellized I will stay Waves free (the handfull plugins that I have are almost never used)!

They have so many plugins I guess that works for them.

Share this post


Link to post
Share on other sites
2 hours ago, simon said:

^^^ yes definitely check for upgrade prices before/if you decide to WUP.  It's often much much cheaper.

Until you get to where I am, after doing that for several version updates, my only upgrade option left is Mercury and that ain't happening.

Share this post


Link to post
Share on other sites
1 hour ago, Brian Walton said:

I think it is marketing speak, unless Windows 11 broke the VST3 standard (which we would all be in deep trouble) it isn't like WAVES plugins are highly dependent on a specific version of the OS.   It is more like scare tatics to make us question if we need to upgrade for fear of incompatibilty.

According to Waves, on their Facebook, they "don't know" if other versions with with Windows 11. What a crock...

  • Haha 1

Share this post


Link to post
Share on other sites
19 minutes ago, RSMcGuitar said:

Until you get to where I am, after doing that for several version updates, my only upgrade option left is Mercury and that ain't happening.

yep......eventually you run out of upgrades ....first world problem of course :)

 

  • Haha 3

Share this post


Link to post
Share on other sites
13 minutes ago, RSMcGuitar said:

they "don't know" if other versions with with Windows 11. What a crock...

That's just typical of software development QA. They probably have a suite of tests that they have run for the latest version and haven't run for the older ones because

  • it takes resources  and effort
  • even if there are problems they won't fix older versions anyway

But, in practical terms: quite likely older versions are ok

  • Like 2

Share this post


Link to post
Share on other sites
59 minutes ago, Eusebio Rufian-Zilbermann said:

But, in practical terms: quite likely older versions are ok

But, also in practical terms, they definitely know if they work or not and are lying when they say they don't know.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, RSMcGuitar said:

Until you get to where I am, after doing that for several version updates, my only upgrade option left is Mercury and that ain't happening.

Years ago I had a rag tag smattering of various Waves plugins from different $29 specials. At some point I inquired with Every Plug-in. He was able to put together a custom price that got me to Mercury at a price that made me jump. I would never have imagined previously that I’d get Mercury.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Eusebio Rufian-Zilbermann said:

That's just typical of software development QA. They probably have a suite of tests that they have run for the latest version and haven't run for the older ones because

  • it takes resources  and effort
  • even if there are problems they won't fix older versions anyway

But, in practical terms: quite likely older versions are ok

Waves has discovered that releasing new versions generates WUP purchases, so regardless of the real need we are now seeing (and will continue to see) version updates on a regular basis.

  • Like 1

Share this post


Link to post
Share on other sites

Got all those bundles I never used and never will. Not even going to register my Abbey Road Collection. Wock that Woop. 

  • Great Idea 1
  • Haha 1
  • Sad 1

Share this post


Link to post
Share on other sites
2 hours ago, Fleer said:

Got all those bundles I never used and never will. Not even going to register my Abbey Road Collection. Wock that Woop. 

Anything particular you'd be looking for in exchange for the serial? 🙃

  • Great Idea 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...